summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2018-06-27 11:15:30 +0200
committerStephane Desneux <stephane.desneux@iot.bzh>2018-06-28 22:06:47 +0200
commitd4f8551e2e951b1c492dac287755197d125a31a1 (patch)
treec089ffa6450538856f323da7fc5615a837096cc9
parent53ca1e6c3b241c2b7c9eef7de2c3bf7a26df11d7 (diff)
meta-audio-4a-framework: align on eel with latest components revisions
This bump is based on recipes coming for eel branch (revision e029270): In 4A layer, we now have: * 4a-softmixer: SRCREV = "731c21e80ba45339b7dd9b8eae63accd3597d281" * 4a-hal-unicens: SRCREV = "${AGL_APP_REVISION}" * agl-service-audio-4a: SRCREV = "${AGL_APP_REVISION}" * 4a-hal-generic: SRCREV = "8142c7ed42167dff7e526952f91909d679453251" * 4a-mixer: SRCREV = "${AGL_APP_REVISION}" * 4a-alsa-core: SRCREV = "${AGL_APP_REVISION}" Change-Id: Ib5708e9551f0646e0206deac8795f3b09f5a0569 Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
-rw-r--r--meta-audio-4a-framework/conf/include/agl-audio-4a-framework.inc17
-rw-r--r--meta-audio-4a-framework/recipes-core/packagegroups/packagegroup-agl-audio.bb3
-rw-r--r--meta-audio-4a-framework/recipes-multimedia/4a-hal-community/4a-hal-community_git.bb23
-rw-r--r--meta-audio-4a-framework/recipes-multimedia/4a-hal-config/4a-hal-config.bb5
-rw-r--r--meta-audio-4a-framework/recipes-multimedia/4a-hal-generic/4a-hal-generic_git.bb9
-rw-r--r--meta-audio-4a-framework/recipes-multimedia/4a-hal-reference/4a-hal-reference_git.bb28
-rw-r--r--meta-audio-4a-framework/recipes-multimedia/4a-mixer/4a-mixer_git.bb25
-rw-r--r--meta-audio-4a-framework/recipes-multimedia/4a-softmixer/4a-softmixer_git.bb9
-rw-r--r--meta-audio-4a-framework/recipes-multimedia/agl-service-audio-4a/agl-service-audio-4a_git.bb8
-rw-r--r--templates/feature/agl-audio-4a-framework/50_local.conf.inc16
10 files changed, 60 insertions, 83 deletions
diff --git a/meta-audio-4a-framework/conf/include/agl-audio-4a-framework.inc b/meta-audio-4a-framework/conf/include/agl-audio-4a-framework.inc
new file mode 100644
index 00000000..491f6d2a
--- /dev/null
+++ b/meta-audio-4a-framework/conf/include/agl-audio-4a-framework.inc
@@ -0,0 +1,17 @@
+# In order to enable the audio-4a-framework features ,
+# enables the following line:
+#
+DISTRO_FEATURES_append = " agl-audio-4a-framework "
+
+# asound.conf is provided by the 4a-hal-config (and not by asound.state)
+#VIRTUAL-RUNTIME_alsa-state = "4a-hal-config"
+VIRTUAL_RUNTIME_alsa-state = ""
+# additionally there is a bug in alsa-utils-alsactl where it pulls in alsa-state directly
+RRECOMMENDS_pn-alsa-utils-alsactl = "VIRTUAL-RUNTIME_alsa-state"
+
+# why should a config package have -dev ... I'll leave that answer to you.
+PACKAGES_pn-alsa-state_remove = "alsa-state-dev"
+PACKAGES_pn-alsa-state_remove = "alsa-states-dev"
+PACKAGES_pn-alsa-state = "alsa-state alsa-states"
+
+PREFERRED_PROVIDER_virtual/mixer ?= "4a-mixer"
diff --git a/meta-audio-4a-framework/recipes-core/packagegroups/packagegroup-agl-audio.bb b/meta-audio-4a-framework/recipes-core/packagegroups/packagegroup-agl-audio.bb
index bb2aaa18..aecfd824 100644
--- a/meta-audio-4a-framework/recipes-core/packagegroups/packagegroup-agl-audio.bb
+++ b/meta-audio-4a-framework/recipes-core/packagegroups/packagegroup-agl-audio.bb
@@ -10,10 +10,11 @@ PACKAGES = "\
RDEPENDS_${PN} += "\
4a-alsa-core \
- 4a-hal-reference \
agl-service-audio-4a \
VIRTUAL-RUNTIME_alsa-state \
agl-service-unicens \
4a-hal-unicens \
bluez-alsa \
+ 4a-softmixer \
+ 4a-hal-generic \
"
diff --git a/meta-audio-4a-framework/recipes-multimedia/4a-hal-community/4a-hal-community_git.bb b/meta-audio-4a-framework/recipes-multimedia/4a-hal-community/4a-hal-community_git.bb
deleted file mode 100644
index 80bd6be8..00000000
--- a/meta-audio-4a-framework/recipes-multimedia/4a-hal-community/4a-hal-community_git.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-SUMMARY = "4A - Community HALs"
-DESCRIPTION = "HALs maintained by AGL Community for 4A (AGL Advanced Audio Agent)"
-HOMEPAGE = "https://git.automotivelinux.org/src/4a-hal-community/"
-SECTION = "apps"
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/src/4a-hal-community;protocol=https;branch=${AGL_BRANCH}"
-
-SRCREV = "${AGL_APP_REVISION}"
-
-PV = "0.1+git${SRCPV}"
-S = "${WORKDIR}/git"
-
-inherit afb-system-cmake
-
-#Select Here your HAL
-EXTRA_OECMAKE += " -DHAL_JABRA=1"
-
-FILES_${PN}-dev += "${INSTALL_PREFIX}/afb-aaaa/htdocs"
-FILES_${PN} += "${INSTALL_PREFIX}/afb-aaaa"
-FILES_${PN} += "${INSTALL_PREFIX}/lib"
diff --git a/meta-audio-4a-framework/recipes-multimedia/4a-hal-config/4a-hal-config.bb b/meta-audio-4a-framework/recipes-multimedia/4a-hal-config/4a-hal-config.bb
index cfb3ff7c..d012cb9a 100644
--- a/meta-audio-4a-framework/recipes-multimedia/4a-hal-config/4a-hal-config.bb
+++ b/meta-audio-4a-framework/recipes-multimedia/4a-hal-config/4a-hal-config.bb
@@ -30,11 +30,6 @@ do_install () {
sed -i "s|@AUDIO_DEV_NAME@|${AUDIO_DEV_NAME}|g" ${D}/${sysconfdir}/asound.conf
sed -i "s|@AUDIO_DEV_NAME_ID@|${AUDIO_DEV_NAME_ID}|g" ${D}/${sysconfdir}/asound.conf
sed -i "s|@INSTALL_PREFIX@|${INSTALL_PREFIX}|g" ${D}/${sysconfdir}/asound.conf
-
- install -d "${D}${prefix}/agl-service-audio-4a"
- install -m 0755 ${WORKDIR}/ahl-config.json.template "${D}${prefix}/agl-service-audio-4a/ahl-agl-service-audio-4a-config.json"
- sed -i "s|@AUDIO_DEV_NAME_ID@|${AUDIO_DEV_NAME_ID}|g" "${D}${prefix}/agl-service-audio-4a/ahl-agl-service-audio-4a-config.json"
}
FILES_${PN} += "${sysconfdir}/asound.conf"
-FILES_${PN} += "${prefix}/agl-service-audio-4a/ahl-agl-service-audio-4a-config.json"
diff --git a/meta-audio-4a-framework/recipes-multimedia/4a-hal-generic/4a-hal-generic_git.bb b/meta-audio-4a-framework/recipes-multimedia/4a-hal-generic/4a-hal-generic_git.bb
index 7d799c29..eede6956 100644
--- a/meta-audio-4a-framework/recipes-multimedia/4a-hal-generic/4a-hal-generic_git.bb
+++ b/meta-audio-4a-framework/recipes-multimedia/4a-hal-generic/4a-hal-generic_git.bb
@@ -4,12 +4,11 @@ HOMEPAGE = "https://github.com/iotbzh/4a-hal-generic/"
SECTION = "apps"
LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=89aea4e17d99a7cacdbeed46a0096b10"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-SRC_URI = "gitsm://github.com/iotbzh/4a-hal-generic;protocol=https;branch=rc1"
-
-SRCREV = "b66e65b1b3c6981cfefd5ba42dcc6acce7d40696"
-##SRCREV = "${AUTOREV}"
+SRC_URI = "gitsm://github.com/iotbzh/4a-hal-generic;protocol=https;branch=${AGL_BRANCH}"
+#SRCREV = "${AGL_APP_REVISION}"
+SRCREV = "8142c7ed42167dff7e526952f91909d679453251"
DEPENDS += "lua"
diff --git a/meta-audio-4a-framework/recipes-multimedia/4a-hal-reference/4a-hal-reference_git.bb b/meta-audio-4a-framework/recipes-multimedia/4a-hal-reference/4a-hal-reference_git.bb
deleted file mode 100644
index 7629b69d..00000000
--- a/meta-audio-4a-framework/recipes-multimedia/4a-hal-reference/4a-hal-reference_git.bb
+++ /dev/null
@@ -1,28 +0,0 @@
-SUMMARY = "4A - Reference HALs"
-DESCRIPTION = "HALs used for Reference boards in 4A (AGL Advanced Audio Agent)"
-HOMEPAGE = "https://git.automotivelinux.org/src/4a-hal-reference/"
-SECTION = "apps"
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/src/4a-hal-reference;protocol=https;branch=${AGL_BRANCH}"
-
-SRCREV = "${AGL_APP_REVISION}"
-
-PV = "0.1+git${SRCPV}"
-S = "${WORKDIR}/git"
-
-inherit afb-system-cmake
-
-EXTRA_OECMAKE += "-DHAL_USB_DEVICE=1"
-
-# Select platform specific additional HAL(s)
-EXTRA_OECMAKE_append_x86-64 = " -DHAL_INTEL_HDA=1"
-# Mark as specific to M3
-PACKAGE_ARCH_m3ulcb = "${MACHINE_ARCH}"
-EXTRA_OECMAKE_append_m3ulcb = " -DHAL_RCAR-M3=1"
-
-FILES_${PN}-dev += "${INSTALL_PREFIX}/afb-aaaa/htdocs"
-FILES_${PN} += "${INSTALL_PREFIX}/afb-aaaa"
-FILES_${PN} += "${INSTALL_PREFIX}/lib"
diff --git a/meta-audio-4a-framework/recipes-multimedia/4a-mixer/4a-mixer_git.bb b/meta-audio-4a-framework/recipes-multimedia/4a-mixer/4a-mixer_git.bb
new file mode 100644
index 00000000..c784ea6e
--- /dev/null
+++ b/meta-audio-4a-framework/recipes-multimedia/4a-mixer/4a-mixer_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Mixer for CES2017 AGL Demonstration"
+DESCRIPTION = "AGL HMI application for control of PulseAudio mixer elements"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/mixer"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/mixer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS += "qtquickcontrols2 \
+ qtwebsockets \
+ pulseaudio \
+ virtual/libhomescreen \
+ qlibwindowmanager \
+"
+
+RPROVIDES_${PN} += "virtual/mixer"
+
+inherit cmake_qt5 aglwgt \ No newline at end of file
diff --git a/meta-audio-4a-framework/recipes-multimedia/4a-softmixer/4a-softmixer_git.bb b/meta-audio-4a-framework/recipes-multimedia/4a-softmixer/4a-softmixer_git.bb
index 1eece70a..2cead9a0 100644
--- a/meta-audio-4a-framework/recipes-multimedia/4a-softmixer/4a-softmixer_git.bb
+++ b/meta-audio-4a-framework/recipes-multimedia/4a-softmixer/4a-softmixer_git.bb
@@ -4,12 +4,11 @@ HOMEPAGE = "https://github.com/iotbzh/4a-softmixer/"
SECTION = "apps"
LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=89aea4e17d99a7cacdbeed46a0096b10"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-SRC_URI = "gitsm://github.com/iotbzh/4a-softmixer/;protocol=https;branch=hal-rc1-sandbox"
-
-SRCREV = "acfda0a2236ca70b18ad2e7a6ec1ef3192405aac"
-#SRCREV = "${AUTOREV}"
+SRC_URI = "gitsm://github.com/iotbzh/4a-softmixer/;protocol=https;branch=${AGL_BRANCH}"
+#SRCREV = "${AGL_APP_REVISION}"
+SRCREV = "731c21e80ba45339b7dd9b8eae63accd3597d281"
DEPENDS += "lua"
diff --git a/meta-audio-4a-framework/recipes-multimedia/agl-service-audio-4a/agl-service-audio-4a_git.bb b/meta-audio-4a-framework/recipes-multimedia/agl-service-audio-4a/agl-service-audio-4a_git.bb
index 2422743d..8aa50efa 100644
--- a/meta-audio-4a-framework/recipes-multimedia/agl-service-audio-4a/agl-service-audio-4a_git.bb
+++ b/meta-audio-4a-framework/recipes-multimedia/agl-service-audio-4a/agl-service-audio-4a_git.bb
@@ -14,7 +14,7 @@ S = "${WORKDIR}/git"
inherit cmake aglwgt pkgconfig
-DEPENDS += "alsa-lib json-c systemd af-binder glib-2.0"
+DEPENDS += "alsa-lib json-c systemd af-binder glib-2.0 lua"
do_aglwgt_deploy_append() {
cat <<'EOF' >${D}/${sysconfdir}/agl-postinsts/99_4A_service_patch.sh
@@ -31,7 +31,11 @@ done
sed -i '/\[Unit\]/ a Before=pulseaudio.service' $svcfile;
sed -i '/\[Unit\]/ a ConditionPathExistsGlob=/dev/snd/control*' $svcfile;
-sed -i -e 's|/usr/bin/afb-daemon\>|& --ldpath=/usr/libexec/agl/afb-aaaa/lib:/usr/libexec/agl/4a-alsa-core/lib|' $svcfile
+sed -i -e 's|/usr/bin/afb-daemon\>|& --ldpath=/usr/libexec/agl/4a-alsa-core/lib:/usr/libexec/agl/4a-hal/lib:/usr/libexec/agl/afb-aaaa/lib:/usr/libexec/agl/smixer/lib|' $svcfile
+
+# binder name matters: it must match "afbd-4a-*" => the config file (controller json file) that will be searched will be "policy-4a-*.json"
+sed -i -e 's|--name afbd-agl-\(.*\)|--name afbd-4a-\1|' $svcfile
+
echo "-- TMP 4A INSTALL FIX END"
EOF
diff --git a/templates/feature/agl-audio-4a-framework/50_local.conf.inc b/templates/feature/agl-audio-4a-framework/50_local.conf.inc
index 19889d8e..91d4c863 100644
--- a/templates/feature/agl-audio-4a-framework/50_local.conf.inc
+++ b/templates/feature/agl-audio-4a-framework/50_local.conf.inc
@@ -1,14 +1,2 @@
-# In order to enable the audio-4a-framework features ,
-# enables the following line:
-#
-DISTRO_FEATURES_append = " agl-audio-4a-framework "
-
-# asound.conf is provided by the 4a-hal-config (and not by asound.state)
-VIRTUAL-RUNTIME_alsa-state = "4a-hal-config"
-# additionally there is a bug in alsa-utils-alsactl where it pulls in alsa-state directly
-RRECOMMENDS_pn-alsa-utils-alsactl = "VIRTUAL-RUNTIME_alsa-state"
-
-# why should a config package have -dev ... I'll leave that answer to you.
-PACKAGES_pn-alsa-state_remove = "alsa-state-dev"
-PACKAGES_pn-alsa-state_remove = "alsa-states-dev"
-PACKAGES_pn-alsa-state = "alsa-state alsa-states"
+#see meta-agl-devel/meta-audio-4a-framework/conf/include/agl-audio-4a-framework.inc
+require conf/include/agl-audio-4a-framework.inc