summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-23 07:37:25 -0400
committerjenkins-dontreply@build.automotivelinux.org <collab-it+agl-jobbuilder@linuxfoundation.org>2024-05-29 21:01:07 +0000
commit26c76168be6aac23db2af0478ec0edd814c75bfa (patch)
treea8b4d2fc6208cc7920251a99c343cf9a90440e83
parent119a5ef5ce20ca98be7c09beee7af1ce0589b033 (diff)
Update recipes for transition to UNPACKDIRnext
Update recipes to handle the transition to using UNPACKDIR as the destination for unpacked files. For recipes that had been using S = WORKDIR, the approach used in meta-openembedded has been followed, i.e. using UNPACKDIR in tasks for consistency. Bug-AGL: SPEC-5147 Change-Id: I32e277e15e5aa1ac93dadc67199dedd148d3d0b9 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--meta-agl-bsp/meta-agl-refhw-gen3/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bbappend9
-rw-r--r--meta-agl-bsp/meta-freescale-layer/recipes-connectivity/hci-uart-helper/hci-uart-helper_1.0.bb7
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-kernel/create-combined-dtb/create-combined-dtb_1.0.0.bb10
-rw-r--r--meta-agl-bsp/meta-rcar-gen3-adas/recipes-bsp/si-tools/si-init_1.0.bb5
-rw-r--r--meta-agl-bsp/meta-rcar-gen3-adas/recipes-bsp/ti-bt/ti-bt_%.bbappend3
-rw-r--r--meta-agl-bsp/meta-rcar-gen3-adas/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bbappend5
-rw-r--r--meta-agl-core/dynamic-layers/meta-selinux/recipes-core/systemd/systemd-selinux-relabel_1.0.bb7
-rw-r--r--meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb7
-rw-r--r--meta-agl-core/recipes-core/systemd/systemd_aglcore.inc6
-rw-r--r--meta-agl-core/recipes-graphics/rba/rba-config.bb5
-rw-r--r--meta-agl-core/recipes-graphics/wayland/Readme.weston-ini-conf8
-rw-r--r--meta-agl-core/recipes-graphics/wayland/agl-compositor-init.bb11
-rw-r--r--meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb9
-rw-r--r--meta-agl-core/recipes-kernel/linux/linux-agl-config.inc2
-rw-r--r--meta-app-framework/recipes-config/polkit-rule-agl-app/polkit-rule-agl-app.bb7
-rw-r--r--meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb12
-rw-r--r--meta-netboot/recipes-core/initramfs-netboot/initramfs-netboot_1.0.bb11
-rw-r--r--meta-netboot/recipes-core/systemd/resolv-conf-relabel.bb5
-rw-r--r--meta-pipewire/recipes-multimedia/wireplumber/wireplumber-config-agl_git.bb19
-rw-r--r--meta-pipewire/recipes-multimedia/wireplumber/wireplumber-policy-config-agl_git.bb11
20 files changed, 98 insertions, 61 deletions
diff --git a/meta-agl-bsp/meta-agl-refhw-gen3/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bbappend b/meta-agl-bsp/meta-agl-refhw-gen3/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bbappend
index 3cd5aa7de..4407b1011 100644
--- a/meta-agl-bsp/meta-agl-refhw-gen3/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bbappend
+++ b/meta-agl-bsp/meta-agl-refhw-gen3/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bbappend
@@ -5,18 +5,21 @@ SRC_URI = "file://gpsd.refhw \
file://refhw.conf \
"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
inherit update-alternatives
do_configure[noexec] = "1"
do_compile[noexec] = "1"
do_install() {
- install -D -m 0644 ${WORKDIR}/gpsd.refhw ${D}/${sysconfdir}/default/gpsd.refhw
+ install -D -m 0644 ${UNPACKDIR}/gpsd.refhw ${D}/${sysconfdir}/default/gpsd.refhw
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -D -m 0755 ${WORKDIR}/refhw-gpsd-helper.sh ${D}/${sbindir}/refhw-gpsd-helper.sh
+ install -D -m 0755 ${UNPACKDIR}/refhw-gpsd-helper.sh ${D}/${sbindir}/refhw-gpsd-helper.sh
install -d ${D}${sysconfdir}/systemd/system/gpsd.service.d
- install -D -m 0644 ${WORKDIR}/refhw.conf ${D}${sysconfdir}/systemd/system/gpsd.service.d/refhw.conf
+ install -D -m 0644 ${UNPACKDIR}/refhw.conf ${D}${sysconfdir}/systemd/system/gpsd.service.d/refhw.conf
fi
}
diff --git a/meta-agl-bsp/meta-freescale-layer/recipes-connectivity/hci-uart-helper/hci-uart-helper_1.0.bb b/meta-agl-bsp/meta-freescale-layer/recipes-connectivity/hci-uart-helper/hci-uart-helper_1.0.bb
index 798fcebe6..df8f62937 100644
--- a/meta-agl-bsp/meta-freescale-layer/recipes-connectivity/hci-uart-helper/hci-uart-helper_1.0.bb
+++ b/meta-agl-bsp/meta-freescale-layer/recipes-connectivity/hci-uart-helper/hci-uart-helper_1.0.bb
@@ -8,6 +8,9 @@ SRC_URI = "file://hci-uart-helper.service \
file://hci-uart-helper.sh \
"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
COMPATIBLE_MACHINE = "imx8mq-evk"
do_configure[noexec] = "1"
@@ -16,11 +19,11 @@ do_compile[noexec] = "1"
do_install() {
# Install helper script
install -d ${D}${sbindir}
- install -m 0755 ${WORKDIR}/hci-uart-helper.sh ${D}${sbindir}/
+ install -m 0755 ${UNPACKDIR}/hci-uart-helper.sh ${D}${sbindir}/
# Install systemd unit
install -d ${D}${systemd_system_unitdir}/
- install -m 0644 ${WORKDIR}/hci-uart-helper.service ${D}${systemd_system_unitdir}/
+ install -m 0644 ${UNPACKDIR}/hci-uart-helper.service ${D}${systemd_system_unitdir}/
install -d ${D}${systemd_system_unitdir}/bluetooth.service.wants
ln -s ../hci-uart-helper.service ${D}${systemd_system_unitdir}/bluetooth.service.wants/
}
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/create-combined-dtb/create-combined-dtb_1.0.0.bb b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/create-combined-dtb/create-combined-dtb_1.0.0.bb
index c5edbe1dc..464ae3f6f 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/create-combined-dtb/create-combined-dtb_1.0.0.bb
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/create-combined-dtb/create-combined-dtb_1.0.0.bb
@@ -1,16 +1,13 @@
SUMMARY = "Combine dtb and dtbo"
DESCRIPTION = "Combine specified dtb and one or more dtbo into specified filename found in deploydir"
SECTION = "bootloader"
-PR = "r1"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
DEPENDS = "dtc-native"
-ALLOW_EMPTY:${PN} = "1"
-FILES:${PN} = ""
-
-S = "${WORKDIR}"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
do_compile[depends] += "virtual/kernel:do_deploy"
@@ -41,3 +38,6 @@ do_deploy () {
}
addtask deploy after do_install
+
+ALLOW_EMPTY:${PN} = "1"
+FILES:${PN} = ""
diff --git a/meta-agl-bsp/meta-rcar-gen3-adas/recipes-bsp/si-tools/si-init_1.0.bb b/meta-agl-bsp/meta-rcar-gen3-adas/recipes-bsp/si-tools/si-init_1.0.bb
index b53504400..6804fbbb9 100644
--- a/meta-agl-bsp/meta-rcar-gen3-adas/recipes-bsp/si-tools/si-init_1.0.bb
+++ b/meta-agl-bsp/meta-rcar-gen3-adas/recipes-bsp/si-tools/si-init_1.0.bb
@@ -6,12 +6,15 @@ inherit systemd
SRC_URI = "file://si-init.service"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
do_configure[noexec] = "1"
do_compile[noexec] = "1"
do_install() {
install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/si-init.service ${D}${systemd_system_unitdir}
+ install -m 0644 ${UNPACKDIR}/si-init.service ${D}${systemd_system_unitdir}
# Add symlink to sysinit.target.wants
install -d ${D}${sysconfdir}/systemd/system/sysinit.target.wants
diff --git a/meta-agl-bsp/meta-rcar-gen3-adas/recipes-bsp/ti-bt/ti-bt_%.bbappend b/meta-agl-bsp/meta-rcar-gen3-adas/recipes-bsp/ti-bt/ti-bt_%.bbappend
index 55d570fc7..eb89d63d0 100644
--- a/meta-agl-bsp/meta-rcar-gen3-adas/recipes-bsp/ti-bt/ti-bt_%.bbappend
+++ b/meta-agl-bsp/meta-rcar-gen3-adas/recipes-bsp/ti-bt/ti-bt_%.bbappend
@@ -6,7 +6,6 @@ SRC_URI += "file://ti-uim.service"
SYSTEMD_SERVICE:${PN} = "ti-uim.service"
-PR = "r0"
PV = "0.1+git${SRCPV}"
do_install:append() {
@@ -14,5 +13,5 @@ do_install:append() {
rm -f ${D}/${sysconfdir}/modprobe.d/ti_bt.conf
install -d ${D}${systemd_unitdir}/system/
- install -m 0644 ${WORKDIR}/ti-uim.service ${D}${systemd_unitdir}/system
+ install -m 0644 ${UNPACKDIR}/ti-uim.service ${D}${systemd_unitdir}/system
}
diff --git a/meta-agl-bsp/meta-rcar-gen3-adas/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bbappend b/meta-agl-bsp/meta-rcar-gen3-adas/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bbappend
index 51604706c..f82e17170 100644
--- a/meta-agl-bsp/meta-rcar-gen3-adas/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bbappend
+++ b/meta-agl-bsp/meta-rcar-gen3-adas/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bbappend
@@ -2,6 +2,9 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
SRC_URI = "file://gpsd.kingfisher"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
inherit update-alternatives
do_configure[noexec] = "1"
@@ -9,7 +12,7 @@ do_compile[noexec] = "1"
do_install() {
install -d ${D}/${sysconfdir}/default
- install -m 0644 ${WORKDIR}/gpsd.kingfisher ${D}/${sysconfdir}/default/gpsd.kingfisher
+ install -m 0644 ${UNPACKDIR}/gpsd.kingfisher ${D}/${sysconfdir}/default/gpsd.kingfisher
}
COMPATIBLE_MACHINE = "ulcb"
diff --git a/meta-agl-core/dynamic-layers/meta-selinux/recipes-core/systemd/systemd-selinux-relabel_1.0.bb b/meta-agl-core/dynamic-layers/meta-selinux/recipes-core/systemd/systemd-selinux-relabel_1.0.bb
index 7e4f9783c..77020a630 100644
--- a/meta-agl-core/dynamic-layers/meta-selinux/recipes-core/systemd/systemd-selinux-relabel_1.0.bb
+++ b/meta-agl-core/dynamic-layers/meta-selinux/recipes-core/systemd/systemd-selinux-relabel_1.0.bb
@@ -6,6 +6,9 @@ SRC_URI = "file://systemd-selinux-relabel.service \
file://systemd-selinux-relabel.sh \
"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
inherit systemd allarch features_check
SYSTEMD_SERVICE:${PN} = "${BPN}.service"
@@ -17,9 +20,9 @@ do_compile[noexec] = "1"
do_install() {
install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/systemd-selinux-relabel.service ${D}${systemd_system_unitdir}/
+ install -m 0644 ${UNPACKDIR}/systemd-selinux-relabel.service ${D}${systemd_system_unitdir}/
install -d ${D}${sbindir}
- install -m 0755 ${WORKDIR}/systemd-selinux-relabel.sh ${D}${sbindir}/
+ install -m 0755 ${UNPACKDIR}/systemd-selinux-relabel.sh ${D}${sbindir}/
}
FILES:${PN} += "${systemd_system_unitdir}"
diff --git a/meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb b/meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb
index a23cd839a..1624aea38 100644
--- a/meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb
+++ b/meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb
@@ -13,16 +13,19 @@ SRC_URI = "\
file://canbus-can.link \
"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
CANBUS_NETWORK_CONFIG ??= "canbus-can.network"
CANBUS_NETWORK_CONFIG:virtio-all ?= "canbus-virtio.network"
do_install() {
# Install CAN bus network configuration
install -d ${D}${nonarch_base_libdir}/systemd/network/
- install -m 0644 ${WORKDIR}/${CANBUS_NETWORK_CONFIG} ${D}${nonarch_base_libdir}/systemd/network/60-canbus-can.network
+ install -m 0644 ${UNPACKDIR}/${CANBUS_NETWORK_CONFIG} ${D}${nonarch_base_libdir}/systemd/network/60-canbus-can.network
# Install link configuration to bump queue size on physical CAN bus devices
- install -m 0644 ${WORKDIR}/canbus-can.link ${D}${nonarch_base_libdir}/systemd/network/60-canbus-can.link
+ install -m 0644 ${UNPACKDIR}/canbus-can.link ${D}${nonarch_base_libdir}/systemd/network/60-canbus-can.link
}
PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/meta-agl-core/recipes-core/systemd/systemd_aglcore.inc b/meta-agl-core/recipes-core/systemd/systemd_aglcore.inc
index 9681329be..9fbe23708 100644
--- a/meta-agl-core/recipes-core/systemd/systemd_aglcore.inc
+++ b/meta-agl-core/recipes-core/systemd/systemd_aglcore.inc
@@ -20,15 +20,15 @@ PACKAGECONFIG:append:agl-devel = " coredump"
do_install:append() {
# Install /etc/e2fsck.conf to avoid boot stuck by wrong clock time
- install -m 644 -p -D ${WORKDIR}/e2fsck.conf ${D}${sysconfdir}/e2fsck.conf
+ install -m 644 -p -D ${UNPACKDIR}/e2fsck.conf ${D}${sysconfdir}/e2fsck.conf
if [ "${VIRTUAL-RUNTIME_net_manager}" = "systemd" ]; then
# Install DHCP configuration for Ethernet adapters
- install -m 644 ${WORKDIR}/wired.network ${D}${sysconfdir}/systemd/network
+ install -m 644 ${UNPACKDIR}/wired.network ${D}${sysconfdir}/systemd/network
elif [ "${VIRTUAL-RUNTIME_net_manager}" = "connman" ]; then
# Disable systemd-networkd-wait-online by default
install -d ${D}${systemd_system_unitdir}/systemd-networkd-wait-online.service.d
- install -m 0644 ${WORKDIR}/wait-disable.conf ${D}${systemd_system_unitdir}/systemd-networkd-wait-online.service.d/
+ install -m 0644 ${UNPACKDIR}/wait-disable.conf ${D}${systemd_system_unitdir}/systemd-networkd-wait-online.service.d/
fi
}
diff --git a/meta-agl-core/recipes-graphics/rba/rba-config.bb b/meta-agl-core/recipes-graphics/rba/rba-config.bb
index cbed9df0c..53bb01bb1 100644
--- a/meta-agl-core/recipes-graphics/rba/rba-config.bb
+++ b/meta-agl-core/recipes-graphics/rba/rba-config.bb
@@ -4,12 +4,13 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7ca
SRC_URI = "file://RBAModel.json"
-S = "${WORKDIR}"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
do_configure[noexec] = "1"
do_compile[noexec] = "1"
do_install:append() {
install -d ${D}/${sysconfdir}/rba
- install -m 0644 ${WORKDIR}/RBAModel.json ${D}/${sysconfdir}/rba
+ install -m 0644 ${UNPACKDIR}/RBAModel.json ${D}/${sysconfdir}/rba
}
diff --git a/meta-agl-core/recipes-graphics/wayland/Readme.weston-ini-conf b/meta-agl-core/recipes-graphics/wayland/Readme.weston-ini-conf
index ee75c7335..e68dc7f0c 100644
--- a/meta-agl-core/recipes-graphics/wayland/Readme.weston-ini-conf
+++ b/meta-agl-core/recipes-graphics/wayland/Readme.weston-ini-conf
@@ -6,16 +6,16 @@ overrides (i.e. use the MACHINE name where "machine" is used below):
'''
do_configure:machine() {
- echo repaint-window=34 >> ${WORKDIR}/core.cfg
+ echo repaint-window=34 >> ${UNPACKDIR}/core.cfg
- echo transition-duration=300 >> ${WORKDIR}/ivishell.cfg
- echo cursor-theme=default >> ${WORKDIR}/ivishell.cfg
+ echo transition-duration=300 >> ${UNPACKDIR}/ivishell.cfg
+ echo cursor-theme=default >> ${UNPACKDIR}/ivishell.cfg
}
'''
or:
'''
do_configure:machine() {
- sed -i -e 's/drm-backend/fbdev-backend/' ${WORKDIR}/core.cfg
+ sed -i -e 's/drm-backend/fbdev-backend/' ${UNPACKDIR}/core.cfg
}
'''
diff --git a/meta-agl-core/recipes-graphics/wayland/agl-compositor-init.bb b/meta-agl-core/recipes-graphics/wayland/agl-compositor-init.bb
index d8baf91f9..8400bc918 100644
--- a/meta-agl-core/recipes-graphics/wayland/agl-compositor-init.bb
+++ b/meta-agl-core/recipes-graphics/wayland/agl-compositor-init.bb
@@ -15,7 +15,8 @@ SRC_URI = "file://agl-compositor.service \
file://agl-compositor.conf.in \
"
-S = "${WORKDIR}"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
AGL_COMPOSITOR_ARGS ?= " --config ${sysconfdir}/xdg/weston/weston.ini --idle-time=0"
AGL_COMPOSITOR_USE_PIXMAN ??= "0"
@@ -25,10 +26,10 @@ AGL_COMPOSITOR_ARGS:append = " ${@bb.utils.contains("WESTON_USE_PIXMAN", "1", "
do_install() {
# Install systemd service
- install -D -p -m0644 ${WORKDIR}/agl-compositor.service ${D}${systemd_system_unitdir}/agl-compositor.service
- install -D -p -m0644 ${WORKDIR}/agl-compositor.socket ${D}${systemd_system_unitdir}/agl-compositor.socket
+ install -D -p -m0644 ${UNPACKDIR}/agl-compositor.service ${D}${systemd_system_unitdir}/agl-compositor.service
+ install -D -p -m0644 ${UNPACKDIR}/agl-compositor.socket ${D}${systemd_system_unitdir}/agl-compositor.socket
if [ "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}" ]; then
- install -D -p -m0644 ${WORKDIR}/agl-compositor-autologin ${D}${sysconfdir}/pam.d/agl-compositor-autologin
+ install -D -p -m0644 ${UNPACKDIR}/agl-compositor-autologin ${D}${sysconfdir}/pam.d/agl-compositor-autologin
fi
# Install systemd service drop-in with extra configuration
@@ -37,7 +38,7 @@ do_install() {
g=${f%.in}
if [ "${f}" != "${g}" ]; then
sed -e "s,@AGL_COMPOSITOR_ARGS@,${AGL_COMPOSITOR_ARGS},g" \
- ${WORKDIR}/${f} > ${WORKDIR}/${g}
+ ${UNPACKDIR}/${f} > ${WORKDIR}/${g}
fi
done
install -d ${D}${systemd_system_unitdir}/agl-compositor.service.d
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
index 574f89f2b..57133d8cf 100644
--- a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
+++ b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
@@ -20,7 +20,8 @@ SRC_URI = " \
file://grpc-proxy.cfg \
"
-S = "${WORKDIR}"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
inherit update-alternatives
@@ -40,7 +41,7 @@ do_compile() {
# orientation configuration
rm -f ${WORKDIR}/weston.ini.default
for F in ${WESTON_FRAGMENTS}; do
- cat ${WORKDIR}/${F}.cfg >> ${WORKDIR}/weston.ini.default
+ cat ${UNPACKDIR}/${F}.cfg >> ${WORKDIR}/weston.ini.default
echo >> ${WORKDIR}/weston.ini.default
done
sed -i -e '$ d' ${WORKDIR}/weston.ini.default
@@ -64,8 +65,8 @@ do_compile() {
F="virtual-0"
INVF="virtual-180"
fi
- cat ${WORKDIR}/${F}.cfg >> ${WORKDIR}/weston.ini.landscape
- cat ${WORKDIR}/${INVF}.cfg >> ${WORKDIR}/weston.ini.landscape-inverted
+ cat ${UNPACKDIR}/${F}.cfg >> ${WORKDIR}/weston.ini.landscape
+ cat ${UNPACKDIR}/${INVF}.cfg >> ${WORKDIR}/weston.ini.landscape-inverted
echo >> ${WORKDIR}/weston.ini.landscape
echo >> ${WORKDIR}/weston.ini.landscape-inverted
done
diff --git a/meta-agl-core/recipes-kernel/linux/linux-agl-config.inc b/meta-agl-core/recipes-kernel/linux/linux-agl-config.inc
index 4799a6180..8205e6ff7 100644
--- a/meta-agl-core/recipes-kernel/linux/linux-agl-config.inc
+++ b/meta-agl-core/recipes-kernel/linux/linux-agl-config.inc
@@ -32,7 +32,7 @@ AGL_KERNEL_SRC ?= "${@' '.join(['file://' + x for x in d.getVar('AGL_KCONFIG_FRA
SRC_URI:append = " ${AGL_KERNEL_SRC}"
# For meta-ti and meta-qcom
-KERNEL_CONFIG_FRAGMENTS ?= "${@' '.join(['${WORKDIR}/' + x for x in d.getVar('AGL_KCONFIG_FRAGMENTS').split()])}"
+KERNEL_CONFIG_FRAGMENTS ?= "${@' '.join(['${UNPACKDIR}/' + x for x in d.getVar('AGL_KCONFIG_FRAGMENTS').split()])}"
# Extra configuration options for the AGL kernel
AGL_KCONFIG_FRAGMENTS += " \
diff --git a/meta-app-framework/recipes-config/polkit-rule-agl-app/polkit-rule-agl-app.bb b/meta-app-framework/recipes-config/polkit-rule-agl-app/polkit-rule-agl-app.bb
index 57dda7787..c4de20b38 100644
--- a/meta-app-framework/recipes-config/polkit-rule-agl-app/polkit-rule-agl-app.bb
+++ b/meta-app-framework/recipes-config/polkit-rule-agl-app/polkit-rule-agl-app.bb
@@ -2,9 +2,12 @@ SUMMARY = "Rule for agl-driver to control agl-app@ services"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+DEPENDS += "polkit"
+
SRC_URI = "file://50-agl-app.rules"
-DEPENDS += "polkit"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
inherit useradd features_check
REQUIRED_DISTRO_FEATURES = "polkit"
@@ -12,7 +15,7 @@ REQUIRED_DISTRO_FEATURES = "polkit"
do_install() {
install -m 700 -d ${D}${datadir}/polkit-1/rules.d
chown polkitd:root ${D}/${datadir}/polkit-1/rules.d
- install -m 0644 ${WORKDIR}/50-agl-app.rules ${D}${datadir}/polkit-1/rules.d
+ install -m 0644 ${UNPACKDIR}/50-agl-app.rules ${D}${datadir}/polkit-1/rules.d
}
USERADD_PACKAGES = "${PN}"
diff --git a/meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb b/meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb
index c1bafad8e..733070d24 100644
--- a/meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb
+++ b/meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb
@@ -45,15 +45,15 @@ SYSTEMD_SERVICE:${PN} = "applaunchd.service"
do_install:append() {
# Install generic template for all agl-app services
install -d ${D}${systemd_system_unitdir}
- install -m 644 ${WORKDIR}/applaunchd.service ${D}${systemd_system_unitdir}/
- install -m 644 ${WORKDIR}/agl-app@.service ${D}${systemd_system_unitdir}/
- install -m 644 ${WORKDIR}/agl-app-web@.service ${D}${systemd_system_unitdir}/
- install -m 644 ${WORKDIR}/agl-app-flutter@.service ${D}${systemd_system_unitdir}/
+ install -m 644 ${UNPACKDIR}/applaunchd.service ${D}${systemd_system_unitdir}/
+ install -m 644 ${UNPACKDIR}/agl-app@.service ${D}${systemd_system_unitdir}/
+ install -m 644 ${UNPACKDIR}/agl-app-web@.service ${D}${systemd_system_unitdir}/
+ install -m 644 ${UNPACKDIR}/agl-app-flutter@.service ${D}${systemd_system_unitdir}/
# Install individual sandboxing overrides/drop-ins to be used by apps
install -d ${D}${systemd_system_unitdir}/sandboxing
- install -m 644 ${WORKDIR}/no-network.conf ${D}${systemd_system_unitdir}/sandboxing/
- install -m 644 ${WORKDIR}/private-tmp.conf ${D}${systemd_system_unitdir}/sandboxing/
+ install -m 644 ${UNPACKDIR}/no-network.conf ${D}${systemd_system_unitdir}/sandboxing/
+ install -m 644 ${UNPACKDIR}/private-tmp.conf ${D}${systemd_system_unitdir}/sandboxing/
}
PACKAGE_BEFORE_PN += "${PN}-template-agl-app ${PN}-template-agl-app-web ${PN}-template-agl-app-flutter"
diff --git a/meta-netboot/recipes-core/initramfs-netboot/initramfs-netboot_1.0.bb b/meta-netboot/recipes-core/initramfs-netboot/initramfs-netboot_1.0.bb
index dd61a1ea8..4aba55578 100644
--- a/meta-netboot/recipes-core/initramfs-netboot/initramfs-netboot_1.0.bb
+++ b/meta-netboot/recipes-core/initramfs-netboot/initramfs-netboot_1.0.bb
@@ -1,21 +1,22 @@
SUMMARY = "Extremely basic live image init script"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
SRC_URI = "file://init.sh"
-S = "${WORKDIR}"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
-RDEPENDS:${PN} += "nbd-client"
+inherit allarch
do_install() {
install -dm 0755 ${D}${sysconfdir}
touch ${D}${sysconfdir}/initrd-release
install -dm 0755 ${D}/dev
install -dm 0755 ${D}${sbindir}
- install -m 0755 ${WORKDIR}/init.sh ${D}${sbindir}/init
+ install -m 0755 ${UNPACKDIR}/init.sh ${D}${sbindir}/init
}
-inherit allarch
-
FILES:${PN} += " /dev ${sysconfdir}/initrd-release ${sbindir}/init "
+RDEPENDS:${PN} += "nbd-client"
diff --git a/meta-netboot/recipes-core/systemd/resolv-conf-relabel.bb b/meta-netboot/recipes-core/systemd/resolv-conf-relabel.bb
index 36d096b44..6180b78c2 100644
--- a/meta-netboot/recipes-core/systemd/resolv-conf-relabel.bb
+++ b/meta-netboot/recipes-core/systemd/resolv-conf-relabel.bb
@@ -4,6 +4,9 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
SRC_URI = "file://resolv-conf-relabel.service"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
inherit systemd allarch features_check
SYSTEMD_SERVICE:${PN} = "${BPN}.service"
@@ -15,7 +18,7 @@ do_compile[noexec] = "1"
do_install() {
install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/resolv-conf-relabel.service ${D}${systemd_system_unitdir}/
+ install -m 0644 ${UNPACKDIR}/resolv-conf-relabel.service ${D}${systemd_system_unitdir}/
}
FILES:${PN} += "${systemd_system_unitdir}"
diff --git a/meta-pipewire/recipes-multimedia/wireplumber/wireplumber-config-agl_git.bb b/meta-pipewire/recipes-multimedia/wireplumber/wireplumber-config-agl_git.bb
index 22ffe5bf3..77c7d99ed 100644
--- a/meta-pipewire/recipes-multimedia/wireplumber/wireplumber-config-agl_git.bb
+++ b/meta-pipewire/recipes-multimedia/wireplumber/wireplumber-config-agl_git.bb
@@ -5,6 +5,7 @@ AUTHOR = "George Kiagiadakis <george.kiagiadakis@collabora.com>"
SECTION = "multimedia"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
SRC_URI = "\
file://bluetooth.lua.d/ \
file://host.lua.d/ \
@@ -14,6 +15,10 @@ SRC_URI = "\
file://wireplumber.conf \
file://wireplumber-bluetooth.conf \
"
+
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
PACKAGE_ARCH = "${MACHINE_ARCH}"
do_configure[noexec] = "1"
@@ -25,27 +30,27 @@ do_install:append() {
systemd_dir="${D}${sysconfdir}/systemd/system/pipewire.service.wants/"
install -d ${config_dir}
- install -m 0644 ${WORKDIR}/00-functions.lua ${config_dir}
+ install -m 0644 ${UNPACKDIR}/00-functions.lua ${config_dir}
# config of the main (host) instance
install -d ${config_dir}/host.lua.d/
ln -s ../00-functions.lua ${config_dir}/host.lua.d/00-functions.lua
- install -m 0644 ${WORKDIR}/host.lua.d/*.lua ${config_dir}/host.lua.d/
- install -m 0644 ${WORKDIR}/wireplumber.conf ${config_dir}
+ install -m 0644 ${UNPACKDIR}/host.lua.d/*.lua ${config_dir}/host.lua.d/
+ install -m 0644 ${UNPACKDIR}/wireplumber.conf ${config_dir}
# config of the bluetooth instance
install -d ${config_dir}/bluetooth.lua.d/
ln -s ../00-functions.lua ${config_dir}/bluetooth.lua.d/00-functions.lua
- install -m 0644 ${WORKDIR}/bluetooth.lua.d/*.lua ${config_dir}/bluetooth.lua.d/
- install -m 0644 ${WORKDIR}/bluetooth.conf ${config_dir}
+ install -m 0644 ${UNPACKDIR}/bluetooth.lua.d/*.lua ${config_dir}/bluetooth.lua.d/
+ install -m 0644 ${UNPACKDIR}/bluetooth.conf ${config_dir}
# install the alsa-suspend script, loaded by the main instance
install -d ${scripts_dir}
- install -m 0644 ${WORKDIR}/alsa-suspend.lua ${scripts_dir}
+ install -m 0644 ${UNPACKDIR}/alsa-suspend.lua ${scripts_dir}
# install dbus daemon configuration
install -d ${dbus_config_dir}
- install -m 0644 ${WORKDIR}/wireplumber-bluetooth.conf ${dbus_config_dir}
+ install -m 0644 ${UNPACKDIR}/wireplumber-bluetooth.conf ${dbus_config_dir}
# enable additional systemd services
install -d ${systemd_dir}
diff --git a/meta-pipewire/recipes-multimedia/wireplumber/wireplumber-policy-config-agl_git.bb b/meta-pipewire/recipes-multimedia/wireplumber/wireplumber-policy-config-agl_git.bb
index 1a031160e..96e5c48c5 100644
--- a/meta-pipewire/recipes-multimedia/wireplumber/wireplumber-policy-config-agl_git.bb
+++ b/meta-pipewire/recipes-multimedia/wireplumber/wireplumber-policy-config-agl_git.bb
@@ -5,11 +5,16 @@ AUTHOR = "Ashok Sidipotu <ashok.sidipotu@collabora.com>"
SECTION = "multimedia"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
SRC_URI = "\
file://policy.lua.d \
file://00-functions.lua \
file://policy.conf \
"
+
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
PACKAGE_ARCH = "${MACHINE_ARCH}"
do_configure[noexec] = "1"
@@ -19,13 +24,13 @@ do_install:append() {
systemd_dir="${D}${sysconfdir}/systemd/system/pipewire.service.wants"
install -d ${config_dir}
- install -m 0644 ${WORKDIR}/00-functions.lua ${config_dir}
+ install -m 0644 ${UNPACKDIR}/00-functions.lua ${config_dir}
# config of the policy instance
install -d ${config_dir}/policy.lua.d/
ln -s ../00-functions.lua ${config_dir}/policy.lua.d/00-functions.lua
- install -m 0644 ${WORKDIR}/policy.lua.d/*.lua ${config_dir}/policy.lua.d/
- install -m 0644 ${WORKDIR}/policy.conf ${config_dir}
+ install -m 0644 ${UNPACKDIR}/policy.lua.d/*.lua ${config_dir}/policy.lua.d/
+ install -m 0644 ${UNPACKDIR}/policy.conf ${config_dir}
# enable additional systemd services
install -d ${systemd_dir}