summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-03-01 15:24:32 +0100
committerronan Le Martret <ronan@iot.bzh>2017-03-19 19:55:43 +0000
commit19af2c64dfdd8425f1bd9aca94041fd20e58d2bc (patch)
treef7f2e532dd309586b1a5f5feed6626e6c898e3a8
parent864c74f41acc2aa29694fcd6698bc58c4414bee4 (diff)
Removed old fix for weston-ivi-shell
- 0001-IVI-Shell-use-primary-screen-for-resolution.patch is not use any more Bug-AGL: SPEC-471 Bug-AGL: SPEC-411 Change-Id: Id2b3eb2ebd11fe1169444d3373f501394247c909 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
-rw-r--r--meta-ivi-common/recipes-graphics/wayland/weston-ivi-shell/0001-IVI-Shell-use-primary-screen-for-resolution.patch49
-rw-r--r--meta-ivi-common/recipes-graphics/wayland/weston_%.bbappend1
-rw-r--r--meta-ivi-common/recipes-graphics/wayland/weston_1.9.0.bbappend8
3 files changed, 1 insertions, 57 deletions
diff --git a/meta-ivi-common/recipes-graphics/wayland/weston-ivi-shell/0001-IVI-Shell-use-primary-screen-for-resolution.patch b/meta-ivi-common/recipes-graphics/wayland/weston-ivi-shell/0001-IVI-Shell-use-primary-screen-for-resolution.patch
deleted file mode 100644
index 2df9f4aed..000000000
--- a/meta-ivi-common/recipes-graphics/wayland/weston-ivi-shell/0001-IVI-Shell-use-primary-screen-for-resolution.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From: Manuel Bachmann <manuel.bachmann@iot.bzh>
-Date: Thu, Nov 5 10:17:00 2015 +0000
-Subject: ivi-shell: use primary screen for resolution values
-
-Screen resolution values (width, height) are always grabbed
-from the first screen, n.0, which can be a bad choice if it
-is not the one really used as main display.
-
-This mostly happens on hardware with a VGA adapter, such as
-laptops or Renesas R-Car E2 "Silk", and prevents correct
-layout stretching (black borders).
-
-Discover the primary screen and use its values.
-
-Signed-off-by: Manuel Bachmann <manuel.bachmann@iot.bzh>
----
-
---- a/ivi-shell/hmi-controller.c 2015-11-05 09:57:55.740942450 +0000
-+++ b/ivi-shell/hmi-controller.c 2015-11-05 10:00:23.545912494 +0000
-@@ -676,6 +676,8 @@
- struct link_layer *tmp_link_layer = NULL;
- int32_t panel_height = 0;
- struct hmi_controller *hmi_ctrl = MEM_ALLOC(sizeof(*hmi_ctrl));
-+ struct weston_output *output = NULL;
-+ int i = 0;
-
- wl_array_init(&hmi_ctrl->ui_widgets);
- hmi_ctrl->layout_mode = IVI_HMI_CONTROLLER_LAYOUT_MODE_TILING;
-@@ -684,11 +686,19 @@
-
- ivi_controller_interface->get_screens(&screen_length, &pp_screen);
-
-- iviscrn = pp_screen[0];
-+ /* find primary screen */
-+ for (i = 0; i < screen_length; i++) {
-+ iviscrn = pp_screen[i];
-+ output = ivi_controller_interface->screen_get_output(iviscrn);
-+ if (output->x == 0)
-+ break;
-+ }
-
- ivi_controller_interface->get_screen_resolution(iviscrn, &screen_width,
- &screen_height);
-
-+ iviscrn = pp_screen[0];
-+
- /* init base ivi_layer*/
- hmi_ctrl->base_layer.x = 0;
- hmi_ctrl->base_layer.y = 0;
diff --git a/meta-ivi-common/recipes-graphics/wayland/weston_%.bbappend b/meta-ivi-common/recipes-graphics/wayland/weston_%.bbappend
new file mode 100644
index 000000000..226126378
--- /dev/null
+++ b/meta-ivi-common/recipes-graphics/wayland/weston_%.bbappend
@@ -0,0 +1 @@
+EXTRA_OECONF_append = " --enable-ivi-shell"
diff --git a/meta-ivi-common/recipes-graphics/wayland/weston_1.9.0.bbappend b/meta-ivi-common/recipes-graphics/wayland/weston_1.9.0.bbappend
deleted file mode 100644
index c2f4b5bc9..000000000
--- a/meta-ivi-common/recipes-graphics/wayland/weston_1.9.0.bbappend
+++ /dev/null
@@ -1,8 +0,0 @@
-FILESEXTRAPATHS_prepend := ":${THISDIR}/weston-ivi-shell:"
-
-
-SRC_URI_append = " \
- file://0001-IVI-Shell-use-primary-screen-for-resolution.patch \
- "
-
-EXTRA_OECONF_append = " --enable-ivi-shell"