summaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-core/psplash/psplash_git.bbappend
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-09-14 17:16:13 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-10-11 14:49:03 +0000
commit1800faed9c28e6139cacf392547fd616904cf15d (patch)
tree6ff3c0326db647a9fea9a83513c982c22972de71 /meta-agl/recipes-core/psplash/psplash_git.bbappend
parent655d099206541b3efada4e18d9cb4940b2bbfe25 (diff)
psplash: add animation and last message from systemd
An animated splash screen is cool. Change-Id: I39c2404513aa6edd287df8555d46fe09e79f4408 Signed-off-by: José Bollo <jose.bollo@iot.bzh> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/11197 ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Stéphane Desneux <stephane.desneux@iot.bzh> Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl/recipes-core/psplash/psplash_git.bbappend')
-rw-r--r--meta-agl/recipes-core/psplash/psplash_git.bbappend2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-agl/recipes-core/psplash/psplash_git.bbappend b/meta-agl/recipes-core/psplash/psplash_git.bbappend
index c2c58c562..bdc196b6f 100644
--- a/meta-agl/recipes-core/psplash/psplash_git.bbappend
+++ b/meta-agl/recipes-core/psplash/psplash_git.bbappend
@@ -3,6 +3,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
SRC_URI += "file://psplash-colors.h \
file://psplash-start.service \
file://psplash-quit.service \
+ file://psplash-anim \
"
SPLASH_IMAGES="file://psplash-poky-img.h;outsuffix=default"
@@ -22,4 +23,5 @@ do_install_append () {
install -d ${D}${systemd_unitdir}/system
install -m 644 ${WORKDIR}/*.service ${D}/${systemd_unitdir}/system
fi
+ install -m 755 ${WORKDIR}/psplash-anim ${D}/${bindir}
}