summaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-graphics/wayland/weston_%.bbappend
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-03-24 11:16:21 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-03-30 07:36:39 +0000
commit7d1d7457ff2b71abe95525b26148d5a3e7a42790 (patch)
treec7b9796ea099f94da5b879276235fea6077d6bf4 /meta-agl/recipes-graphics/wayland/weston_%.bbappend
parent64d59ff0e0e835a53445b07257d3896fb48abfb5 (diff)
Generate weston.ini dynamically
* remove weston-intel.ini * add new package weston-ini-conf * the list of the sections of weston.ini is described in variable flags WESTONSECTION * each section is described in variable flags WESTONSECTION * each output screen is described in agl_screen variable Bug-AGL: SPEC-477 Change-Id: I3d25ab49018e3842c916993ba8b9bcc2428d5170 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
Diffstat (limited to 'meta-agl/recipes-graphics/wayland/weston_%.bbappend')
-rw-r--r--meta-agl/recipes-graphics/wayland/weston_%.bbappend9
1 files changed, 0 insertions, 9 deletions
diff --git a/meta-agl/recipes-graphics/wayland/weston_%.bbappend b/meta-agl/recipes-graphics/wayland/weston_%.bbappend
index 95b886c6e..217c4fc0b 100644
--- a/meta-agl/recipes-graphics/wayland/weston_%.bbappend
+++ b/meta-agl/recipes-graphics/wayland/weston_%.bbappend
@@ -3,7 +3,6 @@ FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
SRC_URI_append = "\
file://0001-compositor-drm.c-Launch-without-input-devices.patch \
file://weston.service \
- file://weston.ini \
"
inherit systemd
@@ -16,12 +15,4 @@ do_install_append() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -m 644 -p -D ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}/weston.service
fi
-
- WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
- install -d ${D}${WESTON_INI_CONFIG}
- install -m 0644 ${WORKDIR}/weston.ini ${D}${WESTON_INI_CONFIG}/weston.ini
}
-
-FILES_${PN} += " \
- ${sysconfdir}/xdg/weston/weston.ini \
- "