aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen2/recipes-graphics/mesa/mesa_17.%.bbappend
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-09-08 23:22:34 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-09-08 23:22:34 +0200
commit5698cf23837e1730f21766bf1b34227b61d20133 (patch)
treed0b7ed6cbfb05ddab504475950cc381533d9e2fa /meta-rcar-gen2/recipes-graphics/mesa/mesa_17.%.bbappend
parent33bb9fed153fd641d434a8edea595dca030f9247 (diff)
Fix RSS-related issues for rcar gen2
For pyro we need to fix a few recipes to work with the recipe specific sysroot feature. Change-Id: I9cc12083675ea2522a1f453f603b034e911d79fd Bug-AGL: SPEC-646 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-rcar-gen2/recipes-graphics/mesa/mesa_17.%.bbappend')
-rw-r--r--meta-rcar-gen2/recipes-graphics/mesa/mesa_17.%.bbappend17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-rcar-gen2/recipes-graphics/mesa/mesa_17.%.bbappend b/meta-rcar-gen2/recipes-graphics/mesa/mesa_17.%.bbappend
new file mode 100644
index 0000000..cd08da8
--- /dev/null
+++ b/meta-rcar-gen2/recipes-graphics/mesa/mesa_17.%.bbappend
@@ -0,0 +1,17 @@
+require ../../include/gles-control.inc
+
+def map_libs(d):
+ if base_conditional('USE_GLES_WAYLAND', "1", "1", "0", d) == "1":
+ return "wayland"
+
+ if base_conditional('USE_GLES_X11', "1", "1", "0", d) == "1":
+ return "x11"
+
+ return "dummy"
+
+MESATARGET := "${@map_libs(d)}"
+include mesa-${MESATARGET}.inc
+
+# For R-Car E2 temporarily disable Cortex A7 optimisation to avoid upstream
+# build issue between YP 1.7 gcc toolchain and Mesa 10.1.x releases.
+TARGET_CC_ARCH_remove_r8a7794 = "-mtune=cortex-a7"