summaryrefslogtreecommitdiffstats
path: root/bluetooth/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'bluetooth/CMakeLists.txt')
-rw-r--r--bluetooth/CMakeLists.txt21
1 files changed, 19 insertions, 2 deletions
diff --git a/bluetooth/CMakeLists.txt b/bluetooth/CMakeLists.txt
index 0e05d3b..e514aab 100644
--- a/bluetooth/CMakeLists.txt
+++ b/bluetooth/CMakeLists.txt
@@ -1,2 +1,19 @@
-add_headers(bluetooth.h bluetoothmodel.h)
-add_sources(bluetooth.cpp bluetoothmodel.cpp)
+
+CONFIGURE_FILE("qtappfw-bt.pc.in" "qtappfw-bt.pc" @ONLY)
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/qtappfw-bt.pc
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)
+
+add_library(qtappfw-bt SHARED bluetooth.cpp bluetoothmodel.cpp)
+
+target_include_directories(qtappfw-bt PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}")
+target_include_directories(qtappfw-bt PRIVATE "${CMAKE_INSTALL_INCLUDEDIR}")
+
+target_link_libraries(qtappfw-bt qtappfw-core)
+set_target_properties(qtappfw-bt PROPERTIES
+ VERSION ${PROJECT_VERSION}
+ SOVERSION 1
+ PUBLIC_HEADER "bluetooth.h;bluetoothmodel.h")
+
+install(TARGETS qtappfw-bt
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/qtappfw-bt)