summaryrefslogtreecommitdiffstats
path: root/waltham-transmitter/transmitter-plugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'waltham-transmitter/transmitter-plugin/CMakeLists.txt')
-rw-r--r--waltham-transmitter/transmitter-plugin/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/waltham-transmitter/transmitter-plugin/CMakeLists.txt b/waltham-transmitter/transmitter-plugin/CMakeLists.txt
index d751870..299357a 100644
--- a/waltham-transmitter/transmitter-plugin/CMakeLists.txt
+++ b/waltham-transmitter/transmitter-plugin/CMakeLists.txt
@@ -5,6 +5,7 @@ pkg_check_modules(WAYLAND_SERVER wayland-server>=1.13.0 REQUIRED)
pkg_check_modules(WESTON weston>=2.0.0 REQUIRED)
pkg_check_modules(PIXMAN pixman-1 REQUIRED)
pkg_check_modules(WALTHAM waltham REQUIRED)
+pkg_check_modules(JSON-C json-c REQUIRED)
include_directories(
include
@@ -15,6 +16,7 @@ include_directories(
${WESTON_INCLUDE_DIRS}
${PIXMAN_INCLUDE_DIRS}
${WALTHAM_INCLUDE_DIRS}
+ ${JSON-C_INCLUDE_DIR}
)
link_directories(
@@ -22,6 +24,7 @@ link_directories(
${WESTON_LIBRARY_DIRS}
${PIXMAN_LIBRARY_DIRS}
${WALTHAM_LIBRARY_DIRS}
+ ${JSON-C_LIBRARY_DIRS}
)
add_library(${PROJECT_NAME} MODULE
@@ -40,6 +43,7 @@ set(LIBS
${WESTON_LIBRARIES}
${PIXMAN_LIBRARIES}
${WALTHAM_LIBRARIES}
+ ${JSON-C_LIBRARIES}
)
SET(SRC_FILES