summaryrefslogtreecommitdiffstats
path: root/theme/setup.py
diff options
context:
space:
mode:
authorShankho Boron Ghosh <shankhoghosh123@gmail.com>2020-11-04 20:48:01 +0530
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-11-10 22:43:20 +0000
commit6b1ab1c2161da3cd7a3d54fe684906e73da23674 (patch)
tree43ffb329b1c418251e8fa7c140b3c5717c7365af /theme/setup.py
parentd03401d2cdcddf2bc24f4eff0954f69fa5aa61ec (diff)
Meta redirects to http://old-docs.automotivelinux.org/docs/en/icefish/getting_started/ Bug-AGL: [SPEC-3633] Signed-off-by: Shankho Boron Ghosh <shankhoghosh123@gmail.com> Change-Id: Ie6bfbc5821b8c158fb92a076d143d8e495ac5d89 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/documentation/+/25509 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'theme/setup.py')
-rw-r--r--theme/setup.py30
1 files changed, 30 insertions, 0 deletions
diff --git a/theme/setup.py b/theme/setup.py
new file mode 100644
index 0000000..444ca07
--- /dev/null
+++ b/theme/setup.py
@@ -0,0 +1,30 @@
+from setuptools import setup, find_packages
+
+VERSION = '1.0.4'
+
+setup(
+ name="mkdocs-windmill",
+ version=VERSION,
+ url='https://github.com/gristlabs/mkdocs-windmill',
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'License :: OSI Approved :: MIT License',
+ 'Topic :: Documentation',
+ 'Topic :: Text Processing',
+ ],
+ install_requires=[
+ 'mkdocs',
+ ],
+ license='MIT',
+ description='MkDocs theme focused on navigation and usability',
+ author='Dmitry S',
+ author_email='dmitry@getgrist.com',
+ packages=find_packages(),
+ include_package_data=True,
+ entry_points={
+ 'mkdocs.themes': [
+ 'windmill = mkdocs_windmill',
+ ]
+ },
+ zip_safe=False
+)