summaryrefslogtreecommitdiffstats
path: root/theme/setup.py
diff options
context:
space:
mode:
authorgrowupboron <shankhoghosh123@gmail.com>2020-09-11 17:18:57 +0530
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-09-11 12:11:56 +0000
commit4aad369c9728061c97b3de792286e743ee884b09 (patch)
tree14bddddeab334e3fdbdcf29446a87aa11cf6cd97 /theme/setup.py
parent619a7e48085be1538c3b01eb93dcb9dc95bf0436 (diff)
Simplified doc-site generationjellyfish_9.99.4jellyfish/9.99.49.99.4
Updated theme to windmill Using Mkdocs static site generator Deployed on readthedocs Signed-off-by: growupboron <shankhoghosh123@gmail.com> Change-Id: If62eaaea1855c91b64f687900f54eba6bc1caee8 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/documentation/+/25236 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'theme/setup.py')
-rw-r--r--theme/setup.py30
1 files changed, 30 insertions, 0 deletions
diff --git a/theme/setup.py b/theme/setup.py
new file mode 100644
index 0000000..444ca07
--- /dev/null
+++ b/theme/setup.py
@@ -0,0 +1,30 @@
+from setuptools import setup, find_packages
+
+VERSION = '1.0.4'
+
+setup(
+ name="mkdocs-windmill",
+ version=VERSION,
+ url='https://github.com/gristlabs/mkdocs-windmill',
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'License :: OSI Approved :: MIT License',
+ 'Topic :: Documentation',
+ 'Topic :: Text Processing',
+ ],
+ install_requires=[
+ 'mkdocs',
+ ],
+ license='MIT',
+ description='MkDocs theme focused on navigation and usability',
+ author='Dmitry S',
+ author_email='dmitry@getgrist.com',
+ packages=find_packages(),
+ include_package_data=True,
+ entry_points={
+ 'mkdocs.themes': [
+ 'windmill = mkdocs_windmill',
+ ]
+ },
+ zip_safe=False
+)