summaryrefslogtreecommitdiffstats
path: root/recipes-config
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-01-03 18:03:05 -0500
committerScott Murray <scott.murray@konsulko.com>2020-01-03 23:07:17 +0000
commit728764b79d6027b7d91cbb80e0ea690ba3c737d2 (patch)
treeebb815cf818758751eae1169004eca062c4c16e6 /recipes-config
parent46a5c08387cb501cb2b70e7cffb6d7518cbf0cbe (diff)
Add support for CAN driven speeds for the demo dashboardicefish_8.99.5icefish/8.99.58.99.5
Changes include: - Update cluster-dashboard recipe to pull in libqtappfw for signal-composer support - Add signal-composer and required low-can and gps bindings to agl-cluster-demo-platform image - Add recipe to install configuration file that tells the cluster-dashboard app to use signal-composer vehicle and engine speed events instead of running the default animation loop, and a new agl-cluster-demo-preload feature template that drives adding the recipe to the image for demo purposes. Bug-AGL: SPEC-3045 Change-Id: I193f9fd764b7610eaacc4c524522552bcc1e7ccc Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-config')
-rw-r--r--recipes-config/cluster-dashboard-demo-config/cluster-dashboard-demo-config_1.0.bb11
-rw-r--r--recipes-config/cluster-dashboard-demo-config/files/AGL.conf.cluster2
2 files changed, 13 insertions, 0 deletions
diff --git a/recipes-config/cluster-dashboard-demo-config/cluster-dashboard-demo-config_1.0.bb b/recipes-config/cluster-dashboard-demo-config/cluster-dashboard-demo-config_1.0.bb
new file mode 100644
index 0000000..f1fce78
--- /dev/null
+++ b/recipes-config/cluster-dashboard-demo-config/cluster-dashboard-demo-config_1.0.bb
@@ -0,0 +1,11 @@
+SUMMARY = "AGL cluster demo dashboard configuration file"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI += "file://AGL.conf.cluster"
+
+inherit allarch
+
+do_install() {
+ install -D -m 0644 ${WORKDIR}/AGL.conf.cluster ${D}${sysconfdir}/xdg/AGL.conf
+}
diff --git a/recipes-config/cluster-dashboard-demo-config/files/AGL.conf.cluster b/recipes-config/cluster-dashboard-demo-config/files/AGL.conf.cluster
new file mode 100644
index 0000000..dd8a912
--- /dev/null
+++ b/recipes-config/cluster-dashboard-demo-config/files/AGL.conf.cluster
@@ -0,0 +1,2 @@
+[dashboard]
+animation=false