aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-demo-hmi/cluster-dashboard/cluster-dashboard_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-01-03 18:03:05 -0500
committerScott Murray <scott.murray@konsulko.com>2020-01-03 18:03:05 -0500
commit82db42ed83c20eb019480cfc25a2e62ba12a532f (patch)
treeae84dd7e620b99d48b07255a2a258a2bd76bb489 /recipes-demo-hmi/cluster-dashboard/cluster-dashboard_git.bb
parentdb01daea8a39766cebc495ccae138f928c681837 (diff)
Add support for CAN driven speeds for the demo dashboardhalibut_8.0.6halibut_8.0.5halibut/8.0.6halibut/8.0.58.0.68.0.5halibut
Changes include: - Update cluster-dashboard recipe to pull in libqtappfw for signal-composer support - Add signal-composer and required low-can and gps bindings to agl-cluster-demo-platform image - Add recipe to install configuration file that tells the cluster-dashboard app to use signal-composer vehicle and engine speed events instead of running the default animation loop, and a new agl-cluster-demo-preload feature template that drives adding the recipe to the image for demo purposes. Bug-AGL: SPEC-3045 Change-Id: I193f9fd764b7610eaacc4c524522552bcc1e7ccc Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-demo-hmi/cluster-dashboard/cluster-dashboard_git.bb')
-rw-r--r--recipes-demo-hmi/cluster-dashboard/cluster-dashboard_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-demo-hmi/cluster-dashboard/cluster-dashboard_git.bb b/recipes-demo-hmi/cluster-dashboard/cluster-dashboard_git.bb
index 74974eb..5420d34 100644
--- a/recipes-demo-hmi/cluster-dashboard/cluster-dashboard_git.bb
+++ b/recipes-demo-hmi/cluster-dashboard/cluster-dashboard_git.bb
@@ -14,7 +14,7 @@ PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
# build-time dependencies
-DEPENDS += "qtquickcontrols2 qtwebsockets qlibwindowmanager"
+DEPENDS += "qtquickcontrols2 qtwebsockets qlibwindowmanager libqtappfw glib-2.0"
inherit pkgconfig cmake_qt5 aglwgt
@@ -24,6 +24,6 @@ RDEPENDS_${PN} += " \
qtquickcontrols-qmlplugins \
qtquickcontrols2 \
qtquickcontrols2-qmlplugins \
- qtwebsockets \
- qtwebsockets-qmlplugins \
+ libqtappfw \
+ agl-service-signal-composer \
"