summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLorenzo Tilve <ltilve@igalia.com>2021-01-12 13:49:57 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-01-13 17:45:50 +0000
commitb22e50de1d9cb4e98f7e2b36300a14f5de278bb9 (patch)
tree8204b86bbc9cde7e923604d2ab2f85c279c9eb73
parent8b0503c64094742a9dcee308b1127d41f20211d5 (diff)
web-runtime: Bump chromium79 and wam to adress first-frame dection and logging
Bump the versions of Chromium79 to include a workaround for the webapps launching delay that was introduced in order to address problems happening with first-frame detection. These updates also fix full WAM verbosity to journalctl when defined, and building Chromium with externalsrc, and removes lld and gold. Also iclude explicit dependency chain when building html5 dempo platform to packagegroup-agl-profile-graphical-html5. Bug-AGL: SPEC-3576 Bug-AGL: SPEC-3767 Signed-off-by: Lorenzo Tilve <ltilve@igalia.com> Change-Id: I34b0001c58522cfc7940d0384809e14e3d999ea8
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb1
-rw-r--r--recipes-wam/chromium/chromium79/0001-GCC-fix-includes-for-gcc-10.patch12
-rw-r--r--recipes-wam/chromium/chromium79_git.bb8
-rw-r--r--recipes-wam/wam/wam_git.bb2
4 files changed, 6 insertions, 17 deletions
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
index acfb9e64..d1ea021a 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
@@ -13,6 +13,7 @@ ALLOW_EMPTY_${PN} = "1"
RDEPENDS_${PN} += "\
packagegroup-agl-image-ivi \
+ packagegroup-agl-profile-graphical-html5 \
packagegroup-agl-demo \
"
diff --git a/recipes-wam/chromium/chromium79/0001-GCC-fix-includes-for-gcc-10.patch b/recipes-wam/chromium/chromium79/0001-GCC-fix-includes-for-gcc-10.patch
index c3f8abdf..45441d61 100644
--- a/recipes-wam/chromium/chromium79/0001-GCC-fix-includes-for-gcc-10.patch
+++ b/recipes-wam/chromium/chromium79/0001-GCC-fix-includes-for-gcc-10.patch
@@ -63,18 +63,6 @@ index cea607055..829ada6d0 100644
#define EGL_PLATFORM_ANGLE_PLATFORM_METHODS_ANGLEX 0x3482
-diff --git a/src/third_party/perfetto/include/perfetto/base/task_runner.h b/src/third_party/perfetto/include/perfetto/base/task_runner.h
-index cf6040123..02658e713 100644
---- a/src/third_party/perfetto/include/perfetto/base/task_runner.h
-+++ b/src/third_party/perfetto/include/perfetto/base/task_runner.h
-@@ -18,6 +18,7 @@
- #define INCLUDE_PERFETTO_BASE_TASK_RUNNER_H_
-
- #include <functional>
-+#include <cstdint>
-
- #include "perfetto/base/export.h"
-
diff --git a/src/third_party/webrtc/call/rtx_receive_stream.h b/src/third_party/webrtc/call/rtx_receive_stream.h
index 8ffa4400a..113a8168b 100644
--- a/src/third_party/webrtc/call/rtx_receive_stream.h
diff --git a/recipes-wam/chromium/chromium79_git.bb b/recipes-wam/chromium/chromium79_git.bb
index 37ebb41b..7f1ce11c 100644
--- a/recipes-wam/chromium/chromium79_git.bb
+++ b/recipes-wam/chromium/chromium79_git.bb
@@ -9,7 +9,7 @@ SRC_URI = "\
# Needed by catapult
DEPENDS += "python-six-native python-beautifulsoup4-native python-lxml-native python-html5lib-native python-webencodings-native"
-SRCREV_chromium79 = "c568380f34a275ed5430f3927b1bdee0e14220e0"
+SRCREV_chromium79 = "3499e08c510310e7dd99c9eb7830b90713a8f8e1"
SRCREV_v8 = "e876fd0e28bd3bda5815394874183b7e6079d440"
BROWSER_APPLICATION = "chromium79-browser"
@@ -24,7 +24,7 @@ GN_ARGS += "closure_compile=false"
# When using meta-clang, one can switch to using the lld linker
# by using the ld-is-lld distro feature otherwise use gold linker
-GN_ARGS += "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-lld', 'use_lld=true use_gold=false', 'use_lld=false use_gold=true', d)}"
+GN_ARGS += "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-lld', 'use_lld=true use_gold=false', bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', 'use_lld=false use_gold=true', 'use_lld=false use_gold=false', d), d)}"
# Toolchains we will use for the build. We need to point to the toolchain file
# we've created, set the right target architecture and make sure we are not
@@ -34,8 +34,8 @@ GN_ARGS += "\
cros_host_is_clang=false \
use_custom_libcxx_for_host=false \
cros_host_ar=\"${BUILD_AR}\" \
- cros_host_cc=\"${BUILD_CC}\" \
- cros_host_cxx=\"${BUILD_CXX}\" \
+ cros_host_cc=\"${BUILD_CC} ${BUILD_CFLAGS}\" \
+ cros_host_cxx=\"${BUILD_CXX} ${BUILD_CXXFLAGS}\" \
cros_host_extra_ldflags=\"${BUILD_LDFLAGS}\" \
custom_toolchain=\"//build/toolchain/cros:target\" \
is_clang=false \
diff --git a/recipes-wam/wam/wam_git.bb b/recipes-wam/wam/wam_git.bb
index ab3a1ae0..a09473ab 100644
--- a/recipes-wam/wam/wam_git.bb
+++ b/recipes-wam/wam/wam_git.bb
@@ -31,7 +31,7 @@ SRC_URI = "\
file://trunc-webapp-roles.patch \
"
S = "${WORKDIR}/git"
-SRCREV = "88e9df41cf6dfbcb5d2ea10c769a44e69171a1c3"
+SRCREV = "a9f18b049d319865514f5f92b248ecdf9c09761d"
do_install_append() {
install -d ${D}${sysconfdir}/wam