summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2018-06-19 14:37:23 +0900
committerStéphane Desneux <stephane.desneux@iot.bzh>2018-06-28 19:12:38 +0000
commitb6c5e9e4b360c334212e5f3c8a0fb33cfb295f87 (patch)
tree1384cfff3ee44613031793dbd02f4849ae29f0d1
parentb4d34cde29a7e5a2f39749c2244b404f675823b0 (diff)
mixer app: bump to latest revision when 4A is enabled
This patch does 2 things: * pin version eel_5.0.3 when 4A is not enabled * use AGL_APP_REVISION when 4A is enabled In the second case, this will pop the following changes in mixer: * 62bb1f0 WIP version based on 4a High Level API * 2aabd6a Add some ignore in .gitignore * d192c51 Make use of afb-helpers submodule * e1fe0c6 Add special permission to the mixer * 21994ea Remove nasty hack to handle HALs * f35abba make of use of app templates to import right HALs depending on compilation options * 6bf2ccb make use of alsacore and hal bindings to control audio volume Change-Id: I5408100aacacb14fe581cf89535bf9b66de0189f Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
-rw-r--r--recipes-demo-hmi/mixer/mixer_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes-demo-hmi/mixer/mixer_git.bb b/recipes-demo-hmi/mixer/mixer_git.bb
index bdbc8db64..ea335990e 100644
--- a/recipes-demo-hmi/mixer/mixer_git.bb
+++ b/recipes-demo-hmi/mixer/mixer_git.bb
@@ -7,7 +7,11 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mixer;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "${AGL_APP_REVISION}"
+
+# 'legacy' version (eel_5.0.3) when 4A is not enabled
+SRCREV = "eel_5.0.3"
+# 4A-aware mixer
+SRVREV_agl-audio-4a-framework = "${AGL_APP_REVISION}"
PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
'>149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177
/*
 * Copyright (C) 2015, 2016 ,2017 "IoT.bzh"
 * Author "Romain Forlot" <romain.forlot@iot.bzh>
 * Author "Loïc Collignon" <loic.collignon@iot.bzh>
 * Licensed under the Apache License, Version 2.0 (the "License");
 * you may not use this file except in compliance with the License.
 * You may obtain a copy of the License at
 *
 *	 http://www.apache.org/licenses/LICENSE-2.0
 *
 * Unless required by applicable law or agreed to in writing, software
 * distributed under the License is distributed on an "AS IS" BASIS,
 * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
 * See the License for the specific language governing permissions and
 * limitations under the License.
 */

#include <unistd.h>
#include <string>
#include <linux/can/raw.h>
#include <net/if.h>
#include <sys/ioctl.h>

#include "socketcan.hpp"
#include "can-message.hpp"

namespace utils
{

	/// @brief Construct a default, invalid, socket.
	socketcan_t::socketcan_t()
		: socket_{INVALID_SOCKET}
	{}

	/// @brief Construct a socket by moving an existing one.
	socketcan_t::socketcan_t(socketcan_t&& s)
		: socket_{s.socket_}
	{
		s.socket_ = INVALID_SOCKET;
	}

	/// @brief Destruct the socket.
	socketcan_t::~socketcan_t()
	{
		if(socket_ != INVALID_SOCKET)
			::close(socket_);
	}

	const struct sockaddr_can& socketcan_t::get_tx_address() const
	{
		return tx_address_;
	}

	/// @brief Test if socket is valid.
	/// @return true if valid, false otherwise.
	socketcan_t::operator bool() const
	{
		return socket_ != INVALID_SOCKET;
	}

	/// @brief Open the socket.
	/// @param[in] domain Specifies the communications domain in which a socket is to be created.
	/// @param[in] type Specifies the type of socket to be created.
	/// @param[in] protocol Specifies a particular protocol to be used with the socket. Specifying a protocol of 0 causes socket() to use an unspecified default protocol appropriate for the requested socket type.
	/// @return Upon successful completion, shall return a non-negative integer, the socket file descriptor. Otherwise, a value of -1 shall be returned and errno set to indicate the error.
	int socketcan_t::open(int domain, int type, int protocol)
	{
		close();
		socket_ = ::socket(domain, type, protocol);
		return socket_;
	}

	/// @brief Close the socket.
	/// @return 0 if success.
	int socketcan_t::close()
	{
		return socket_ != INVALID_SOCKET ? ::close(socket_) : 0;
	}

	/// @brief Set socket option.
	/// @return 0 if success.
	int socketcan_t::setopt(int level, int optname, const void* optval, socklen_t optlen)
	{
		return socket_ != INVALID_SOCKET ? ::setsockopt(socket_, level, optname, optval, optlen) : 0;
	}

	/// @brief Bind the socket.
	/// @return 0 if success.
	int socketcan_t::bind(const struct sockaddr* addr, socklen_t len)
	{
		return socket_ != INVALID_SOCKET ? ::bind(socket_, addr, len) : 0;
	}

	/// @brief Connect the socket.
	/// @return 0 if success.
	int socketcan_t::connect(const struct sockaddr* addr, socklen_t len)
	{
		return socket_ != INVALID_SOCKET ? ::connect(socket_, addr, len) : 0;
	}

	/// @brief Get the file descriptor.
	/// @return The socket's file descriptor
	int socketcan_t::socket() const
	{
		return socket_;
	}

	/// @brief Open a raw socket CAN.
	/// @param[in] device_name is the kernel network device name of the CAN interface.
	///
	/// @return Upon successful completion, shall return a non-negative integer, the socket file descriptor. Otherwise, a value of -1 shall be returned and errno set to indicate the error.
	int socketcan_t::open(std::string device_name)
	{
		close();
		
		struct ifreq ifr;
		socket_ = ::socket(PF_CAN, SOCK_DGRAM, CAN_BCM);

		// Attempts to open a socket to CAN bus
		::strcpy(ifr.ifr_name, device_name.c_str());
		DEBUG(binder_interface, "%s: ifr_name is : %s", __FUNCTION__, ifr.ifr_name);
		if(::ioctl(socket_, SIOCGIFINDEX, &ifr) < 0)
		{
			ERROR(binder_interface, "%s: ioctl failed. Error was : %s", __FUNCTION__, strerror(errno));
			close();
		}
		else
		{
			tx_address_.can_family = AF_CAN;
			tx_address_.can_ifindex = ifr.ifr_ifindex;

			if(connect((struct sockaddr *)&tx_address_, sizeof(tx_address_)) < 0)
			{
				ERROR(binder_interface, "%s: Connect failed. %s", __FUNCTION__, strerror(errno));
				close();
			}
		}
		return socket_;
	}

	socketcan_t& operator>>(socketcan_t& s, const can_message_t& cm)
	{
		struct {
			struct bcm_msg_head msg_head;
			struct can_frame frames;
		} msg;

		struct sockaddr_can addr = s.get_tx_address();
		socklen_t addrlen = sizeof(addr);
		struct ifreq ifr;

		ssize_t nbytes = ::recvfrom(s.socket(), &msg, sizeof(msg), 0, (struct sockaddr*)&addr, &addrlen);
		ifr.ifr_ifindex = addr.can_ifindex;
		ioctl(s.socket(), SIOCGIFNAME, &ifr);

		printf("Data available: %i bytes read\n", (int)nbytes);
		printf("read: Found on bus %s:\n id: %X, length: %X, data %02X%02X%02X%02X%02X%02X%02X%02X\n", ifr.ifr_name, msg.msg_head.can_id, msg.frames.len,
			msg.frames.data[0], msg.frames.data[1], msg.frames.data[2], msg.frames.data[3], msg.frames.data[4], msg.frames.data[5], msg.frames.data[6], msg.frames.data[7]);

		
		return s;
	}

	socketcan_t& operator<<(socketcan_t& s, const struct basic_bcm_msg<struct can_frame>& obj)
	{
		s << obj.msg_head;
		s << obj.frames;
		return s;
	}

	socketcan_t& operator<<(socketcan_t& s, const struct canfd_bcm_msg& obj)
	{
		s << obj.msg_head;
		s << obj.frames;
		return s;
	}
}