summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoel Winarske <joel.winarske@gmail.com>2024-09-09 17:05:48 -0700
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-09-10 13:32:28 +0000
commitb81e1c60cbfae4b48ba99f1af3bbbf8a9c69a43c (patch)
treeab8fa73b2002f21987bdb54ae5d0707c252f0c8e
parent65e6910f05a65aff631187ff8576e471b5798bf1 (diff)
-ignore pubspec.lock file -disable network access for do_compile -remove loop to install config.toml; now handled by meta-flutter Change-Id: Icdfb240c330e98a90cf05ca4f0acfbcd935bf89a Signed-off-by: Joel Winarske <joel.winarske@gmail.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30270 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> (cherry picked from commit 82c703554b58474c366108cced2d6bb2767d56cd) Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30282 Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb11
-rw-r--r--recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb12
2 files changed, 4 insertions, 19 deletions
diff --git a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
index b510a88bf..41d806e6b 100644
--- a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
+++ b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
@@ -31,22 +31,15 @@ inherit flutter-app update-alternatives systemd
APP_CONFIG = "flutter_cluster_dashboard_on_bg.toml"
-SYSTEMD_SERVICE:${PN} = "flutter-cluster-dashboard.service"
+PUBSPEC_IGNORE_LOCKFILE = "1"
-do_compile[network] = "1"
+SYSTEMD_SERVICE:${PN} = "flutter-cluster-dashboard.service"
do_install:append() {
install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
install -D -m 0644 ${WORKDIR}/kvm.conf ${D}${systemd_system_unitdir}/${BPN}.service.d/kvm.conf
- # determine build type based on what flutter-engine installed.
- for runtime_mode in ${FLUTTER_RUNTIME_MODES}
- do
- install -D -m 0644 ${WORKDIR}/${APP_CONFIG} \
- ${D}${datadir}/flutter/${PUBSPEC_APPNAME}/${FLUTTER_SDK_VERSION}/${runtime_mode}/config.toml
- done
-
install -d ${D}${sysconfdir}/xdg/AGL/cluster-dashboard
install -m 0644 ${WORKDIR}/cluster-dashboard.yaml ${D}${sysconfdir}/xdg/AGL/cluster-dashboard.yaml.default
install -m 0644 ${WORKDIR}/cluster-dashboard.yaml.demo ${D}${sysconfdir}/xdg/AGL/
diff --git a/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb b/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
index 508df276a..542ecb30a 100644
--- a/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
+++ b/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
@@ -27,6 +27,8 @@ inherit flutter-app systemd update-alternatives
APP_CONFIG = "ics-homescreen.toml"
+PUBSPEC_IGNORE_LOCKFILE = "1"
+
SYSTEMD_SERVICE:${PN} = "flutter-ics-homescreen.service"
# Disable the background animation on all platforms except the Renesas M3/H3 for now
@@ -34,21 +36,11 @@ DISABLE_BG_ANIMATION = "-DDISABLE_BKG_ANIMATION=true"
DISABLE_BG_ANIMATION:rcar-gen3 = ""
APP_AOT_EXTRA:append = " ${DISABLE_BG_ANIMATION}"
-do_compile[network] = "1"
-
do_install:append() {
install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
install -D -m 0644 ${WORKDIR}/kvm.conf ${D}${systemd_system_unitdir}/${BPN}.service.d/kvm.conf
- # determine build type based on what flutter-engine installed.
- for runtime_mode in ${FLUTTER_RUNTIME_MODES}
- do
- install -D -m 0644 ${WORKDIR}/${APP_CONFIG} \
- ${D}${datadir}/flutter/${PUBSPEC_APPNAME}/${FLUTTER_SDK_VERSION}/${runtime_mode}/config.toml
- done
-
-
# VIS authorization token file for KUKSA.val should ideally not
# be readable by other users, but currently that's not doable
# until a packaging/sandboxing/MAC scheme is (re)implemented or