summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Dapena Paz <jdapena@igalia.com>2022-05-31 19:56:05 +0200
committerJose Dapena Paz <jdapena@igalia.com>2022-07-19 20:30:37 +0200
commit1f2eba7c64b20ef7753606edbe5afb6078334963 (patch)
treed4904895600bdede5bb9eafd5a00f50a125a626e
parent08977ac24f2d31b0955786824c9ff62eff981ee9 (diff)
html5-aquarium, html5-youtube added
Added two web demos (WebGL aquarium and Youtube launcher). Bug-AGL: SPEC-4392, SPEC-4248 Change-Id: I3e1e7a098d432d5d1c8de4640780ef05abf0e9f2 Signed-off-by: Jose Dapena Paz <jdapena@igalia.com>
-rw-r--r--recipes-demo/webapp-samples/files/webapps-aquarium.desktop11
-rw-r--r--recipes-demo/webapp-samples/files/webapps-youtube.desktop11
-rw-r--r--recipes-demo/webapp-samples/html5-aquarium_git.bb11
-rw-r--r--recipes-demo/webapp-samples/html5-youtube_git.bb11
-rw-r--r--recipes-demo/webapp-samples/webapp-samples.inc26
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb2
6 files changed, 72 insertions, 0 deletions
diff --git a/recipes-demo/webapp-samples/files/webapps-aquarium.desktop b/recipes-demo/webapp-samples/files/webapps-aquarium.desktop
new file mode 100644
index 00000000..49ae05a5
--- /dev/null
+++ b/recipes-demo/webapp-samples/files/webapps-aquarium.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Name=HTML5 Aquarium
+Comment=Aquarium
+GenericName=Aquarium
+Exec=/usr/bin/WebAppMgr --appid=webapps-aquarium --app-install-dir=/usr/lib/wam_apps/html5-aquarium/
+Icon=settings
+Terminal=false
+Type=Application
+Categories=System;
+StartupNotify=true
diff --git a/recipes-demo/webapp-samples/files/webapps-youtube.desktop b/recipes-demo/webapp-samples/files/webapps-youtube.desktop
new file mode 100644
index 00000000..71faa0f6
--- /dev/null
+++ b/recipes-demo/webapp-samples/files/webapps-youtube.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Name=HTML5 YouTube
+Comment=YouTube
+GenericName=YouTube
+Exec=/usr/bin/WebAppMgr --appid=webapps-youtube --app-install-dir=/usr/lib/wam_apps/html5-youtube/
+Icon=settings
+Terminal=false
+Type=Application
+Categories=System;
+StartupNotify=true
diff --git a/recipes-demo/webapp-samples/html5-aquarium_git.bb b/recipes-demo/webapp-samples/html5-aquarium_git.bb
new file mode 100644
index 00000000..08367841
--- /dev/null
+++ b/recipes-demo/webapp-samples/html5-aquarium_git.bb
@@ -0,0 +1,11 @@
+SUMMARY = "AGL HTML5 Aquarium Demo"
+LICENSE = "BSD-3"
+LIC_FILES_CHKSUM = "file://aquarium/LICENSE;md5=9f0d95e61aa217eacd61ee6833cf411c"
+DESKTOP_FILE = "webapps-aquarium.desktop"
+
+require webapp-samples.inc
+
+do_install:append() {
+ cp -R --no-dereference --preserve=mode,links ${S}/aquarium/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+}
+
diff --git a/recipes-demo/webapp-samples/html5-youtube_git.bb b/recipes-demo/webapp-samples/html5-youtube_git.bb
new file mode 100644
index 00000000..8f45c42b
--- /dev/null
+++ b/recipes-demo/webapp-samples/html5-youtube_git.bb
@@ -0,0 +1,11 @@
+SUMMARY = "AGL HTML5 Youtube"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7ea5dd8751060d9f04d2748030c547ed"
+DESKTOP_FILE = "webapps-youtube.desktop"
+
+require webapp-samples.inc
+
+do_install:append() {
+ cp -R --no-dereference --preserve=mode,links ${S}/youtube/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+}
+
diff --git a/recipes-demo/webapp-samples/webapp-samples.inc b/recipes-demo/webapp-samples/webapp-samples.inc
new file mode 100644
index 00000000..f2d61a09
--- /dev/null
+++ b/recipes-demo/webapp-samples/webapp-samples.inc
@@ -0,0 +1,26 @@
+HOMEPAGE = "https://github.com/AGL-web-applications/webapp-samples"
+SECTION = "apps"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+B = "${WORKDIR}/build"
+
+SRC_URI = " \
+ git://github.com/AGL-web-applications/webapp-samples.git;protocol=https;branch=master \
+ file://${DESKTOP_FILE} \
+"
+SRCREV = "b24a62cc524bdec98a61acc03fc53cbab24c1571"
+
+WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
+APPLICATIONS_DIR="${datadir}/applications"
+
+do_install() {
+ install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
+ install -d ${D}${APPLICATIONS_DIR}
+ install ${WORKDIR}/${DESKTOP_FILE} ${D}${APPLICATIONS_DIR}
+}
+
+FILES:${PN} = " \
+ ${WAM_APPLICATIONS_DIR}/${PN} \
+ ${APPLICATIONS_DIR} \
+"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
index 06df05ec..53159ba3 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
@@ -25,6 +25,8 @@ AGL_APPS = " \
html5-mediaplayer \
html5-mixer \
html5-settings \
+ html5-aquarium \
+ html5-youtube \
"
RDEPENDS:${PN}:append = " \