summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAakash Solanki <tech2aks@gmail.com>2022-10-29 16:21:34 +0200
committerAakash Solanki <tech2aks@gmail.com>2022-10-29 16:28:31 +0200
commit7832492d87871cfb382b58c1eeb9f182537c0c60 (patch)
treedbda16a87c711ccd156e43dc7fe15fc5b9cb3ba3
parent2c0ca4f324f997f2ba3173655f73ae1c5ce0dc89 (diff)
Update flutter-cluster-dashboard
- Import all flutter-cluster-dashboard changes from master. - Add 'flutter-cluster-dashboard.yaml' file. - Set openrouteservice API Key in local.conf to the variable `OPENROUTE_API_KEY`. - Change SRCREV and SRC_URI Bug-AGL: SPEC-4508 Change-Id: Ic1cd18e290c951443b393840bcf053a549fd2ee2 Signed-off-by: Aakash Solanki <tech2aks@gmail.com>
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/flutter-cluster-dashboard.yaml6
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-debug.json17
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-profile.json18
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-release.json11
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-debug.json11
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-profile.json11
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-release.json10
-rw-r--r--recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb37
-rw-r--r--recipes-demo/kuksa-vss-init/files/kuksa_vss_init.py13
9 files changed, 91 insertions, 43 deletions
diff --git a/recipes-demo/flutter-cluster-dashboard/files/flutter-cluster-dashboard.yaml b/recipes-demo/flutter-cluster-dashboard/files/flutter-cluster-dashboard.yaml
new file mode 100644
index 00000000..35f5bdfd
--- /dev/null
+++ b/recipes-demo/flutter-cluster-dashboard/files/flutter-cluster-dashboard.yaml
@@ -0,0 +1,6 @@
+hostname: localhost
+port: 8090
+homeLat: 31.708643
+homeLng: 76.931882
+orsPathParam: driving-car
+kuskaAuthToken: eyJ0eXAiOiJKV1QiLCJhbGciOiJSUzI1NiJ9.eyJzdWIiOiJrdWtzYS52YWwiLCJpc3MiOiJFY2xpcHNlIEtVS1NBIERldiIsImFkbWluIjp0cnVlLCJpYXQiOjE1MTYyMzkwMjIsImV4cCI6MTc2NzIyNTU5OSwia3Vrc2EtdnNzIjp7IioiOiJydyJ9fQ.QQcVR0RuRJIoasPXYsMGZhdvhLjUalk4GcRaxhh3-0_j3CtVSZ0lTbv_Z3As5BfIYzaMlwUzFGvCVOq2MXVjRK81XOAZ6wIsyKOxva16zjbZryr2V_m3yZ4twI3CPEzJch11_qnhInirHltej-tGg6ySfLaTYeAkw4xYGwENMBBhN5t9odANpScZP_xx5bNfwdW1so6FkV1WhpKlCywoxk_vYZxo187d89bbiu-xOZUa5D-ycFkd1-1rjPXLGE_g5bc4jcQBvNBc-5FDbvt4aJlTQqjpdeppxhxn_gjkPGIAacYDI7szOLC-WYajTStbksUju1iQCyli11kPx0E66me_ZVwOX07f1lRF6D2brWm1LcMAHM3bQUK0LuyVwWPxld64uSAEsvSKsRyJERc7nZUgLf7COnUrrkxgIUNjukbdT2JVN_I-3l3b4YXg6JVD7Y5g0QYBKgXEFpZrDbBVhzo7PXPAhJD6-c3DcUQyRZExbrnFV56RwWuExphw8lYnbMvxPWImiVmB9nRVgFKD0TYaw1sidPSSlZt8Uw34VZzHWIZQAQY0BMjR33fefg42XQ1YzIwPmDx4GYXLl7HNIIVbsRsibKaJnf49mz2qnLC1K272zXSPljO11Ke1MNnsnKyUH7mcwEs9nhTsnMgEOx_TyMLRYo-VEHBDLuEOiBo
diff --git a/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-debug.json b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-debug.json
new file mode 100644
index 00000000..3d92b45f
--- /dev/null
+++ b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-debug.json
@@ -0,0 +1,17 @@
+{
+ "view": [
+ {
+ "window_type": "BG",
+ "bundle_path": "/usr/share/flutter/flutter_cluster_dashboard",
+ "vm_args": [
+ "--observatory-host",
+ "0.0.0.0",
+ "--observatory-port",
+ "1234"
+ ],
+ "width": 1920,
+ "height": 1080,
+ "fullscreen": true
+ }
+ ]
+} \ No newline at end of file
diff --git a/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-profile.json b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-profile.json
new file mode 100644
index 00000000..aca303fb
--- /dev/null
+++ b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-profile.json
@@ -0,0 +1,18 @@
+{
+ "view": [
+ {
+ "window_type": "BG",
+ "bundle_path": "/usr/share/flutter/flutter_cluster_dashboard",
+ "vm_args": [
+ "--observatory-host",
+ "0.0.0.0",
+ "--observatory-port",
+ "1234",
+ "--start-paused"
+ ],
+ "width": 1920,
+ "height": 1080,
+ "fullscreen": true
+ }
+ ]
+} \ No newline at end of file
diff --git a/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-release.json b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-release.json
new file mode 100644
index 00000000..eb75dc4f
--- /dev/null
+++ b/recipes-demo/flutter-cluster-dashboard/files/flutter_cluster_dashboard_on_bg-release.json
@@ -0,0 +1,11 @@
+{
+ "view": [
+ {
+ "window_type": "BG",
+ "bundle_path": "/usr/share/flutter/flutter_cluster_dashboard",
+ "width": 1920,
+ "height": 1080,
+ "fullscreen": true
+ }
+ ]
+} \ No newline at end of file
diff --git a/recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-debug.json b/recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-debug.json
deleted file mode 100644
index 3cee3508..00000000
--- a/recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-debug.json
+++ /dev/null
@@ -1,11 +0,0 @@
-{
- "view" : [ {
- "window_type" : "BG",
- "bundle_path" : "/usr/share/flutter/ic",
- "vm_args":["--observatory-host", "0.0.0.0", "--observatory-port", "1234"],
- "width" : 1920,
- "height": 1080,
- "fullscreen": true
- }
- ]
-}
diff --git a/recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-profile.json b/recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-profile.json
deleted file mode 100644
index c7ea10fa..00000000
--- a/recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-profile.json
+++ /dev/null
@@ -1,11 +0,0 @@
-{
- "view" : [ {
- "window_type" : "BG",
- "bundle_path" : "/usr/share/flutter/ic",
- "vm_args":["--observatory-host", "0.0.0.0", "--observatory-port", "1234", "--start-paused"],
- "width" : 1920,
- "height": 1080,
- "fullscreen": true
- }
- ]
-}
diff --git a/recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-release.json b/recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-release.json
deleted file mode 100644
index fdff54f7..00000000
--- a/recipes-demo/flutter-cluster-dashboard/files/ic_on_bg-release.json
+++ /dev/null
@@ -1,10 +0,0 @@
-{
- "view" : [ {
- "window_type" : "BG",
- "bundle_path" : "/usr/share/flutter/ic",
- "width" : 1920,
- "height": 1080,
- "fullscreen": true
- }
- ]
-}
diff --git a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
index 44be070f..aa5343da 100644
--- a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
+++ b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
@@ -1,35 +1,44 @@
SUMMARY = "Flutter Instrument Cluster "
DESCRIPTION = "An instrument cluster app written in dart for the flutter runtime"
AUTHOR = "Aakash Solanki"
-HOMEPAGE = "https://github.com/aakash-s45/ic"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/flutter-instrument-cluster"
SECTION = "graphics"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE.md;md5=0c52b0e4b5f0dbf57ea7d44bebb2e29d"
-SRC_URI = "git://github.com/aakash-s45/ic;protocol=https;branch=main \
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-instrument-cluster;protocol=https;branch=${AGL_BRANCH} \
file://flutter-cluster-dashboard.service \
- file://ic_on_bg-debug.json \
- file://ic_on_bg-profile.json \
- file://ic_on_bg-release.json \
+ file://flutter_cluster_dashboard_on_bg-debug.json \
+ file://flutter_cluster_dashboard_on_bg-profile.json \
+ file://flutter_cluster_dashboard_on_bg-release.json \
+ file://flutter-cluster-dashboard.yaml \
"
PV = "1.0+git${SRCPV}"
-SRCREV = "32f72bb68142a0dbde9ccf28b27c445598c95112"
+SRCREV = "5e0cf02b4e11d67ce8b705479e13e0b9ebbf8ad4"
S = "${WORKDIR}/git"
-PUBSPEC_APPNAME = "ic"
+PUBSPEC_APPNAME = "flutter_cluster_dashboard"
FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
+OPENROUTE_API_KEY ??= "YOU_NEED_TO_SET_IT_IN_LOCAL_CONF"
+
inherit flutter-app
-APP_CONFIG = "ic_on_bg-release.json"
-APP_CONFIG:class-runtimedebug = "ic_on_bg-debug.json"
-APP_CONFIG:class-runtimeprofile = "ic_on_bg-profile.json"
+APP_CONFIG = "flutter_cluster_dashboard_on_bg-release.json"
+APP_CONFIG:class-runtimedebug = "flutter_cluster_dashboard_on_bg-debug.json"
+APP_CONFIG:class-runtimeprofile = "flutter_cluster_dashboard_on_bg-profile.json"
+
+do_configure:prepend() {
+ if [ "${OPENROUTE_API_KEY}" = "YOU_NEED_TO_SET_IT_IN_LOCAL_CONF" ]; then
+ bbwarn "WARNING: You should set openrouteservice API key to OPENROUTE_API_KEY variable in local.conf."
+ fi
+}
do_install:append() {
install -D -m 0644 ${WORKDIR}/flutter-cluster-dashboard.service ${D}${systemd_user_unitdir}/flutter-cluster-dashboard.service
@@ -37,7 +46,13 @@ do_install:append() {
ln -s ../flutter-cluster-dashboard.service ${D}${systemd_user_unitdir}/agl-session.target.wants/flutter-cluster-dashboard.service
install -D -m 0644 ${WORKDIR}/${APP_CONFIG} ${D}${datadir}/flutter/default.json
+
+ install -d ${D}${sysconfdir}/xdg/AGL
+ install -m 0644 ${WORKDIR}/flutter-cluster-dashboard.yaml ${D}${sysconfdir}/xdg/AGL/
+
+ install -m 0755 -d ${D}${sysconfdir}/default/
+ echo 'OPENROUTE_API_KEY:${OPENROUTE_API_KEY}' >> ${D}${sysconfdir}/default/openroutekey
}
-FILES:${PN} += "${datadir} ${systemd_user_unitdir}"
+FILES:${PN} += "${datadir} ${systemd_user_unitdir} ${sysconfdir}/xdg/AGL ${sysconfdir}/default/"
diff --git a/recipes-demo/kuksa-vss-init/files/kuksa_vss_init.py b/recipes-demo/kuksa-vss-init/files/kuksa_vss_init.py
index 5453112c..0177e3c1 100644
--- a/recipes-demo/kuksa-vss-init/files/kuksa_vss_init.py
+++ b/recipes-demo/kuksa-vss-init/files/kuksa_vss_init.py
@@ -50,6 +50,12 @@ class VSS:
self.cruiseControlSpeedSet = "Vehicle.ADAS.CruiseControl.SpeedSet"
self.cruiseControlisActive = "Vehicle.ADAS.CruiseControl.IsActive"
self.batteryChargingStatus = "Vehicle.Powertrain.Battery.Charging.Status"
+ #
+ self.currLat = "Vehicle.Cabin.Infotainment.Navigation.CurrentLocation.Latitude"
+ self.currLng = "Vehicle.Cabin.Infotainment.Navigation.CurrentLocation.Longitude"
+ self.desLat = "Vehicle.Cabin.Infotainment.Navigation.DestinationSet.Latitude"
+ self.desLng = "Vehicle.Cabin.Infotainment.Navigation.DestinationSet.Longitude"
+ self.steeringInfo = "Vehicle.Cabin.SteeringWheel.Switches.Info"
def setInitialValues(self):
print("Setting values")
@@ -74,6 +80,13 @@ class VSS:
self.client.setValue(self.cruiseControlisActive, "false")
self.client.setValue(self.cruiseControlSpeedSet, '60')
self.client.setValue(self.batteryChargingStatus, "true")
+ #
+ self.client.setValue(self.currLat, "31.708643")
+ self.client.setValue(self.currLng, "76.931882")
+ self.client.setValue(self.desLat, "31.781456")
+ self.client.setValue(self.desLng, "76.997469")
+ # Show the map
+ self.client.setValue(self.steeringInfo, "true")
print("All value set succesfully")