summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoger Zanoni <rzanoni@igalia.com>2023-02-21 12:35:40 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-03-23 10:19:24 +0000
commitf9004968a0e9f3e5fc075c4df474f9fa33225e6d (patch)
tree41f2f7cc6cbd82fa5ba898bd81bf30ceb9fc0a87
parentfeceeb931c9c940026e93753c37ad9e0721fe47d (diff)
nss: Create a nss database for agl-driver user
The change creates an empty db and allows other recipes to add their own certificates when needed. It will be needed by kuksa-val recipe for adding its root CA certificate that will fix CA validation issues that are happening on chromium. v2 (jsmoeller): convert to own recipe to avoid modifying nss itself Bug-AGL: SPEC-4599 Signed-off-by: Roger Zanoni <rzanoni@igalia.com> Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I5a5e4ff24cb640580cff4c609ee6293acae64487
-rw-r--r--recipes-core/nss/nss-agl-driver-db_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-core/nss/nss-agl-driver-db_git.bb b/recipes-core/nss/nss-agl-driver-db_git.bb
new file mode 100644
index 00000000..ba203d4e
--- /dev/null
+++ b/recipes-core/nss/nss-agl-driver-db_git.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Custom nss db hosting the kuksa certificates"
+DESCRIPTION = "Custom nss db hosting the kuksa certificates for chromium"
+AUTHOR = "Jan-Simon Moeller <jsmoeller@linuxfoundation.org>"
+HOMEPAGE = "https://git.automotivelinux.org"
+LICENSE = "MIT"
+DEPENDS = " agl-session nss-native"
+PV = "0.1"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+ mkdir -p ${D}/home/agl-driver/.pki/nssdb
+ certutil -N -d ${D}/home/agl-driver/.pki/nssdb --empty-password
+}
+
+pkg_postinst_ontarget:${PN} () {
+ chown agl-driver:agl-driver -R /home/agl-driver/.pki/
+}
+
+FILES:${PN} += "/home/agl-driver/.pki/*"