summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntia Puentes <apuentes@igalia.com>2020-08-07 22:46:08 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-08-11 16:27:42 +0000
commitf2770f57537b7b8f61fbcb47185253e5edbdbff8 (patch)
treeafa6f98a951d68b213f0df65f5ca3acdef034856
parentf94200a7bff05126eb74df1fd2933d766dda7708 (diff)
html5-background: (new) Added recipe
Bug-AGL: SPEC-3497 Signed-off-by: Antia Puentes <apuentes@igalia.com> Change-Id: Ic70838f19c268b836e364b1d52e77b4e80156e1b
-rw-r--r--recipes-demo-hmi/html5-background/html5-background_git.bb13
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb1
2 files changed, 14 insertions, 0 deletions
diff --git a/recipes-demo-hmi/html5-background/html5-background_git.bb b/recipes-demo-hmi/html5-background/html5-background_git.bb
new file mode 100644
index 000000000..c0ac220f5
--- /dev/null
+++ b/recipes-demo-hmi/html5-background/html5-background_git.bb
@@ -0,0 +1,13 @@
+SUMMARY = "AGL HTML5 Background Application"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git/"
+
+SRC_URI = "git://github.com/AGL-web-applications/background.git;protocol=https;branch=master"
+SRCREV = "3b8dae349d428c0230b9885f86d421d43cda5638"
+
+DEPENDS = "nodejs-native"
+
+inherit aglwgt
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
index 6ec717bd0..176bfefd9 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
@@ -25,6 +25,7 @@ AGL_APPS = " \
html5-mixer \
html5-mediaplayer \
html5-dashboard \
+ html5-background \
"
RDEPENDS_${PN}_append = " \
183'>183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341
# DBC mappings for other signals for V2C demo

# DBC mappings for demo HVAC

Vehicle.Cabin.HVAC.Station.Row1.Driver.Temperature:
  datatype: int8
  type: actuator
  vss2dbc:
    signal: PT_TempLeft

Vehicle.Cabin.HVAC.Station.Row1.Passenger.Temperature:
  datatype: int8
  type: actuator
  vss2dbc:
    signal: PT_TempRight

Vehicle.Cabin.HVAC.Station.Row1.Driver.FanSpeed:
  datatype: uint8
  type: actuator
  vss2dbc:
    signal: PT_FanSpeed

#
# AGL VSS additions
#

# Extra navigation state signals

Vehicle.Cabin.Infotainment.Navigation.State:
  datatype: string
  type: sensor
  allowed: [ 'UNKNOWN', 'ACTIVE', 'ARRIVED', 'STOPPED' ]
  description: Navigation state.

Vehicle.Cabin.Infotainment.Navigation.ElapsedDistance:
  datatype: float
  type: sensor
  unit: km
  description: Navigation elapsed distance.


# Extra audio control signals

Vehicle.Cabin.Infotainment.Media.Audio:
  type: branch
  description: Media audio controls.

Vehicle.Cabin.Infotainment.Media.Audio.Balance:
  datatype: int8
  type: actuator
  min: -100
  max: 100
  unit: percent
  description: Audio left/right balance.

Vehicle.Cabin.Infotainment.Media.Audio.Fade:
  datatype: int8
  type: actuator
  min: -100
  max: 100
  unit: percent
  description: Audio front/rear balance.

Vehicle.Cabin.Infotainment.Media.Audio.Bass:
  datatype: int8
  type: actuator
  min: -100
  max: 100
  unit: percent
  description: Audio low-frequency filter control.

Vehicle.Cabin.Infotainment.Media.Audio.Treble:
  datatype: int8
  type: actuator
  min: -100
  max: 100
  unit: percent
  description: Audio high-frequency filter control.


# Extra steering wheel switch signals, including DBC mappings

Vehicle.Cabin.SteeringWheel:
  type: branch
  description: AGL steering wheel demo data.

Vehicle.Cabin.SteeringWheel.Switches:
  type: branch
  description: AGL steering wheel demo switch data.

Vehicle.Cabin.SteeringWheel.Switches.VolumeUp:
  datatype: boolean
  type: sensor
  description: Steering wheel volume up switch engaged.
  dbc2vss:
    signal: SW_VolumeUp
    on_change: true
    transform:
      mapping:
        - from: 0
          to: false
        - from: 1
          to: true

Vehicle.Cabin.SteeringWheel.Switches.VolumeDown:
  datatype: boolean
  type: sensor
  description: Steering wheel volume down switch engaged.
  dbc2vss:
    signal: SW_VolumeDown
    on_change: true
    transform:
      mapping:
        - from: 0
          to: false
        - from: 1
          to: true

Vehicle.Cabin.SteeringWheel.Switches.VolumeMute:
  datatype: boolean
  type: sensor
  description: Steering wheel volume mute switch engaged.
  dbc2vss:
    signal: SW_VolumeMute
    on_change: true
    transform:
      mapping:
        - from: 0
          to: false
        - from: 1
          to: true

Vehicle.Cabin.SteeringWheel.Switches.Next:
  datatype: boolean
  type: sensor
  description: Steering wheel next switch engaged.
  dbc2vss:
    signal: SW_Next
    on_change: true
    transform:
      mapping:
        - from: 0
          to: false
        - from: 1
          to: true

Vehicle.Cabin.SteeringWheel.Switches.Previous:
  datatype: boolean
  type: sensor
  description: Steering wheel previous switch engaged.
  dbc2vss:
    signal: SW_Previous
    on_change: true
    transform:
      mapping:
        - from: 0
          to: false
        - from: 1
          to: true

Vehicle.Cabin.SteeringWheel.Switches.Mode:
  datatype: boolean
  type: sensor
  description: Steering wheel mode switch engaged.
  dbc2vss:
    signal: SW_Mode
    on_change: true
    transform:
      mapping:
        - from: 0
          to: false
        - from: 1
          to: true

Vehicle.Cabin.SteeringWheel.Switches.Info:
  datatype: boolean
  type: sensor
  description: Steering wheel info switch engaged.
  dbc2vss:
    signal: SW_Info
    on_change: true
    transform:
      mapping:
        - from: 0
          to: false
        - from: 1
          to: true

Vehicle.Cabin.SteeringWheel.Switches.CruiseEnable:
  datatype: boolean
  type: sensor
  description: Steering wheel cruise enable switch engaged.
  dbc2vss:
    signal: SW_CruiseEnable
    on_change: true
    transform:
      mapping:
        - from: 0
          to: false
        - from: 1
          to: true

Vehicle.Cabin.SteeringWheel.Switches.CruiseSet:
  datatype: boolean
  type: sensor
  description: Steering wheel cruise set switch engaged.
  dbc2vss:
    signal: SW_CruiseSet
    on_change: true
    transform:
      mapping:
        - from: 0
          to: false
        - from: 1
          to: true

Vehicle.Cabin.SteeringWheel.Switches.CruiseResume:
  datatype: boolean
  type: sensor
  description: Steering wheel cruise resume switch engaged.
  dbc2vss:
    signal: SW_CruiseResume
    on_change: true
    transform:
      mapping:
        - from: 0
          to: false
        - from: 1
          to: true

Vehicle.Cabin.SteeringWheel.Switches.CruiseCancel:
  datatype: boolean
  type: sensor
  description: Steering wheel cruise cancel switch engaged.
  dbc2vss:
    signal: SW_CruiseCancel
    on_change: true
    transform:
      mapping:
        - from: 0
          to: false
        - from: 1
          to: true

Vehicle.Cabin.SteeringWheel.Switches.CruiseLimit:
  datatype: boolean
  type: sensor
  description: Steering wheel cruise limit switch engaged.
  dbc2vss:
    signal: SW_CruiseLimit
    on_change: true
    transform:
      mapping:
        - from: 0
          to: false
        - from: 1
          to: true

Vehicle.Cabin.SteeringWheel.Switches.CruiseDistance:
  datatype: boolean
  type: sensor
  description: Steering wheel cruise distance switch engaged.
  dbc2vss:
    signal: SW_CruiseDistance
    on_change: true
    transform:
      mapping:
        - from: 0
          to: false
        - from: 1
          to: true

Vehicle.Cabin.SteeringWheel.Switches.Voice:
  datatype: boolean
  type: sensor
  description: Steering wheel voice switch engaged.
  dbc2vss:
    signal: SW_Voice
    on_change: true
    transform:
      mapping:
        - from: 0
          to: false
        - from: 1
          to: true

Vehicle.Cabin.SteeringWheel.Switches.PhoneCall:
  datatype: boolean
  type: sensor
  description: Steering wheel phone call switch engaged.
  dbc2vss:
    signal: SW_PhoneCall
    on_change: true
    transform:
      mapping:
        - from: 0
          to: false
        - from: 1
          to: true

Vehicle.Cabin.SteeringWheel.Switches.PhoneHangup:
  datatype: boolean
  type: sensor
  description: Steering wheel phone hangup switch engaged.
  dbc2vss:
    signal: SW_PhoneHangup
    on_change: true
    transform:
      mapping:
        - from: 0
          to: false
        - from: 1
          to: true

Vehicle.Cabin.SteeringWheel.Switches.Horn:
  datatype: boolean
  type: sensor
  description: Steering wheel horn switch engaged.
  dbc2vss:
    signal: SW_Horn
    on_change: true
    transform:
      mapping:
        - from: 0
          to: false
        - from: 1
          to: true

Vehicle.Cabin.SteeringWheel.Switches.LaneDepartureWarning:
  datatype: boolean
  type: sensor
  description: Steering wheel lane departure warning switch engaged.
  dbc2vss:
    signal: SW_LaneDepartureWarning
    on_change: true
    transform:
      mapping:
        - from: 0
          to: false
        - from: 1
          to: true