summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-10-26 17:09:06 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-10-31 11:21:22 +0000
commit9aa37897cdf3bcd7f4d5650c11bc2b679a6b9099 (patch)
tree4540267434e319ca4a53156a4c88015fa948df52
parent7832492d87871cfb382b58c1eeb9f182537c0c60 (diff)
Import flutter apps from master branch
For CES we will evolve the flutter applications. Import the state from master. Bug-AGL: SPEC-4592 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I6f561d76a8fee3903eb1431d0e5e141588dc365d
-rw-r--r--recipes-demo/flutter-dashboard/files/dashboard_config.yaml3
-rw-r--r--recipes-demo/flutter-dashboard/flutter-dashboard_git.bb47
-rw-r--r--recipes-demo/flutter-hvac/files/HVAC_config.yaml3
-rw-r--r--recipes-demo/flutter-hvac/flutter-hvac_git.bb40
-rw-r--r--recipes-demo/flutter-mediaplayer/flutter-mediaplayer_git.bb30
-rw-r--r--recipes-demo/flutter-nav/files/nav_config.yaml3
-rw-r--r--recipes-demo/flutter-nav/flutter-nav_git.bb52
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb5
8 files changed, 182 insertions, 1 deletions
diff --git a/recipes-demo/flutter-dashboard/files/dashboard_config.yaml b/recipes-demo/flutter-dashboard/files/dashboard_config.yaml
new file mode 100644
index 00000000..6824c6b7
--- /dev/null
+++ b/recipes-demo/flutter-dashboard/files/dashboard_config.yaml
@@ -0,0 +1,3 @@
+hostname : localhost
+port : 8090
+kuskaAuthToken : eyJ0eXAiOiJKV1QiLCJhbGciOiJSUzI1NiJ9.eyJzdWIiOiJrdWtzYS52YWwiLCJpc3MiOiJFY2xpcHNlIEtVS1NBIERldiIsImFkbWluIjp0cnVlLCJtb2RpZnlUcmVlIjp0cnVlLCJpYXQiOjE1MTYyMzkwMjIsImV4cCI6MTc2NzIyNTU5OSwia3Vrc2EtdnNzIjp7IioiOiJydyJ9fQ.p2cnFGH16QoQ14l6ljPVKggFXZKmD-vrw8G6Vs6DvAokjsUG8FHh-F53cMsE-GDjyZH_1_CrlDCnbGlqjsFbgAylqA7IAJWp9_N6dL5p8DHZTwlZ4IV8L1CtCALs7XVqvcQKHCCzB63Y8PgVDCAqpQSRb79JPVD4pZwkBKpOknfEY5y9wfbswZiRKdgz7o61_oFnd-yywpse-23HD6v0htThVF1SuGL1PuvGJ8p334nt9bpkZO3gaTh1xVD_uJMwHzbuBCF33_f-I5QMZO6bVooXqGfe1zvl3nDrPEjq1aPulvtP8RgREYEqE6b2hB8jouTiC_WpE3qrdMw9sfWGFbm04qC-2Zjoa1yYSXoxmYd0SnliSYHAad9aXoEmFENezQV-of7sc-NX1-2nAXRAEhaqh0IRuJwB4_sG7SvQmnanwkz-sBYxKqkoFpOsZ6hblgPDOPYY2NAsZlYkjvAL2mpiInrsmY_GzGsfwPeAx31iozImX75rao8rm-XucAmCIkRlpBz6MYKCjQgyRz3UtZCJ2DYF4lKqTjphEAgclbYZ7KiCuTn9HualwtEmVzHHFneHMKl7KnRQk-9wjgiyQ5nlsVpCCblg6JKr9of4utuPO3cBvbjhB4_ueQ40cpWVOICcOLS7_w0i3pCq1ZKDEMrYDJfz87r2sU9kw1zeFQk
diff --git a/recipes-demo/flutter-dashboard/flutter-dashboard_git.bb b/recipes-demo/flutter-dashboard/flutter-dashboard_git.bb
new file mode 100644
index 00000000..d44b30c9
--- /dev/null
+++ b/recipes-demo/flutter-dashboard/flutter-dashboard_git.bb
@@ -0,0 +1,47 @@
+SUMMARY = "Flutter Dashboard"
+DESCRIPTION = "A Flutter based IVI Dashboard Application for automotive grade Linux."
+
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/flutter-dashboard"
+
+BUGTRACKER = "https://github.com/hritik-chouhan/dashboard_for_recipe/issues"
+
+SECTION = "graphics"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://License.md;md5=f712ede8d4f845976061925d1416fc40"
+
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-dashboard;protocol=https;branch=${AGL_BRANCH} \
+ file://dashboard_config.yaml \
+ "
+
+SRCREV = "10945b8056eb2b228c156918a3505882a49a79b8"
+S = "${WORKDIR}/git"
+
+
+inherit agl-app flutter-app
+
+# flutter-app
+#############
+PUBSPEC_APPNAME = "dashboard_app"
+FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
+FLUTTER_BUILD_ARGS = "bundle -v"
+
+# agl-app
+#########
+AGL_APP_TEMPLATE = "agl-app-flutter"
+AGL_APP_ID = "dashboard_app"
+AGL_APP_NAME = "Flutter Dashboard"
+
+
+
+do_install:append() {
+ install -d ${D}${sysconfdir}/xdg/AGL
+ install -m 0644 ${WORKDIR}/dashboard_config.yaml ${D}${sysconfdir}/xdg/AGL/
+
+
+
+}
+
+FILES:${PN} += "${sysconfdir}/xdg/AGL"
+
diff --git a/recipes-demo/flutter-hvac/files/HVAC_config.yaml b/recipes-demo/flutter-hvac/files/HVAC_config.yaml
new file mode 100644
index 00000000..6824c6b7
--- /dev/null
+++ b/recipes-demo/flutter-hvac/files/HVAC_config.yaml
@@ -0,0 +1,3 @@
+hostname : localhost
+port : 8090
+kuskaAuthToken : eyJ0eXAiOiJKV1QiLCJhbGciOiJSUzI1NiJ9.eyJzdWIiOiJrdWtzYS52YWwiLCJpc3MiOiJFY2xpcHNlIEtVS1NBIERldiIsImFkbWluIjp0cnVlLCJtb2RpZnlUcmVlIjp0cnVlLCJpYXQiOjE1MTYyMzkwMjIsImV4cCI6MTc2NzIyNTU5OSwia3Vrc2EtdnNzIjp7IioiOiJydyJ9fQ.p2cnFGH16QoQ14l6ljPVKggFXZKmD-vrw8G6Vs6DvAokjsUG8FHh-F53cMsE-GDjyZH_1_CrlDCnbGlqjsFbgAylqA7IAJWp9_N6dL5p8DHZTwlZ4IV8L1CtCALs7XVqvcQKHCCzB63Y8PgVDCAqpQSRb79JPVD4pZwkBKpOknfEY5y9wfbswZiRKdgz7o61_oFnd-yywpse-23HD6v0htThVF1SuGL1PuvGJ8p334nt9bpkZO3gaTh1xVD_uJMwHzbuBCF33_f-I5QMZO6bVooXqGfe1zvl3nDrPEjq1aPulvtP8RgREYEqE6b2hB8jouTiC_WpE3qrdMw9sfWGFbm04qC-2Zjoa1yYSXoxmYd0SnliSYHAad9aXoEmFENezQV-of7sc-NX1-2nAXRAEhaqh0IRuJwB4_sG7SvQmnanwkz-sBYxKqkoFpOsZ6hblgPDOPYY2NAsZlYkjvAL2mpiInrsmY_GzGsfwPeAx31iozImX75rao8rm-XucAmCIkRlpBz6MYKCjQgyRz3UtZCJ2DYF4lKqTjphEAgclbYZ7KiCuTn9HualwtEmVzHHFneHMKl7KnRQk-9wjgiyQ5nlsVpCCblg6JKr9of4utuPO3cBvbjhB4_ueQ40cpWVOICcOLS7_w0i3pCq1ZKDEMrYDJfz87r2sU9kw1zeFQk
diff --git a/recipes-demo/flutter-hvac/flutter-hvac_git.bb b/recipes-demo/flutter-hvac/flutter-hvac_git.bb
new file mode 100644
index 00000000..a2062411
--- /dev/null
+++ b/recipes-demo/flutter-hvac/flutter-hvac_git.bb
@@ -0,0 +1,40 @@
+SUMMARY = "Flutter HVAC"
+DESCRIPTION = "A Flutter based IVI Dashboard Application for automotive grade Linux."
+
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/flutter-hvac"
+
+BUGTRACKER = "https://github.com/hritik-chouhan/HVAC_dashboard/issues"
+
+SECTION = "graphics"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://License.md;md5=f712ede8d4f845976061925d1416fc40"
+
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-hvac;protocol=https;branch=${AGL_BRANCH} \
+ file://HVAC_config.yaml \
+ "
+
+SRCREV = "5559cdb261cfd3e69daa2349906f071dc2491c0d"
+S = "${WORKDIR}/git"
+
+inherit agl-app flutter-app
+
+# flutter-app
+#############
+PUBSPEC_APPNAME = "flutter_hvac"
+FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
+FLUTTER_BUILD_ARGS = "bundle -v"
+
+# agl-app
+#########
+AGL_APP_TEMPLATE = "agl-app-flutter"
+AGL_APP_ID = "flutter_hvac"
+AGL_APP_NAME = "Flutter Hvac"
+
+do_install:append() {
+ install -d ${D}${sysconfdir}/xdg/AGL
+ install -m 0644 ${WORKDIR}/HVAC_config.yaml ${D}${sysconfdir}/xdg/AGL/
+}
+
+FILES:${PN} += "${sysconfdir}/xdg/AGL"
diff --git a/recipes-demo/flutter-mediaplayer/flutter-mediaplayer_git.bb b/recipes-demo/flutter-mediaplayer/flutter-mediaplayer_git.bb
new file mode 100644
index 00000000..cfcfa265
--- /dev/null
+++ b/recipes-demo/flutter-mediaplayer/flutter-mediaplayer_git.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Flutter MediaPlayer app for IVI"
+DESCRIPTION = "A Flutter based IVI Dashboard Application for automotive grade Linux"
+
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/flutter-mediaplayer"
+
+BUGTRACKER = "https://github.com/hritik-chouhan/musicplayer/issues"
+
+SECTION = "graphics"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://License.md;md5=f712ede8d4f845976061925d1416fc40"
+
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-mediaplayer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "735de5a38ea937ee13157f6ac594053ddb8b027b"
+S = "${WORKDIR}/git"
+
+inherit agl-app flutter-app
+
+# flutter-app
+#############
+PUBSPEC_APPNAME = "musicplayer"
+FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
+FLUTTER_BUILD_ARGS = "bundle -v"
+
+# agl-app
+#########
+AGL_APP_TEMPLATE = "agl-app-flutter"
+AGL_APP_ID = "musicplayer"
+AGL_APP_NAME = "Flutter MediaPlayer"
diff --git a/recipes-demo/flutter-nav/files/nav_config.yaml b/recipes-demo/flutter-nav/files/nav_config.yaml
new file mode 100644
index 00000000..6824c6b7
--- /dev/null
+++ b/recipes-demo/flutter-nav/files/nav_config.yaml
@@ -0,0 +1,3 @@
+hostname : localhost
+port : 8090
+kuskaAuthToken : eyJ0eXAiOiJKV1QiLCJhbGciOiJSUzI1NiJ9.eyJzdWIiOiJrdWtzYS52YWwiLCJpc3MiOiJFY2xpcHNlIEtVS1NBIERldiIsImFkbWluIjp0cnVlLCJtb2RpZnlUcmVlIjp0cnVlLCJpYXQiOjE1MTYyMzkwMjIsImV4cCI6MTc2NzIyNTU5OSwia3Vrc2EtdnNzIjp7IioiOiJydyJ9fQ.p2cnFGH16QoQ14l6ljPVKggFXZKmD-vrw8G6Vs6DvAokjsUG8FHh-F53cMsE-GDjyZH_1_CrlDCnbGlqjsFbgAylqA7IAJWp9_N6dL5p8DHZTwlZ4IV8L1CtCALs7XVqvcQKHCCzB63Y8PgVDCAqpQSRb79JPVD4pZwkBKpOknfEY5y9wfbswZiRKdgz7o61_oFnd-yywpse-23HD6v0htThVF1SuGL1PuvGJ8p334nt9bpkZO3gaTh1xVD_uJMwHzbuBCF33_f-I5QMZO6bVooXqGfe1zvl3nDrPEjq1aPulvtP8RgREYEqE6b2hB8jouTiC_WpE3qrdMw9sfWGFbm04qC-2Zjoa1yYSXoxmYd0SnliSYHAad9aXoEmFENezQV-of7sc-NX1-2nAXRAEhaqh0IRuJwB4_sG7SvQmnanwkz-sBYxKqkoFpOsZ6hblgPDOPYY2NAsZlYkjvAL2mpiInrsmY_GzGsfwPeAx31iozImX75rao8rm-XucAmCIkRlpBz6MYKCjQgyRz3UtZCJ2DYF4lKqTjphEAgclbYZ7KiCuTn9HualwtEmVzHHFneHMKl7KnRQk-9wjgiyQ5nlsVpCCblg6JKr9of4utuPO3cBvbjhB4_ueQ40cpWVOICcOLS7_w0i3pCq1ZKDEMrYDJfz87r2sU9kw1zeFQk
diff --git a/recipes-demo/flutter-nav/flutter-nav_git.bb b/recipes-demo/flutter-nav/flutter-nav_git.bb
new file mode 100644
index 00000000..0e8b8ac7
--- /dev/null
+++ b/recipes-demo/flutter-nav/flutter-nav_git.bb
@@ -0,0 +1,52 @@
+SUMMARY = "Flutter Navigation app"
+DESCRIPTION = "A Flutter based IVI Dashboard Application for automotive grade Linux."
+
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/flutter-navigation"
+
+BUGTRACKER = "https://github.com/hritik-chouhan/nav-app/issues"
+
+SECTION = "graphics"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://License.md;md5=f712ede8d4f845976061925d1416fc40"
+
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-navigation;protocol=https;branch=${AGL_BRANCH} \
+ file://nav_config.yaml \
+ "
+SRCREV = "53164c0441db946b4293f483a28b524ecdc91e30"
+S = "${WORKDIR}/git"
+
+MAPBOX_API_KEY ??= "YOU_NEED_TO_SET_IT_IN_LOCAL_CONF"
+
+inherit agl-app flutter-app
+
+# flutter-app
+#############
+PUBSPEC_APPNAME = "flutter_navigation"
+FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
+FLUTTER_BUILD_ARGS = "bundle -v"
+
+# agl-app
+#########
+AGL_APP_TEMPLATE = "agl-app-flutter"
+AGL_APP_ID = "flutter_navigation"
+AGL_APP_NAME = "Flutter Navigation"
+
+do_configure:prepend() {
+ if [ "${MAPBOX_API_KEY}" = "YOU_NEED_TO_SET_IT_IN_LOCAL_CONF" ]; then
+ bbwarn "WARNING: You should set mapbox API key to mapbox_API_KEY variable in local.conf."
+ fi
+}
+
+do_install:append() {
+ install -d ${D}${sysconfdir}/xdg/AGL
+ install -m 0644 ${WORKDIR}/nav_config.yaml ${D}${sysconfdir}/xdg/AGL/
+
+ install -m 0755 -d ${D}${sysconfdir}/default/
+
+ echo 'MAPBOX_API_KEY:${MAPBOX_API_KEY}' >> ${D}${sysconfdir}/default/mapboxkey
+}
+
+FILES:${PN} += "${sysconfdir}/xdg/AGL ${sysconfdir}/default/"
+
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb
index 747fb6f8..2ab68823 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb
@@ -20,7 +20,10 @@ RDEPENDS:${PN} += "\
AGL_APPS = " \
hvac \
dashboard \
- flutter-gallery-runtimerelease \
+ flutter-dashboard \
+ flutter-hvac \
+ flutter-nav \
+ flutter-mediaplayer \
"
RDEPENDS:${PN}:append = " \