summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Porter <mporter@konsulko.com>2017-11-10 21:24:18 +0200
committerMatt Porter <mporter@konsulko.com>2017-11-10 19:47:37 +0000
commit2a1c53a8a152b5744b631278f52264be13f316f1 (patch)
treefcca90c1f304ca76167765f26a62abd228045e9f
parenta0d3614d34a851f1c8115acdc11843eb869b35bc (diff)
libqtappfw: clean up syntax and unused FILES* bits
Fix some unnecessary whitespace and remove all the explicit FILES* additions. These are all handled by the defaults. Bug-AGL: SPEC-1064 Change-Id: I3b610cf503f938c84b17d514bb1ed1cf3f8607bb Signed-off-by: Matt Porter <mporter@konsulko.com>
-rw-r--r--recipes-demo-hmi/libqtappfw/libqtappfw_git.bb19
1 files changed, 2 insertions, 17 deletions
diff --git a/recipes-demo-hmi/libqtappfw/libqtappfw_git.bb b/recipes-demo-hmi/libqtappfw/libqtappfw_git.bb
index 27f695dc..53519c89 100644
--- a/recipes-demo-hmi/libqtappfw/libqtappfw_git.bb
+++ b/recipes-demo-hmi/libqtappfw/libqtappfw_git.bb
@@ -4,11 +4,11 @@ HOMEPAGE = "http://docs.automotivelinux.org"
LICENSE = "Apache-2.0"
SECTION = "libs"
-BBCLASSEXTEND = " nativesdk"
+BBCLASSEXTEND = "nativesdk"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-DEPENDS += " qtbase qtwebsockets "
+DEPENDS += "qtbase qtwebsockets"
inherit cmake_qt5
@@ -18,18 +18,3 @@ S = "${WORKDIR}/git/"
# PV needs to be modified with SRCPV to work AUTOREV correctly
PV = "0.0+git${SRCPV}"
-
-FILES_${PN} = "\
- ${libdir}/libqtappfw.so.* \
-"
-FILES_${PN}-dev = "\
- ${includedir}/qtappfw/message.h \
- ${includedir}/qtappfw/messageengine.h \
- ${includedir}/qtappfw/telephonymessage.h \
- ${includedir}/qtappfw/telephony.h \
- ${libdir}/libqtappfw.so \
- ${libdir}/pkgconfig/qtappfw.pc \
-"
-FILES_${PN}-dbg += "\
- ${libdir}/.debug/libqtappfw.so.* \
-"