summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>2017-09-11 16:07:39 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-10-09 21:21:47 +0000
commit9879e35d670df53af43de123ce1804a7296531e1 (patch)
treeb10d4024bc44f2dabed787498b6a64aa70a12a52
parent94f35a1364fb97c65f8f027bcc85b71c02dd5967 (diff)
mapview: It should be run user service instead of system
Change-Id: I65dd87561b80765ae2bbff5fc7f903ffe27394a8 Signed-off-by: Harunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>
-rw-r--r--recipes-demo-hmi/navigation/mapviewer/mapviewer.service5
-rw-r--r--recipes-demo-hmi/navigation/mapviewer_%.bbappend5
2 files changed, 6 insertions, 4 deletions
diff --git a/recipes-demo-hmi/navigation/mapviewer/mapviewer.service b/recipes-demo-hmi/navigation/mapviewer/mapviewer.service
index eba4a0dd..c3f5515a 100644
--- a/recipes-demo-hmi/navigation/mapviewer/mapviewer.service
+++ b/recipes-demo-hmi/navigation/mapviewer/mapviewer.service
@@ -1,6 +1,6 @@
[Unit]
Conflicts=getty@tty1.service
-After=weston.service
+After=weston.service HomeScreen.service
# map viewr is a child application which can work with navigation.
# This app requires mapdata. It has to be stored at /var/mapdata/navi_data_UK .
@@ -17,6 +17,7 @@ ExecStartPost=/usr/AGL/mapviewer/mapviewer-settings.sh
ExecStop=/usr/bin/killall -s KILL mapview
Type=simple
+Restart=always
[Install]
-WantedBy=multi-user.target
+WantedBy=default.target
diff --git a/recipes-demo-hmi/navigation/mapviewer_%.bbappend b/recipes-demo-hmi/navigation/mapviewer_%.bbappend
index a4eebfb4..4e89af06 100644
--- a/recipes-demo-hmi/navigation/mapviewer_%.bbappend
+++ b/recipes-demo-hmi/navigation/mapviewer_%.bbappend
@@ -15,7 +15,8 @@ do_install_append() {
# Install systemd unit files
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -m 644 -p -D ${WORKDIR}/mapviewer.service ${D}${systemd_system_unitdir}/mapviewer.service
+ install -d ${D}${systemd_user_unitdir}
+ install -m 644 -p -D ${WORKDIR}/mapviewer.service ${D}${systemd_user_unitdir}/mapviewer.service
fi
}
@@ -26,6 +27,6 @@ do_install_append() {
#SYSTEMD_SERVICE_${PN} = "mapviewer.service"
FILES_${PN} += " \
- ${systemd_system_unitdir}/mapviewer.service \
+ ${systemd_user_unitdir}/mapviewer.service \
/usr/AGL/mapviewer/ \
"