summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Porter <mporter@konsulko.com>2017-11-09 16:45:44 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-11-10 14:35:09 +0000
commita0d3614d34a851f1c8115acdc11843eb869b35bc (patch)
treea0215fbaa00b7d1b56ad8b4877c2eba72a8a7444
parent69b258204487fea5505bbb1afe58f995332bd0d5 (diff)
Add AGL libqtappfw to the platform
Add libqtappfw to the platform. This supports SDK development and runtime of apps leveraging libqtappfw. Bug-AGL: SPEC-1064 Change-Id: I7fc54fc7d9c4db885cd79d899bd40f44e4543766 Signed-off-by: Matt Porter <mporter@konsulko.com>
-rw-r--r--recipes-demo-hmi/libqtappfw/libqtappfw_git.bb35
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo.bb1
2 files changed, 36 insertions, 0 deletions
diff --git a/recipes-demo-hmi/libqtappfw/libqtappfw_git.bb b/recipes-demo-hmi/libqtappfw/libqtappfw_git.bb
new file mode 100644
index 00000000..27f695dc
--- /dev/null
+++ b/recipes-demo-hmi/libqtappfw/libqtappfw_git.bb
@@ -0,0 +1,35 @@
+SUMMARY = "AGL Qt AppFW Library"
+DESCRIPTION = "libqtappfw"
+HOMEPAGE = "http://docs.automotivelinux.org"
+LICENSE = "Apache-2.0"
+SECTION = "libs"
+
+BBCLASSEXTEND = " nativesdk"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS += " qtbase qtwebsockets "
+
+inherit cmake_qt5
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libqtappfw;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "112fc8be473f02befc7596750ad7044113f29849"
+S = "${WORKDIR}/git/"
+
+# PV needs to be modified with SRCPV to work AUTOREV correctly
+PV = "0.0+git${SRCPV}"
+
+FILES_${PN} = "\
+ ${libdir}/libqtappfw.so.* \
+"
+FILES_${PN}-dev = "\
+ ${includedir}/qtappfw/message.h \
+ ${includedir}/qtappfw/messageengine.h \
+ ${includedir}/qtappfw/telephonymessage.h \
+ ${includedir}/qtappfw/telephony.h \
+ ${libdir}/libqtappfw.so \
+ ${libdir}/pkgconfig/qtappfw.pc \
+"
+FILES_${PN}-dbg += "\
+ ${libdir}/.debug/libqtappfw.so.* \
+"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo.bb b/recipes-platform/packagegroups/packagegroup-agl-demo.bb
index cc93ddaa..186280e1 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo.bb
@@ -21,6 +21,7 @@ HOMESCREEN-NEW = "packagegroup-hmi-framework packagegroup-hmi-framework-dev"
RDEPENDS_${PN} += "\
packagegroup-agl-appfw \
+ libqtappfw \
${@bb.utils.contains('DISTRO_FEATURES', 'agl-hmi-framework', '${HOMESCREEN-NEW}', '${HOMESCREEN-OLD}', d)} \
udisks \
${SMARTDEVICELINK} \