summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-11-22 10:39:00 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-11-22 14:15:09 +0000
commitd312c2fb6f0a00f3abb45e99d4085845715866c7 (patch)
tree503feef1ac04140825b7c233b2697208ad8bf992
parent64b28dd3f4004a6c651b96513820e39f6d0b8c69 (diff)
Use ROOT_HOME variable, not /home/root
This enforces the use of the dedicated variable ROOT_HOME of yocto instead of /home/root. Note that the use of root's home made in the patched demos is bad and have to be changed. Change-Id: Ib0095a62d75800a0427be27955d1b2216b14554f Signed-off-by: José Bollo <jose.bollo@iot.bzh>
-rw-r--r--recipes-demo-hmi/can-lin/can-lin_0.2.bb6
-rw-r--r--recipes-demo-hmi/navigation/mapviewer-demo.bb1
-rw-r--r--recipes-demo-hmi/radio/radio_git.bb14
-rw-r--r--recipes-demo-hmi/unicens/unicens_0.1.bb10
-rw-r--r--recipes-demo-hmi/vod-server/vod-server_0.1.bb7
5 files changed, 20 insertions, 18 deletions
diff --git a/recipes-demo-hmi/can-lin/can-lin_0.2.bb b/recipes-demo-hmi/can-lin/can-lin_0.2.bb
index 287fe4eb..918b8686 100644
--- a/recipes-demo-hmi/can-lin/can-lin_0.2.bb
+++ b/recipes-demo-hmi/can-lin/can-lin_0.2.bb
@@ -27,13 +27,13 @@ do_install() {
# Execute install manually for root user on behalf of systemctl script
# because it doesn't support user mode of systemd.
- install -m 0755 -d ${D}/home/root/.config/systemd/user/default.target.wants/
- ln -sf ${systemd_user_unitdir}/hvac-demo.service ${D}/home/root/.config/systemd/user/default.target.wants/hvac-demo.service
+ install -m 0755 -d ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/
+ ln -sf ${systemd_user_unitdir}/hvac-demo.service ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/hvac-demo.service
}
FILES_${PN} += " \
${bindir}/OptoLyzerMoccaApp \
/usr/AGL/most/vod-client \
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/hvac-demo.service', '', d)} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '/home/root/.config/systemd/user/default.target.wants/hvac-demo.service', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${ROOT_HOME}/.config/systemd/user/default.target.wants/hvac-demo.service', '', d)} \
"
diff --git a/recipes-demo-hmi/navigation/mapviewer-demo.bb b/recipes-demo-hmi/navigation/mapviewer-demo.bb
index 86e7f93d..ea2e38b1 100644
--- a/recipes-demo-hmi/navigation/mapviewer-demo.bb
+++ b/recipes-demo-hmi/navigation/mapviewer-demo.bb
@@ -26,6 +26,7 @@ do_install() {
install -d ${D}${systemd_system_unitdir}
install -m 0644 ${WORKDIR}/weston-mapviewer-demo.service ${D}${systemd_system_unitdir}
+ sed -i "s:/home/root:${ROOT_HOME}:" ${D}${systemd_system_unitdir}/weston-mapviewer-demo.service
}
## DO NOT ENABLE 'weston-mapviewer-demo.service' BY DEFAULT
diff --git a/recipes-demo-hmi/radio/radio_git.bb b/recipes-demo-hmi/radio/radio_git.bb
index 8563b018..4f8063a0 100644
--- a/recipes-demo-hmi/radio/radio_git.bb
+++ b/recipes-demo-hmi/radio/radio_git.bb
@@ -27,16 +27,16 @@ inherit qmake5 aglwgt
AGL_RADIO_PRESETS_LOCALE ?= "CES"
do_install_append() {
- install -d ${D}/home/root/app-data/radio
- install -m 0644 ${WORKDIR}/presets-CES.conf ${D}/home/root/app-data/radio/
- install -m 0644 ${WORKDIR}/presets-ALS.conf ${D}/home/root/app-data/radio/
- install -m 0644 ${WORKDIR}/presets-FOSDEM.conf ${D}/home/root/app-data/radio/
- install -m 0644 ${WORKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}/home/root/app-data/radio/presets.conf
+ install -d ${D}${ROOT_HOME}/app-data/radio
+ install -m 0644 ${WORKDIR}/presets-CES.conf ${D}${ROOT_HOME}/app-data/radio/
+ install -m 0644 ${WORKDIR}/presets-ALS.conf ${D}${ROOT_HOME}/app-data/radio/
+ install -m 0644 ${WORKDIR}/presets-FOSDEM.conf ${D}${ROOT_HOME}/app-data/radio/
+ install -m 0644 ${WORKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}${ROOT_HOME}/app-data/radio/presets.conf
}
FILES_${PN} += " \
- /home/root/app-data/radio/presets-*.conf \
- /home/root/app-data/radio/presets.conf \
+ ${ROOT_HOME}/app-data/radio/presets-*.conf \
+ ${ROOT_HOME}/app-data/radio/presets.conf \
"
RDEPENDS_${PN} += "agl-service-radio"
diff --git a/recipes-demo-hmi/unicens/unicens_0.1.bb b/recipes-demo-hmi/unicens/unicens_0.1.bb
index 7b854ea7..4f289c61 100644
--- a/recipes-demo-hmi/unicens/unicens_0.1.bb
+++ b/recipes-demo-hmi/unicens/unicens_0.1.bb
@@ -34,9 +34,9 @@ do_install() {
# Execute install manually for root user on behalf of systemctl script
# because it doesn't support user mode of systemd.
- install -m 0755 -d ${D}/home/root/.config/systemd/user/default.target.wants/
- ln -sf ${systemd_user_unitdir}/most-network-startup.service ${D}/home/root/.config/systemd/user/default.target.wants/most-network-startup.service
- ln -sf ${systemd_user_unitdir}/most-network-manager.service ${D}/home/root/.config/systemd/user/default.target.wants/most-network-manager.service
+ install -m 0755 -d ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/
+ ln -sf ${systemd_user_unitdir}/most-network-startup.service ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/most-network-startup.service
+ ln -sf ${systemd_user_unitdir}/most-network-manager.service ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/most-network-manager.service
fi
}
@@ -44,6 +44,6 @@ FILES_${PN} += " \
/usr/AGL/most \
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/most-network-startup.service', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/most-network-manager.service', '', d)} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '/home/root/.config/systemd/user/default.target.wants/most-network-startup.service', '', d)} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '/home/root/.config/systemd/user/default.target.wants/most-network-manager.service', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${ROOT_HOME}/.config/systemd/user/default.target.wants/most-network-startup.service', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${ROOT_HOME}/.config/systemd/user/default.target.wants/most-network-manager.service', '', d)} \
"
diff --git a/recipes-demo-hmi/vod-server/vod-server_0.1.bb b/recipes-demo-hmi/vod-server/vod-server_0.1.bb
index 73b7fb74..5c3ad6a6 100644
--- a/recipes-demo-hmi/vod-server/vod-server_0.1.bb
+++ b/recipes-demo-hmi/vod-server/vod-server_0.1.bb
@@ -24,12 +24,13 @@ do_install() {
# Execute install manually for root user on behalf of systemctl script
# because it doesn't support user mode of systemd.
- install -m 0755 -d ${D}/home/root/.config/systemd/user/default.target.wants/
- ln -sf ${systemd_user_unitdir}/vod-demo.service ${D}/home/root/.config/systemd/user/default.target.wants/vod-demo.service
+ install -m 0755 -d ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/
+ ln -sf ${systemd_user_unitdir}/vod-demo.service ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/vod-demo.service
+ sed -i "s:/home/root:${ROOT_HOME}:" ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/vod-demo.service
fi
}
FILES_${PN} += " \
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/vod-demo.service', '', d)} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '/home/root/.config/systemd/user/default.target.wants/vod-demo.service', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${ROOT_HOME}/.config/systemd/user/default.target.wants/vod-demo.service', '', d)} \
"