summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <trini@konsulko.com>2017-09-26 15:10:31 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-09-28 12:54:51 +0000
commite5cbbff04a9ce2742e47dc6e5af72454583cd522 (patch)
treea9e61d3e5d106d724b18e03e13e1f7eb57bf5232
parente3253ac2cbc5fb9df6fcc6df6b0de1db34490abf (diff)
packagegroup-agl-appfw-graphics: Add opencv
We add support for a relatively minimal opencv library to the appfw-grahpics packagegroup. As part of this, we set the PACKAGECONFIG for opencv to a minimal level that enables support for things we already have in the system as well as using V4L devices. Additional features that are normally enabled in OpenEmbedded are left out. Bug-AGL: SPEC-912 Change-Id: Iae4480420ccb619ef79f45de30c86e05831e70f9 Signed-off-by: zheng_wenlong <wenlong_zheng@nexty-ele.com> Signed-off-by: Tom Rini <trini@konsulko.com>
-rw-r--r--recipes-appfw/packagegroups/packagegroup-agl-appfw-graphics.bb1
-rw-r--r--recipes-support/opencv/opencv_3.2.bbappend1
2 files changed, 2 insertions, 0 deletions
diff --git a/recipes-appfw/packagegroups/packagegroup-agl-appfw-graphics.bb b/recipes-appfw/packagegroups/packagegroup-agl-appfw-graphics.bb
index f71b56cb..1e707ce4 100644
--- a/recipes-appfw/packagegroups/packagegroup-agl-appfw-graphics.bb
+++ b/recipes-appfw/packagegroups/packagegroup-agl-appfw-graphics.bb
@@ -13,4 +13,5 @@ PACKAGES = "\
ALLOW_EMPTY_${PN} = "1"
RDEPENDS_${PN} += "\
+ opencv \
"
diff --git a/recipes-support/opencv/opencv_3.2.bbappend b/recipes-support/opencv/opencv_3.2.bbappend
new file mode 100644
index 00000000..8656abf0
--- /dev/null
+++ b/recipes-support/opencv/opencv_3.2.bbappend
@@ -0,0 +1 @@
+PACKAGECONFIG ?= "jpeg png v4l libv4l gstreamer"