summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2017-11-30 22:31:14 -0800
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-12-01 21:39:10 +0000
commit9438be0e6e64fdaed9d65b21a227c25efda82946 (patch)
tree147fa6d01449ed1ae0eef4dce0b339d4e80b846f
parent77eb5ee0570afa0b5cb859d5be9c0bdb5d36a31d (diff)
libhomescreen-2017: correct dbus permissions to allow statusbar access
Settings application using bluetooth + wifi bindings was able to change HMI status because of invalid dbus permissions access Bug-AGL: SPEC-1150 Change-Id: Id730c67dc8e20dfc38424247fe68ce16939aff8b Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
-rw-r--r--recipes-demo-hmi/libhomescreen/libhomescreen-2017/org.agl.statusbar.conf16
-rw-r--r--recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb9
2 files changed, 24 insertions, 1 deletions
diff --git a/recipes-demo-hmi/libhomescreen/libhomescreen-2017/org.agl.statusbar.conf b/recipes-demo-hmi/libhomescreen/libhomescreen-2017/org.agl.statusbar.conf
new file mode 100644
index 00000000..dc3852ee
--- /dev/null
+++ b/recipes-demo-hmi/libhomescreen/libhomescreen-2017/org.agl.statusbar.conf
@@ -0,0 +1,16 @@
+<!DOCTYPE busconfig PUBLIC
+"-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
+"http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
+<busconfig>
+ <policy context="default">
+ <!-- Allow everyone to talk to main service. We'll later add an agent to
+ only share the location if user allows it. -->
+ <allow send_interface="org.agl.statusbar"/>
+ </policy>
+
+ <policy user="root">
+ <!-- Allow root to own the name on the bus -->
+ <allow own="org.agl.statusbar"/>
+ </policy>
+</busconfig>
+
diff --git a/recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb b/recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb
index 4ef42ee6..b78f2f56 100644
--- a/recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb
+++ b/recipes-demo-hmi/libhomescreen/libhomescreen-2017_git.bb
@@ -12,9 +12,16 @@ DEPENDS = "af-binder json-c"
inherit cmake
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/libhomescreen.git;protocol=https;branch=${AGL_BRANCH}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/libhomescreen.git;protocol=https;branch=${AGL_BRANCH} \
+ file://org.agl.statusbar.conf \
+ "
SRCREV = "d97eb6052b7652a42d502e5887bd7acf3fc6d91b"
S = "${WORKDIR}/git"
+do_install_append() {
+ mkdir -p ${D}${sysconfdir}/dbus-1/session.d
+ install -m 0644 ${WORKDIR}/org.agl.statusbar.conf ${D}${sysconfdir}/dbus-1/session.d
+}
+
RDEPENDS_${PN} = "agl-service-homescreen-2017"
PROVIDES += "virtual/libhomescreen"