summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2017-12-20 19:39:54 -0500
committerScott Murray <scott.murray@konsulko.com>2017-12-20 19:55:39 -0500
commit0d29ff059d328feb85bfdb362dee1f45b66dd854 (patch)
tree3e00f3fda722408463fe22e1f71200389783ec18
parent6a216fe38fee5342043d7b784075c67469ed42c5 (diff)
agl-service-radio: Set appropriate sink if 4A is configured
If 4A is enabled in DISTRO_FEATURES, add an extension conf file to add setting PULSE_SINK to the systemd service unit. This will direct the radio output into the matching PulseAudio sink for the 4A Radio role. Change-Id: Ic67f3bcf1bd64636813e426f4471e666d2c33938 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--recipes-demo-hmi/agl-service-radio/agl-service-radio_git.bb13
-rw-r--r--recipes-demo-hmi/agl-service-radio/files/set-4a-output-sink.conf2
2 files changed, 14 insertions, 1 deletions
diff --git a/recipes-demo-hmi/agl-service-radio/agl-service-radio_git.bb b/recipes-demo-hmi/agl-service-radio/agl-service-radio_git.bb
index 0e913af1..46dc48a2 100644
--- a/recipes-demo-hmi/agl-service-radio/agl-service-radio_git.bb
+++ b/recipes-demo-hmi/agl-service-radio/agl-service-radio_git.bb
@@ -8,7 +8,9 @@ LICENSE = "Apache-2.0 & GPLv2+"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
-SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-radio;protocol=https;branch=${AGL_BRANCH}"
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-radio;protocol=https;branch=${AGL_BRANCH} \
+ file://set-4a-output-sink.conf \
+"
SRCREV = "${AGL_APP_REVISION}"
PV = "1.0+git${SRCPV}"
@@ -18,3 +20,12 @@ S = "${WORKDIR}/git"
DEPENDS = "rtl-sdr glib-2.0 pulseaudio alsa-lib"
inherit cmake aglwgt pkgconfig
+
+do_install_append() {
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'agl-audio-4a-framework', 'true', 'false', d)}; then
+ install -d ${D}${systemd_user_unitdir}/afm-service-agl-service-radio@1.0.service.d
+ install -m 0644 ${WORKDIR}/set-4a-output-sink.conf ${D}${systemd_user_unitdir}/afm-service-agl-service-radio@1.0.service.d/
+ fi
+}
+
+FILES_${PN} += "${systemd_user_unitdir}"
diff --git a/recipes-demo-hmi/agl-service-radio/files/set-4a-output-sink.conf b/recipes-demo-hmi/agl-service-radio/files/set-4a-output-sink.conf
new file mode 100644
index 00000000..c574ca17
--- /dev/null
+++ b/recipes-demo-hmi/agl-service-radio/files/set-4a-output-sink.conf
@@ -0,0 +1,2 @@
+[Service]
+Environment=PULSE_SINK=alsa_output.Radio