summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLorenzo Tilve <ltilve@igalia.com>2020-02-03 11:46:50 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-02-11 21:50:11 +0000
commitfecd22cab132fd110ac2e9af6893eb4bc39c0be5 (patch)
tree114998b0a51520717d0d3327f8c0141067f2ca2d
parentadd253657e477bcb17741e6765bc0e2e676f5f03 (diff)
html5-settings: create recipe and add to html5 demo
Bug-AGL: SPEC-2823 Change-Id: Ia58ae3d871b1f5119daf60ea08378aba6fc75046 Signed-off-by: Lorenzo Tilve <ltilve@igalia.com>
-rw-r--r--recipes-demo-hmi/html5-settings/html5-settings_git.bb25
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb1
2 files changed, 26 insertions, 0 deletions
diff --git a/recipes-demo-hmi/html5-settings/html5-settings_git.bb b/recipes-demo-hmi/html5-settings/html5-settings_git.bb
new file mode 100644
index 00000000..dea1ec35
--- /dev/null
+++ b/recipes-demo-hmi/html5-settings/html5-settings_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "AGL HTML5 Settings Application"
+HOMEPAGE = "https://git.automotivelinux.org/apps/html5-settings/"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git/"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-settings;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+DEPENDS += " nodejs-native"
+
+inherit aglwgt
+
+do_configure() {
+ cd ${B}
+ npm install
+}
+
+do_aglwgt_package() {
+ cd ${B}
+ npm run build
+}
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
index afedf07a..cddab0ba 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
@@ -20,6 +20,7 @@ RDEPENDS_${PN} += "\
AGL_APPS = " \
html5-launcher \
html5-hvac \
+ html5-settings \
"
RDEPENDS_${PN}_append = " \