aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2015-12-05 13:46:17 +0100
committerTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2015-12-22 23:20:40 +0900
commit2ef3a253290cee25348b37d536a1c8580d420da4 (patch)
treef178d0797441338bfb64e952fb2055d5d42c9cac
parent762181dff011efbaf3d40edb1b3d573c5aceab01 (diff)
Cleanup of recipes for CESdemo
Small fix to the README.md adding a dependency. 2 fixes for the agl-demo-platform.bb a) remove porter specifics, they moved to a bbappend in meta-renesas. b) add CESdemo dependencies and install files in /opt by default. v2: Fixed typo in agl-demo-platform.bb v3: Add 'climatecontrolplugin' package to run CES2016 demo. Change-Id: Id6d2d0b1cdcdf3dbc74309322544e0488a6a003c Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org> Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
-rw-r--r--README.md9
-rw-r--r--recipes-platform/images/agl-demo-platform.bb13
2 files changed, 10 insertions, 12 deletions
diff --git a/README.md b/README.md
index eab32ca9..dd08bc21 100644
--- a/README.md
+++ b/README.md
@@ -29,7 +29,7 @@ URI: git://git.yoctoproject.org/poky
> revision: df87cb27efeaea1455f20692f9f1397c6fcab254
URI: git://git.openembedded.org/meta-openembedded
-> layer: meta-oe
+> layer: meta-oe, meta-multimedia, meta-ruby
> branch: dizzy
> revision: 9efaed99125b1c4324663d9a1b2d3319c74e7278
@@ -151,13 +151,10 @@ You can build a QEMU image using the following steps:
2. Build the full image of AGL Demo Platform and applications
$ bitbake agl-demo-platform
- 2a. Specifically If you are building the CES2016 demos you will want to add the following to your "conf/local.conf" file to install the demo code in the image:
-IMAGE_INSTALL_append = " CES2016-demo"
-
- 2b. If you want to run QEMU directly as VM in Virtual Box or your other favorite VM software then add this line to your "conf/local.conf" file.
+ 2a. If you want to run QEMU directly as VM in Virtual Box or your other favorite VM software then add this line to your "conf/local.conf" file.
IMAGE_FSTYPES += "vmdk"
- 2c. The Weston IVI-Shell always gets built ; it will not be started, however, unless you specify the following in your "conf/local.conf" file :
+ 2b. The Weston IVI-Shell always gets built ; it will not be started, however, unless you specify the following in your "conf/local.conf" file :
IMAGE_INSTALL_append = " \
weston-ivi-shell-config \
diff --git a/recipes-platform/images/agl-demo-platform.bb b/recipes-platform/images/agl-demo-platform.bb
index 79c5e25a..a40680df 100644
--- a/recipes-platform/images/agl-demo-platform.bb
+++ b/recipes-platform/images/agl-demo-platform.bb
@@ -15,10 +15,11 @@ IMAGE_INSTALL_append = " \
packagegroup-agl-demo-platform \
"
-# for Renesas R-Car2 M2 Porter
-IMAGE_INSTALL_append_porter = " \
- gles-kernel-module \
- libegl \
- libgbm-dev \
+# add packages for CES2016 demo
+IMAGE_INSTALL_append = " \
+ CES2016-demo \
+ can-utils iproute2 \
+ python-curses \
+ dhcp-client \
+ climatecontrolplugin \
"
-