aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Bachmann <mbc@iot.bzh>2015-12-02 07:41:24 +0000
committerManuel Bachmann <mbc@iot.bzh>2015-12-02 08:50:35 +0000
commit38a51bc5152e2a95fa6d89d5828de643e1592559 (patch)
treea0337ddbaaa4485e988b8ef0eeff6e221558c8c0
parent19240aa96251048ca49a26a80f9b67d3b2130392 (diff)
Provide AM/FM radio QML plugin 0.1
qml-radio-plugin is a standalone QML plugin building on top of Qt5/QML and RTL-SDR (RTL2832U chipsets ; it is planned to also support different hardware). It provides a simple API able to detect, initialize and playback radio from QML applications. It also ships with an example. (Qt itself already provides a Radio class in QtMultimedia, but it has little to no implementations, and is far too much demanding for a start. Let us do this first) Change-Id: Ic6d2417247f7227ccb84d4e1d9f8b1c58319390f Signed-off-by: Manuel Bachmann <mbc@iot.bzh>
-rw-r--r--recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb1
-rw-r--r--recipes-qt/qml-radio-plugin/qml-radio-plugin_0.1.bb31
2 files changed, 32 insertions, 0 deletions
diff --git a/recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb b/recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb
index 8b410f0a..e03c85b0 100644
--- a/recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb
+++ b/recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb
@@ -35,6 +35,7 @@ RDEPENDS_${PN} += "\
qtwayland-plugins \
qtwayland-tools \
qtgraphicaleffects-qmlplugins \
+ qml-radio-plugin \
"
# qtwebkit
diff --git a/recipes-qt/qml-radio-plugin/qml-radio-plugin_0.1.bb b/recipes-qt/qml-radio-plugin/qml-radio-plugin_0.1.bb
new file mode 100644
index 00000000..60360aa0
--- /dev/null
+++ b/recipes-qt/qml-radio-plugin/qml-radio-plugin_0.1.bb
@@ -0,0 +1,31 @@
+SUMMARY = "AM/FM Radio QML plugin (for RTL2832U hardware)"
+DESCRIPTION = "This provides a simple QML plugin able to detect and use radio hardware, most notable RTL2832U chipsets (although it can easily be extended). Among other things, it provides generic APIs to display status, switch between AM/FM mode, choose frequency, mute sound..."
+HOMEPAGE = "https://github.com/iotbzh/qml_radio_plugin"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
+ file://qml_radio.cpp;endline=16;md5=10a65c128e3a6cff2a61bb38556ceb04"
+
+DEPENDS = "qtbase-native qtdeclarative rtl-sdr alsa-lib"
+RDEPENDS_${PN} = "qtdeclarative-tools qtquickcontrols-qmlplugins"
+
+SRC_URI = "git://github.com/iotbzh/qml_radio_plugin"
+SRCREV = "0032dc92d1a208219a0f782b68aef7f4cbcc0028"
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--with-moc-dir=${STAGING_BINDIR_NATIVE}/qt5"
+
+QML_LIBDIR = "${libdir}/qt5/qml"
+
+do_install_append() {
+ # Remove .la files for loadable modules
+ rm -f ${D}/${QML_LIBDIR}/radio/*.la
+ # Install QML example
+ install -d ${D}/${datadir}/qt5/examples/radio
+ install -m 0644 ${S}/radio.qml ${D}/${datadir}/qt5/examples/radio
+}
+
+FILES_${PN} += "${QML_LIBDIR}/radio/*.so ${QML_LIBDIR}/radio/qmldir ${datadir}"
+FILES_${PN}-dbg += "${QML_LIBDIR}/radio/.debug"