aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2015-11-03 22:49:49 +0100
committerGerrit Code Review <gerrit@172.30.200.200>2015-11-04 20:43:44 +0000
commit39912e7554b2f1c88d512955cef5ea1b45ace77c (patch)
tree70a4fd03edd6d703f87a9cf3fc94d50506d7821b
parent84548852f969f2c5de604509ebd62d7ee3a3a1bc (diff)
Add dummy recipes for UI components.
Change-Id: I221367d457685f026c3fee84594a2b25b08ef6e9 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rw-r--r--recipes-demo-hmi/HVAC/HVAC.bb31
-rw-r--r--recipes-demo-hmi/HomeScreen/HomeScreen.bb31
-rw-r--r--recipes-demo-hmi/MediaPlayer/MediaPlayer.bb31
-rw-r--r--recipes-demo-hmi/Settings/Settings.bb31
4 files changed, 124 insertions, 0 deletions
diff --git a/recipes-demo-hmi/HVAC/HVAC.bb b/recipes-demo-hmi/HVAC/HVAC.bb
new file mode 100644
index 00000000..681b84f0
--- /dev/null
+++ b/recipes-demo-hmi/HVAC/HVAC.bb
@@ -0,0 +1,31 @@
+SUMMARY = "${PN} for the AGL Demo Platform"
+DESCRIPTION = "${PN} app"
+HOMEPAGE = "https://git.automotivelinux.org/gerrit/#/admin/projects/AGL/DemoApps/${PN}"
+
+SECTION = "apps"
+
+# To be revised once sourcecode lands
+# LICENSE = "xyz"
+# Dummy MPL-2.0
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
+
+
+SRC_URI = "git://git.automotivelinux.org/gerrit/AGL/DemoApps/${PN};protocol=http"
+SRCREV = "AUTOINC"
+
+# custom configure and install as these are just qml files
+
+# we work in the git checkout ...
+S = "${WORKDIR}/git"
+
+do_configure() {
+ true
+}
+
+# empty folder for now
+do_install() {
+ mkdir -p ${D}/opt/AGL/${PN}/
+}
+
+FILES_${PN} = "/opt/AGL/${PN}/"
diff --git a/recipes-demo-hmi/HomeScreen/HomeScreen.bb b/recipes-demo-hmi/HomeScreen/HomeScreen.bb
new file mode 100644
index 00000000..681b84f0
--- /dev/null
+++ b/recipes-demo-hmi/HomeScreen/HomeScreen.bb
@@ -0,0 +1,31 @@
+SUMMARY = "${PN} for the AGL Demo Platform"
+DESCRIPTION = "${PN} app"
+HOMEPAGE = "https://git.automotivelinux.org/gerrit/#/admin/projects/AGL/DemoApps/${PN}"
+
+SECTION = "apps"
+
+# To be revised once sourcecode lands
+# LICENSE = "xyz"
+# Dummy MPL-2.0
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
+
+
+SRC_URI = "git://git.automotivelinux.org/gerrit/AGL/DemoApps/${PN};protocol=http"
+SRCREV = "AUTOINC"
+
+# custom configure and install as these are just qml files
+
+# we work in the git checkout ...
+S = "${WORKDIR}/git"
+
+do_configure() {
+ true
+}
+
+# empty folder for now
+do_install() {
+ mkdir -p ${D}/opt/AGL/${PN}/
+}
+
+FILES_${PN} = "/opt/AGL/${PN}/"
diff --git a/recipes-demo-hmi/MediaPlayer/MediaPlayer.bb b/recipes-demo-hmi/MediaPlayer/MediaPlayer.bb
new file mode 100644
index 00000000..681b84f0
--- /dev/null
+++ b/recipes-demo-hmi/MediaPlayer/MediaPlayer.bb
@@ -0,0 +1,31 @@
+SUMMARY = "${PN} for the AGL Demo Platform"
+DESCRIPTION = "${PN} app"
+HOMEPAGE = "https://git.automotivelinux.org/gerrit/#/admin/projects/AGL/DemoApps/${PN}"
+
+SECTION = "apps"
+
+# To be revised once sourcecode lands
+# LICENSE = "xyz"
+# Dummy MPL-2.0
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
+
+
+SRC_URI = "git://git.automotivelinux.org/gerrit/AGL/DemoApps/${PN};protocol=http"
+SRCREV = "AUTOINC"
+
+# custom configure and install as these are just qml files
+
+# we work in the git checkout ...
+S = "${WORKDIR}/git"
+
+do_configure() {
+ true
+}
+
+# empty folder for now
+do_install() {
+ mkdir -p ${D}/opt/AGL/${PN}/
+}
+
+FILES_${PN} = "/opt/AGL/${PN}/"
diff --git a/recipes-demo-hmi/Settings/Settings.bb b/recipes-demo-hmi/Settings/Settings.bb
new file mode 100644
index 00000000..681b84f0
--- /dev/null
+++ b/recipes-demo-hmi/Settings/Settings.bb
@@ -0,0 +1,31 @@
+SUMMARY = "${PN} for the AGL Demo Platform"
+DESCRIPTION = "${PN} app"
+HOMEPAGE = "https://git.automotivelinux.org/gerrit/#/admin/projects/AGL/DemoApps/${PN}"
+
+SECTION = "apps"
+
+# To be revised once sourcecode lands
+# LICENSE = "xyz"
+# Dummy MPL-2.0
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
+
+
+SRC_URI = "git://git.automotivelinux.org/gerrit/AGL/DemoApps/${PN};protocol=http"
+SRCREV = "AUTOINC"
+
+# custom configure and install as these are just qml files
+
+# we work in the git checkout ...
+S = "${WORKDIR}/git"
+
+do_configure() {
+ true
+}
+
+# empty folder for now
+do_install() {
+ mkdir -p ${D}/opt/AGL/${PN}/
+}
+
+FILES_${PN} = "/opt/AGL/${PN}/"