aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2015-11-03 23:46:13 +0100
committerGerrit Code Review <gerrit@172.30.200.200>2015-11-04 20:41:26 +0000
commit84548852f969f2c5de604509ebd62d7ee3a3a1bc (patch)
tree6932064db39d2c73d22e14396036a1acbe9005c1
parentd58321651ddaa20dd9876a51031a5de08e654f93 (diff)
Add bitbake recipe for the CES demo.
v2:(Tadao Tanikawa) -add RDEPENDS because CES demo apps depends on qtquickcontrols and qtmultimedia v1:(Jan-Simon Möller) Change-Id: I0aed622d5e9c72695a728398a6e457c261804621 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org> Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
-rw-r--r--recipes-demo-hmi/CES2016-demo/CES2016-demo.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-demo-hmi/CES2016-demo/CES2016-demo.bb b/recipes-demo-hmi/CES2016-demo/CES2016-demo.bb
new file mode 100644
index 00000000..48e242b7
--- /dev/null
+++ b/recipes-demo-hmi/CES2016-demo/CES2016-demo.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Homescreen for the AGL Demonstrator @ CES2016"
+DESCRIPTION = "Homescreen apps in QML format for the AGL Demonstrator @ CES2016"
+HOMEPAGE = "https://git.automotivelinux.org/gerrit/#/admin/projects/AGL/DemoApps/CES2016"
+
+SECTION = "apps"
+
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad"
+
+SRC_URI = "git://git.automotivelinux.org/gerrit/AGL/DemoApps/CES2016;protocol=http"
+SRCREV = "AUTOINC"
+
+RDEPENDS_${PN}_append = "qtmultimedia qtquickcontrols"
+
+# custom configure and install as these are just qml files
+
+# we work in the git checkout ...
+S = "${WORKDIR}/git"
+
+do_configure() {
+ ls
+}
+
+# plain copy in own folder for now
+do_install() {
+ mkdir -p ${D}/opt/AGL/CES2016/
+ cp -ar ./* ${D}/opt/AGL/CES2016/
+}
+
+FILES_${PN} = "/opt/AGL/"