aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2015-11-13 16:21:51 +0900
committerTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2015-11-13 16:21:51 +0900
commit99dcaa369e44f8fc601ecc98362b317e19dafc96 (patch)
tree6432bfd491020534dc757fd9d320e9ca4638915a
parent362043a875cc613687aeb1e9ec8a72461723174c (diff)
Build and install AMB-Qt plugins for QML
This recipe depends on QtDeclarative, so should be placed into meta-agl-demo (not meta-agl/meta-ivi-common). Change-Id: I1f953d3d0005e966db7114b8c098ca628a1a9aaf Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
-rw-r--r--recipes-automotive/automotive-message-broker/automotive-message-broker_git.bbappend16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bbappend b/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bbappend
new file mode 100644
index 00000000..5a60105b
--- /dev/null
+++ b/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bbappend
@@ -0,0 +1,16 @@
+inherit cmake_qt5
+
+PACKAGECONFIG ??= "qmlplugins"
+
+PACKAGECONFIG[qmlplugins] = "-Dqt_bindings=On,,qtdeclarative"
+
+INSANE_SKIP_${PN} = "dev-deps"
+
+FILES_${PN} += " \
+ ${OE_QMAKE_PATH_QML}/amb/qmldir \
+ ${OE_QMAKE_PATH_QML}/amb/libambqtquick.so \
+"
+
+FILES_${PN}-dbg += " \
+ ${OE_QMAKE_PATH_QML}/amb/.debug/libambqtquick.so \
+"