summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2016-10-28 22:21:09 +0900
committerTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2016-10-28 22:27:25 +0900
commiteb689fa7b8a252ca1ae933ca9fe0c57e6757e87d (patch)
tree82753e54e6bea920830845aab290bbd3bf3cc607
parentb5cbc82b0fe8b1761ae629b13f0042474aaa7d0d (diff)
Preparation of upgrading to Qt5.7
Qt5.7 no longer provides any fonts. As a result of this change, fontconfig and some ttf fonts are to be installed for AGL DEMO Apps. Change-Id: I2cee35ccd909d08b47d4f2c6d68414f01fa82853 Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
-rw-r--r--recipes-platform/images/agl-demo-platform.bb9
-rw-r--r--recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb6
-rw-r--r--recipes-qt/qt5/qtbase_%.bbappend2
3 files changed, 10 insertions, 7 deletions
diff --git a/recipes-platform/images/agl-demo-platform.bb b/recipes-platform/images/agl-demo-platform.bb
index 6ed69ad1..7fa34e5f 100644
--- a/recipes-platform/images/agl-demo-platform.bb
+++ b/recipes-platform/images/agl-demo-platform.bb
@@ -15,6 +15,14 @@ IMAGE_INSTALL_append = " \
packagegroup-agl-demo-platform \
"
+# fonts
+IMAGE_TTF_FONTS = " \
+ ttf-bitstream-vera \
+ ttf-dejavu-sans \
+ ttf-dejavu-sans-mono \
+ ttf-dejavu-serif \
+ "
+
# add packages for CES2016 demo
IMAGE_INSTALL_append = " \
als2016-demo \
@@ -24,4 +32,5 @@ IMAGE_INSTALL_append = " \
dhcp-client \
climatecontrolplugin \
Navigation \
+ ${IMAGE_TTF_FONTS} \
"
diff --git a/recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb b/recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb
index 1fe2579f..5444095f 100644
--- a/recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb
+++ b/recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb
@@ -14,12 +14,6 @@ ALLOW_EMPTY_${PN} = "1"
RDEPENDS_${PN} += "\
qtbase \
qtbase-dev \
- qtbase-fonts \
- qtbase-fonts-pfa \
- qtbase-fonts-pfb \
- qtbase-fonts-qpf \
- qtbase-fonts-ttf-dejavu \
- qtbase-fonts-ttf-vera \
qtbase-plugins \
qtbase-staticdev \
qtbase-tools \
diff --git a/recipes-qt/qt5/qtbase_%.bbappend b/recipes-qt/qt5/qtbase_%.bbappend
index d302780f..65ee442a 100644
--- a/recipes-qt/qt5/qtbase_%.bbappend
+++ b/recipes-qt/qt5/qtbase_%.bbappend
@@ -6,7 +6,7 @@ DEPENDS_append_porter = " libegl"
PACKAGECONFIG_WAYLAND = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)}"
PACKAGECONFIG_GL = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2', '', d)}"
PACKAGECONFIG_append = " ${PACKAGECONFIG_WAYLAND} icu accessibility"
-PACKAGECONFIG_append_rpi = " fontconfig"
+PACKAGECONFIG_append = " fontconfig"
EXTRA_OECONF_append = ""