aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2016-12-28 15:49:09 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-12-28 23:04:19 +0000
commit2b0029244a4abee48ac42b0d28d25eacff07e26c (patch)
tree0527ae1a8ae20a351c62fd693bf41b005961a529
parent902589932c94a9c9112fa34f25b6ea867e20bc39 (diff)
ces2017-demo: add install of presets configuration file for Radio app
Add preset configuration files for the Radio app for CES and ALS locations, and commands to install the one selected with a new variable, AGL_RADIO_PRESETS_LOCALE. The default is to use the presets appropriate for CES. Change-Id: I9b278e1c983de16898fc71329afe7c6ba58e9b52 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--recipes-demo-hmi/CES2017-demo/CES2017-demo.bb11
-rw-r--r--recipes-demo-hmi/CES2017-demo/files/presets-ALS.conf12
-rw-r--r--recipes-demo-hmi/CES2017-demo/files/presets-CES.conf14
3 files changed, 34 insertions, 3 deletions
diff --git a/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb b/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
index e66a9600..a81ceaf1 100644
--- a/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
+++ b/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
@@ -12,9 +12,12 @@ DEPENDS = "homescreen zip-native qtmultimedia qtquickcontrols2"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/AGL/DemoApps/CES2017;protocol=http"
-SRCREV = "${AUTOREV}"
+AGL_RADIO_PRESETS_LOCALE ?= "CES"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/AGL/DemoApps/CES2017;protocol=http \
+ file://presets-${AGL_RADIO_PRESETS_LOCALE}.conf \
+"
+SRCREV = "${AUTOREV}"
RDEPENDS_${PN} += " \
qtmultimedia-qmlplugins \
@@ -88,7 +91,6 @@ do_install_prepend() {
zip radio.wgt config.xml radio
-
cat > ${B}/apps/installAllApps.sh <<-EOF
#!/bin/sh
cd /usr/AGL/apps
@@ -111,6 +113,8 @@ do_install() {
install -m 0644 ${B}/apps/Dashboard/dashboard.wgt ${D}/usr/AGL/apps/
install -m 0644 ${B}/apps/Phone/phone.wgt ${D}/usr/AGL/apps/
install -m 0644 ${B}/apps/Radio/radio.wgt ${D}/usr/AGL/apps/
+ install -d ${D}/home/root/app-data/radio
+ install -m 0644 ${WORKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}/home/root/app-data/radio/presets.conf
install -m 0755 ${B}/apps/installAllApps.sh ${D}/usr/AGL/apps/
ln -sf ../apps/installAllApps.sh ${D}/usr/AGL/${PN}/installAllApps.sh
@@ -146,6 +150,7 @@ do_install() {
FILES_${PN} += "/usr/AGL/ \
/usr/AGL/apps/* \
/usr/AGL/${PN}/* \
+ /home/root/app-data/radio/presets.conf \
/usr/lib/qt5/qml/AGL/Demo/Controls/qmldir \
/usr/lib/qt5/qml/AGL/Demo/Controls/ImageButton.qml \
/usr/lib/qt5/qml/AGL/Demo/Controls/ToggleButton.qml \
diff --git a/recipes-demo-hmi/CES2017-demo/files/presets-ALS.conf b/recipes-demo-hmi/CES2017-demo/files/presets-ALS.conf
new file mode 100644
index 00000000..ff559227
--- /dev/null
+++ b/recipes-demo-hmi/CES2017-demo/files/presets-ALS.conf
@@ -0,0 +1,12 @@
+[fmPresets]
+1\frequency=76100000
+1\title=Inter FM
+2\frequency=77100000
+2\title=The Open University of Japan
+3\frequency=80000000
+3\title=TOKYO FM
+4\frequency=81300000
+4\title=J-WAVE
+5\frequency=82500000
+5\title=NHK FM Tokyo
+size=5
diff --git a/recipes-demo-hmi/CES2017-demo/files/presets-CES.conf b/recipes-demo-hmi/CES2017-demo/files/presets-CES.conf
new file mode 100644
index 00000000..83caeffe
--- /dev/null
+++ b/recipes-demo-hmi/CES2017-demo/files/presets-CES.conf
@@ -0,0 +1,14 @@
+[fmPresets]
+1\frequency=93100000
+1\title=93.1 The Mountain
+2\frequency=94100000
+2\title=Mix 94.1
+3\frequency=96300000
+3\title=96.3 KKLZ
+4\frequency=102700000
+4\title=102.7 THE COYOTE
+5\frequency=88900000
+5\title=News 88.9
+6\frequency=91500000
+6\title=KUNV
+size=6