aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-01-02 19:30:48 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-01-04 09:38:45 +0000
commit7e540a7240a786051f50c1b56f61444628cdc82e (patch)
tree9817a2874309fc2efb99e57a00c7fc4a08aaba94
parent320766a2a75760625c6eb3dcb111072dadc40ea0 (diff)
Copy all Radio presets onto the target
Copy all radio presets to the target to allow changes on-the-fly. Change-Id: Ibcbc3300688268d4962bcd7704c9434a3ab0fd58 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rw-r--r--recipes-demo-hmi/CES2017-demo/CES2017-demo.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb b/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
index 2306a364..514aea0b 100644
--- a/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
+++ b/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
@@ -16,13 +16,17 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad"
AGL_RADIO_PRESETS_LOCALE ?= "CES"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/AGL/DemoApps/CES2017;protocol=http \
- file://presets-${AGL_RADIO_PRESETS_LOCALE}.conf \
+ file://presets-ALS.conf \
+ file://presets-CES.conf \
+ file://presets-FOSDEM.conf \
"
SRCREV = "${AUTOREV}"
# Pinned branch/SRCREV for Charming Chinook
SRC_URI_chinook = "git://gerrit.automotivelinux.org/gerrit/AGL/DemoApps/CES2017;protocol=http;branch=chinook \
- file://presets-${AGL_RADIO_PRESETS_LOCALE}.conf \
+ file://presets-ALS.conf \
+ file://presets-CES.conf \
+ file://presets-FOSDEM.conf \
"
SRCREV_chinook = "354195c83841240ddd5f2c5daad97d66cc9e1d28"
@@ -121,6 +125,9 @@ do_install() {
install -m 0644 ${B}/apps/Phone/phone.wgt ${D}/usr/AGL/apps/
install -m 0644 ${B}/apps/Radio/radio.wgt ${D}/usr/AGL/apps/
install -d ${D}/home/root/app-data/radio
+ install -m 0644 ${WORKDIR}/presets-CES.conf ${D}/home/root/app-data/radio/
+ install -m 0644 ${WORKDIR}/presets-ALS.conf ${D}/home/root/app-data/radio/
+ install -m 0644 ${WORKDIR}/presets-FOSDEM.conf ${D}/home/root/app-data/radio/
install -m 0644 ${WORKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}/home/root/app-data/radio/presets.conf
install -m 0755 ${B}/apps/installAllApps.sh ${D}/usr/AGL/apps/
@@ -157,6 +164,7 @@ do_install() {
FILES_${PN} += "/usr/AGL/ \
/usr/AGL/apps/* \
/usr/AGL/${PN}/* \
+ /home/root/app-data/radio/presets-*.conf \
/home/root/app-data/radio/presets.conf \
/usr/lib/qt5/qml/AGL/Demo/Controls/qmldir \
/usr/lib/qt5/qml/AGL/Demo/Controls/ImageButton.qml \