aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-12-29 11:40:00 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-12-29 10:57:48 +0000
commit93a08ff49e1c351f0269db7cbe4f2bb7767691e1 (patch)
tree074a73bad6137c79b9e775faea9028799b559613
parentbeadfbef64d4d9c9db40b71fa4f15e80b0045b77 (diff)
Pin homescreen recipe for chinook
Change-Id: If528266166545262d024ea830b8d807eae0796df Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rw-r--r--recipes-demo-hmi/homescreen/homescreen_git.bb33
1 files changed, 21 insertions, 12 deletions
diff --git a/recipes-demo-hmi/homescreen/homescreen_git.bb b/recipes-demo-hmi/homescreen/homescreen_git.bb
index 2115804b..8f03d0e2 100644
--- a/recipes-demo-hmi/homescreen/homescreen_git.bb
+++ b/recipes-demo-hmi/homescreen/homescreen_git.bb
@@ -1,15 +1,27 @@
SUMMARY = "AGL Home Screen Application"
DESCRIPTION = "AGL Home Screen Application + SampleAppTimeDate + HomeScreenAppFrameworkBinderAGL + WindowManager + InputEventManager"
HOMEPAGE = "https://wiki.automotivelinux.org/homescreen"
-LICENSE = "Apache-2.0"
SECTION = "apps"
-S = "${WORKDIR}/git/"
-BBCLASSEXTEND = " nativesdk"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://HomeScreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-inherit qmake5 systemd pkgconfig
-DEPENDS = " qtbase "
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/staging/HomeScreen.git;protocol=http \
+ file://homescreen.pc.in \
+ file://dbus-homescreen.conf.in"
+SRCREV = "${AUTOREV}"
+
+# Pinned SRCREV for Charming Chinook, staging projects do not follow release branches
+SRCREV_chinook = "5e2ec461d467571834d18df91b1cf37905229db0"
+
+
+# PV needs to be modified with SRCPV to work AUTOREV correctly
+PV = "0.0+git${SRCPV}"
+# git repository used
+S = "${WORKDIR}/git/"
+
+DEPENDS += " qtbase "
# for HomeScreenAppFrameworkBinderTizen:
#DEPENDS += " pkgmgr-info aul "
# for WindowManager:
@@ -19,14 +31,9 @@ DEPENDS += " glib-2.0 "
# for sample apps
DEPENDS += " qtdeclarative qtquickcontrols2 "
-LIC_FILES_CHKSUM = "file://HomeScreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-SRCREV = "${AUTOREV}"
-# PV needs to be modified with SRCPV to work AUTOREV correctly
-PV = "0.0+git${SRCPV}"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/staging/HomeScreen.git;protocol=http \
- file://homescreen.pc.in \
- file://dbus-homescreen.conf.in"
+inherit qmake5 systemd pkgconfig
+
PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
@@ -95,3 +102,5 @@ RDEPENDS_libhomescreen-dbg += "${PN}-dbg libhomescreen-dev"
RDEPENDS_${PN}-dev += "libhomescreen-dev"
+
+BBCLASSEXTEND = " nativesdk"