aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2017-03-29 18:17:51 -0400
committerScott Murray <scott.murray@konsulko.com>2017-03-29 18:23:17 -0400
commitdfcf831dfc1c8420397dc3d9b3d7a8f2d80ff9be (patch)
treecb884e576917b23ad2840784f4b4073c42db5c2d
parentfac2695a7bfb78a8a1b599925cfabe977d71ac98 (diff)
Use split out AGL QtQuickControls2 repositories
Replace usage of the CES2017 repository with the new split out qtquickcontrols2-agl and qtquickcontrols2-agl-style repositories containing the AGL demo custom widgets and style. Since the CES2017-demo recipe no longer serves a purpose, remove it now as well. Bug-AGL: SPEC-404, SPEC-462 Change-Id: I0c31ccfe45c8912da4589e38c2cb159975536aad Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--recipes-demo-hmi/CES2017-demo/CES2017-demo.bb69
-rw-r--r--recipes-demo-hmi/qtquickcontrols2-agl-style/qtquickcontrols2-agl-style_git.bb25
-rw-r--r--recipes-demo-hmi/qtquickcontrols2-agl/qtquickcontrols2-agl_git.bb25
-rw-r--r--recipes-platform/images/agl-demo-platform.bb3
4 files changed, 52 insertions, 70 deletions
diff --git a/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb b/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
deleted file mode 100644
index e96c98f9..00000000
--- a/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
+++ /dev/null
@@ -1,69 +0,0 @@
-SUMMARY = "App Launcher for the AGL Demonstrator @ CES2017"
-DESCRIPTION = "App Lanucher app in QML format for the AGL Demonstrator @ CESS2017"
-HOMEPAGE = "https://git.automotivelinux.org/gerrit/#/admin/projects/AGL/DemoApps/CES2017"
-SECTION = "apps"
-LICENSE = "MPL-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad"
-
-DEPENDS = "homescreen zip-native qtmultimedia qtquickcontrols2"
-
-PV = "1.0+git${SRCPV}"
-PN = "ces2017-demo"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/AGL/DemoApps/CES2017;protocol=http"
-SRCREV = "${AUTOREV}"
-
-# Pinned branch/SRCREV for Charming Chinook
-SRC_URI_chinook = "git://gerrit.automotivelinux.org/gerrit/AGL/DemoApps/CES2017;protocol=http;branch=chinook"
-SRCREV_chinook = "f31423226ad2baf75a770d41dae1b0ec42bf7ff1"
-
-S = "${WORKDIR}/git/"
-
-inherit qmake5
-
-do_install() {
- install -d ${D}${libdir}/qt5/qml/AGL/Demo/Controls/
- install -m 0644 ${S}/imports/AGL/Demo/Controls/qmldir ${D}${libdir}/qt5/qml/AGL/Demo/Controls/
- install -m 0644 ${S}/imports/AGL/Demo/Controls/ImageButton.qml ${D}${libdir}/qt5/qml/AGL/Demo/Controls/
- install -m 0644 ${S}/imports/AGL/Demo/Controls/ToggleButton.qml ${D}${libdir}/qt5/qml/AGL/Demo/Controls/
- install -m 0644 ${S}/imports/AGL/Demo/Controls/Key.qml ${D}${libdir}/qt5/qml/AGL/Demo/Controls/
- install -m 0644 ${S}/imports/AGL/Demo/Controls/AbstractKeyboard.qml ${D}${libdir}/qt5/qml/AGL/Demo/Controls/
- install -m 0644 ${S}/imports/AGL/Demo/Controls/Symbols.qml ${D}${libdir}/qt5/qml/AGL/Demo/Controls/
- install -m 0644 ${S}/imports/AGL/Demo/Controls/Alphabet.qml ${D}${libdir}/qt5/qml/AGL/Demo/Controls/
- install -m 0644 ${S}/imports/AGL/Demo/Controls/Keyboard.qml ${D}${libdir}/qt5/qml/AGL/Demo/Controls/
- install -d ${D}${libdir}/qt5/qml/AGL/Demo/Controls/images/
- install -m 0644 ${S}/imports/AGL/Demo/Controls/images/Keyboard_Back.svg ${D}${libdir}/qt5/qml/AGL/Demo/Controls/images/
- install -m 0644 ${S}/imports/AGL/Demo/Controls/images/Keyboard_Shift.svg ${D}${libdir}/qt5/qml/AGL/Demo/Controls/images/
- install -m 0644 ${S}/imports/AGL/Demo/Controls/images/Keyboard_Space.svg ${D}${libdir}/qt5/qml/AGL/Demo/Controls/images/
- install -m 0644 ${S}/imports/AGL/Demo/Controls/images/Keyboard_Arrow.svg ${D}${libdir}/qt5/qml/AGL/Demo/Controls/images/
-
- install -d ${D}${libdir}/qt5/qml/QtQuick/Controls.2/AGL
- install -m 0644 ${S}/imports/qtquickcontrols2aglstyle/*.qml ${D}${libdir}/qt5/qml/QtQuick/Controls.2/AGL
-
- install -d ${D}${libdir}/qt5/qml/QtQuick/Controls.2/AGL/images/
- install -m 0644 ${S}/imports/qtquickcontrols2aglstyle/images/* ${D}${libdir}/qt5/qml/QtQuick/Controls.2/AGL/images/
-}
-
-FILES_${PN} += " \
- /usr/AGL/ \
- /usr/lib/qt5/qml/AGL/Demo/Controls/qmldir \
- /usr/lib/qt5/qml/AGL/Demo/Controls/ImageButton.qml \
- /usr/lib/qt5/qml/AGL/Demo/Controls/ToggleButton.qml \
- /usr/lib/qt5/qml/AGL/Demo/Controls/Key.qml \
- /usr/lib/qt5/qml/AGL/Demo/Controls/AbstractKeyboard.qml \
- /usr/lib/qt5/qml/AGL/Demo/Controls/Symbols.qml \
- /usr/lib/qt5/qml/AGL/Demo/Controls/Alphabet.qml \
- /usr/lib/qt5/qml/AGL/Demo/Controls/Keyboard.qml \
- /usr/lib/qt5/qml/AGL/Demo/Controls/images/Keyboard_Back.svg \
- /usr/lib/qt5/qml/AGL/Demo/Controls/images/Keyboard_Shift.svg \
- /usr/lib/qt5/qml/AGL/Demo/Controls/images/Keyboard_Space.svg \
- /usr/lib/qt5/qml/AGL/Demo/Controls/images/Keyboard_Arrow.svg \
- /usr/lib/qt5/qml/QtQuick/Controls.2/AGL \
- /usr/lib/qt5/qml/QtQuick/Controls.2/AGL/images \
-"
-
-RDEPENDS_${PN} += " \
- qtquickcontrols-qmlplugins \
- qtquickcontrols2-qmlplugins \
- qtsvg-plugins \
-"
diff --git a/recipes-demo-hmi/qtquickcontrols2-agl-style/qtquickcontrols2-agl-style_git.bb b/recipes-demo-hmi/qtquickcontrols2-agl-style/qtquickcontrols2-agl-style_git.bb
new file mode 100644
index 00000000..3deaf1fb
--- /dev/null
+++ b/recipes-demo-hmi/qtquickcontrols2-agl-style/qtquickcontrols2-agl-style_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "AGL QtQuickControls2 style customizations"
+HOMEPAGE = "https://git.automotivelinux.org/gerrit/#/admin/projects/src/qtquickcontrols2-agl-style"
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad"
+
+PV = "1.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qtquickcontrols2-agl-style;protocol=http"
+SRCREV = "${AUTOREV}"
+
+# Pinned branch/SRCREV for Charming Chinook
+SRC_URI_chinook = "git://gerrit.automotivelinux.org/gerrit/src/qtquickcontrols2-agl-style;protocol=http;branch=chinook"
+SRCREV_chinook = "a78db8638590c797c78c36b2ef3de5ed9c012bba"
+
+S = "${WORKDIR}/git/"
+
+inherit qmake5
+
+FILES_${PN} += "${OE_QMAKE_PATH_QML}/QtQuick/Controls.2/AGL/*"
+
+RDEPENDS_${PN} += " \
+ qtquickcontrols-qmlplugins \
+ qtquickcontrols2-qmlplugins \
+ qtsvg-plugins \
+"
diff --git a/recipes-demo-hmi/qtquickcontrols2-agl/qtquickcontrols2-agl_git.bb b/recipes-demo-hmi/qtquickcontrols2-agl/qtquickcontrols2-agl_git.bb
new file mode 100644
index 00000000..094edf7b
--- /dev/null
+++ b/recipes-demo-hmi/qtquickcontrols2-agl/qtquickcontrols2-agl_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "AGL demo custom QtQuickControls2 widgets"
+HOMEPAGE = "https://git.automotivelinux.org/gerrit/#/admin/projects/src/qtquickcontrols2-agl"
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad"
+
+PV = "1.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qtquickcontrols2-agl;protocol=http"
+SRCREV = "${AUTOREV}"
+
+# Pinned branch/SRCREV for Charming Chinook
+SRC_URI_chinook = "git://gerrit.automotivelinux.org/gerrit/src/qtquickcontrols2-agl;protocol=http;branch=chinook"
+SRCREV_chinook = "a7ac743468f50d6d2e2c3bcd275adc53b7ac26b1"
+
+S = "${WORKDIR}/git/"
+
+inherit qmake5
+
+FILES_${PN} += "${OE_QMAKE_PATH_QML}/AGL/Demo/Controls/*"
+
+RDEPENDS_${PN} += " \
+ qtquickcontrols-qmlplugins \
+ qtquickcontrols2-qmlplugins \
+ qtsvg-plugins \
+"
diff --git a/recipes-platform/images/agl-demo-platform.bb b/recipes-platform/images/agl-demo-platform.bb
index d1381218..ab32817c 100644
--- a/recipes-platform/images/agl-demo-platform.bb
+++ b/recipes-platform/images/agl-demo-platform.bb
@@ -73,13 +73,14 @@ IMAGE_AGL_APPS = " \
"
IMAGE_INSTALL_append = " \
- ces2017-demo \
linux-firmware-ath9k \
linux-firmware-ralink \
can-utils \
iproute2 \
python-curses \
dhcp-client \
+ qtquickcontrols2-agl \
+ qtquickcontrols2-agl-style \
${IMAGE_MAPVIEWER} \
${IMAGE_MOST_HVAC} \
${IMAGE_AGL_APPS} \