summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Porter <mporter@konsulko.com>2016-12-21 18:50:13 +0200
committerMatt Porter <mporter@konsulko.com>2016-12-21 18:50:13 +0200
commit5123685a5069f5f8e190c1e688958b86ece181c2 (patch)
tree0e053783c71bd3cb18f5d1ae21aa25845e3a8092
parenta56ca4d7070289e09b27d944d4b63834da434262 (diff)
Add AGL mixer application recipe
The mixer app provides a direct interface to PulseAudio mixer elements for AGL demonstration and development purposes. The resulting app widget must first be installed via the application framework. To install, enter the following on the target console: # cd /usr/AGL/apps # afm-util install mixer.wgt Change-Id: I8fa976f7055909b196a1892e7cf59b0e0ad0dd8e Signed-off-by: Matt Porter <mporter@konsulko.com>
-rw-r--r--recipes-demo-hmi/mixer/mixer_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-demo-hmi/mixer/mixer_git.bb b/recipes-demo-hmi/mixer/mixer_git.bb
new file mode 100644
index 00000000..c7f30a16
--- /dev/null
+++ b/recipes-demo-hmi/mixer/mixer_git.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Mixer for CES2017 AGL Demonstration"
+DESCRIPTION = "AGL HMI application for control of PulseAudio mixer elements"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/mixer"
+LICENSE = "Apache-2.0"
+SECTION = "apps"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit qmake5
+
+DEPENDS += "qtquickcontrols2"
+# 'wgtpkg-pack' in af-main-native is required.
+DEPENDS += "af-main-native"
+DEPENDS += "pulseaudio"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mixer;protocol=http"
+SRCREV = "${AUTOREV}"
+
+RDEPENDS_${PN} += " \
+ qtmultimedia-qmlplugins \
+ qtquickcontrols2-qmlplugins \
+ "
+
+do_install() {
+ install -d ${D}/usr/AGL/apps
+ install -m 0644 ${B}/package/${PN}.wgt ${D}/usr/AGL/apps/
+}
+
+FILES_${PN} += "/usr/AGL/apps/ \
+ /usr/AGL/apps/${PN} \
+ "