summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>2016-12-26 20:21:43 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-12-27 14:50:38 +0000
commit276f30ef24715c9c86a9b63e7406dd9a8cc93a0c (patch)
tree86b7a077434186f5fde1c2763688fba6cefac37d
parentdd70c8c5298a1fea8b2ff2be50536af777b9dfaa (diff)
Merge the installation script to ces2017-demo
I divided the script of Navi, but I will do the merge. With this change, all installations are done with one script. This patch solves the problem that navigation can not be started. Change-Id: I523b85cbee19531345c2e3fdaffc9c8c5f6b9c1b Signed-off-by: Naoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
-rw-r--r--recipes-demo-hmi/CES2017-demo/CES2017-demo.bb5
-rw-r--r--recipes-demo-hmi/navigation/poiapp/installNaviApps.sh6
-rw-r--r--recipes-demo-hmi/navigation/poiapp_git.bb4
3 files changed, 6 insertions, 9 deletions
diff --git a/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb b/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
index 777f98e6..ef4b48d7 100644
--- a/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
+++ b/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
@@ -97,6 +97,11 @@ do_install_prepend() {
/usr/bin/afm-util install radio.wgt
/usr/bin/afm-util install settings.wgt
/usr/bin/afm-util install navigation.wgt
+ /usr/bin/afm-util install poi.wgt
+
+ #it's Workaround
+ cyad -s -k MANIFESTS -t allow -c User::App::navigation -u '*' -p 'http://tizen.org/privilege/internal/dbus'
+ cyad -s -k MANIFESTS -t allow -c User::App::poi -u '*' -p 'http://tizen.org/privilege/internal/dbus'
EOF
}
diff --git a/recipes-demo-hmi/navigation/poiapp/installNaviApps.sh b/recipes-demo-hmi/navigation/poiapp/installNaviApps.sh
deleted file mode 100644
index 50f27d69..00000000
--- a/recipes-demo-hmi/navigation/poiapp/installNaviApps.sh
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-/usr/bin/afm-util install poi.wgt
-
-#it's Workaround
-cyad -s -k MANIFESTS -t allow -c User::App::navigation -u '*' -p 'http://tizen.org/privilege/internal/dbus'
-cyad -s -k MANIFESTS -t allow -c User::App::poi -u '*' -p 'http://tizen.org/privilege/internal/dbus'
diff --git a/recipes-demo-hmi/navigation/poiapp_git.bb b/recipes-demo-hmi/navigation/poiapp_git.bb
index 45753660..42707bab 100644
--- a/recipes-demo-hmi/navigation/poiapp_git.bb
+++ b/recipes-demo-hmi/navigation/poiapp_git.bb
@@ -9,7 +9,6 @@ DEPENDS += " qtbase libdbus-c++ json-c \
SRCREV="4e09ab88d0d97c59896ba66bf08a8e006e2af81a"
SRC_URI="git://github.com/AGLExport/genivi-navi-yelp-client.git;branch=new-layout \
file://config.xml \
- file://installNaviApps.sh \
"
RDEPENDS_${PN} = " navigation "
@@ -25,7 +24,6 @@ do_install_append() {
install -d ${D}/usr/AGL/ces2017-demo
install -m 0644 ${WORKDIR}/widget/poi.wgt ${D}/usr/AGL/ces2017-demo/
- install -m 0755 ${WORKDIR}/installNaviApps.sh ${D}/usr/AGL/ces2017-demo/
}
-FILES_${PN} += " /usr/AGL/ces2017-demo/poi.wgt /usr/AGL/ces2017-demo/installNaviApps.sh "
+FILES_${PN} += " /usr/AGL/ces2017-demo/poi.wgt "