summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2016-12-21 18:14:11 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-12-22 22:23:51 +0000
commit32b8cd3398e2f8bdbe02b16b5c24a6ab21c474b0 (patch)
tree7c469df3164270ede98c6a1c9a17dfc140f41a8a
parent49806ebb05a7d77c7e88f541c8d712c5e8a148ef (diff)
Add packages to agl-demo-platform for CES2017 Demo
Adding packages for CES2017 Demo to be incliuded in agl-demo-platform by default. This changes add below apps and related packages: MediaPlayer from apps/mediaplayer Settings from apps/settings HVAC from apps/hvac MOST network VOD Service v4 (jsmoeller): mark drivers as porter specific and conditionalize the inclusion for porter only v3 (jsmoeller): rebase on master v2 (jsmoeller): make can-lin conditional to porter board Change-Id: I4e89607508df2e630f46fcbcb64d4babb66a2d6f Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com> Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rw-r--r--recipes-demo-hmi/can-lin/can-lin_0.2.bb3
-rw-r--r--recipes-kernel/aim-cdev/aim-cdev.bb3
-rw-r--r--recipes-kernel/aim-network/aim-network.bb3
-rw-r--r--recipes-kernel/aim-sound/aim-sound.bb3
-rw-r--r--recipes-kernel/aim-v4l2/aim-v4l2.bb3
-rw-r--r--recipes-kernel/hdm-dim2/hdm-dim2.bb3
-rw-r--r--recipes-kernel/hdm-i2c/hdm-i2c.bb3
-rw-r--r--recipes-kernel/hdm-usb/hdm-usb.bb3
-rw-r--r--recipes-kernel/mocca-usb/_files/COPYING340
-rw-r--r--recipes-kernel/mocca-usb/_files/Makefile17
-rw-r--r--recipes-kernel/mocca-usb/_files/_Makefile42
-rw-r--r--recipes-kernel/mocca-usb/_files/mocca_usb.c391
-rw-r--r--recipes-kernel/mocca-usb/mocca-usb.bb3
-rw-r--r--recipes-kernel/mostcore/mostcore.bb3
-rw-r--r--recipes-platform/images/agl-demo-platform.bb37
15 files changed, 67 insertions, 790 deletions
diff --git a/recipes-demo-hmi/can-lin/can-lin_0.2.bb b/recipes-demo-hmi/can-lin/can-lin_0.2.bb
index b12bc0ff..efbda3c6 100644
--- a/recipes-demo-hmi/can-lin/can-lin_0.2.bb
+++ b/recipes-demo-hmi/can-lin/can-lin_0.2.bb
@@ -8,6 +8,9 @@ SRC_URI += "file://hvac-demo.service"
S = "${WORKDIR}/git"
SRCREV = "fd2101e277cb80eef4c6381924cfdc1d50087d12"
+# These binaries are currently for the porter kernel only
+COMPATIBLE_MACHINE = "porter"
+
do_install() {
install -m 0755 -d ${D}${bindir}
install -m 0755 ${S}/OptoLyzerMoccaApp ${D}${bindir}
diff --git a/recipes-kernel/aim-cdev/aim-cdev.bb b/recipes-kernel/aim-cdev/aim-cdev.bb
index b43800ec..66a294b9 100644
--- a/recipes-kernel/aim-cdev/aim-cdev.bb
+++ b/recipes-kernel/aim-cdev/aim-cdev.bb
@@ -24,3 +24,6 @@ do_install_append () {
echo "aim_cdev" > ${D}${sysconfdir}/modules-load.d/aim_cdev.conf
fi
}
+
+# These sources are currently for the porter kernel only
+COMPATIBLE_MACHINE = "porter"
diff --git a/recipes-kernel/aim-network/aim-network.bb b/recipes-kernel/aim-network/aim-network.bb
index ce3d7677..ce504ead 100644
--- a/recipes-kernel/aim-network/aim-network.bb
+++ b/recipes-kernel/aim-network/aim-network.bb
@@ -24,3 +24,6 @@ do_install_append () {
echo "aim_network" > ${D}${sysconfdir}/modules-load.d/aim_network.conf
fi
}
+
+# These sources are currently for the porter kernel only
+COMPATIBLE_MACHINE = "porter"
diff --git a/recipes-kernel/aim-sound/aim-sound.bb b/recipes-kernel/aim-sound/aim-sound.bb
index 02d79077..3740d257 100644
--- a/recipes-kernel/aim-sound/aim-sound.bb
+++ b/recipes-kernel/aim-sound/aim-sound.bb
@@ -24,3 +24,6 @@ do_install_append () {
echo "aim_sound" > ${D}${sysconfdir}/modules-load.d/aim_sound.conf
fi
}
+
+# These sources are currently for the porter kernel only
+COMPATIBLE_MACHINE = "porter"
diff --git a/recipes-kernel/aim-v4l2/aim-v4l2.bb b/recipes-kernel/aim-v4l2/aim-v4l2.bb
index 12336960..c3261034 100644
--- a/recipes-kernel/aim-v4l2/aim-v4l2.bb
+++ b/recipes-kernel/aim-v4l2/aim-v4l2.bb
@@ -24,3 +24,6 @@ do_install_append () {
echo "aim_v4l2" > ${D}${sysconfdir}/modules-load.d/aim_v4l2.conf
fi
}
+
+# These sources are currently for the porter kernel only
+COMPATIBLE_MACHINE = "porter"
diff --git a/recipes-kernel/hdm-dim2/hdm-dim2.bb b/recipes-kernel/hdm-dim2/hdm-dim2.bb
index d9cdf4d8..3a73e5ec 100644
--- a/recipes-kernel/hdm-dim2/hdm-dim2.bb
+++ b/recipes-kernel/hdm-dim2/hdm-dim2.bb
@@ -24,3 +24,6 @@ do_install_append () {
echo "hdm_dim2" > ${D}${sysconfdir}/modules-load.d/hdm_dim2.conf
fi
}
+
+# These sources are currently for the porter kernel only
+COMPATIBLE_MACHINE = "porter"
diff --git a/recipes-kernel/hdm-i2c/hdm-i2c.bb b/recipes-kernel/hdm-i2c/hdm-i2c.bb
index 6e51106b..92184afd 100644
--- a/recipes-kernel/hdm-i2c/hdm-i2c.bb
+++ b/recipes-kernel/hdm-i2c/hdm-i2c.bb
@@ -24,3 +24,6 @@ do_install_append () {
echo "hdm_i2c" > ${D}${sysconfdir}/modules-load.d/hdm_i2c.conf
fi
}
+
+# These sources are currently for the porter kernel only
+COMPATIBLE_MACHINE = "porter"
diff --git a/recipes-kernel/hdm-usb/hdm-usb.bb b/recipes-kernel/hdm-usb/hdm-usb.bb
index d8724d4f..41741279 100644
--- a/recipes-kernel/hdm-usb/hdm-usb.bb
+++ b/recipes-kernel/hdm-usb/hdm-usb.bb
@@ -24,3 +24,6 @@ do_install_append () {
echo "hdm_usb" > ${D}${sysconfdir}/modules-load.d/hdm_usb.conf
fi
}
+
+# These sources are currently for the porter kernel only
+COMPATIBLE_MACHINE = "porter"
diff --git a/recipes-kernel/mocca-usb/_files/COPYING b/recipes-kernel/mocca-usb/_files/COPYING
deleted file mode 100644
index 6d45519c..00000000
--- a/recipes-kernel/mocca-usb/_files/COPYING
+++ /dev/null
@@ -1,340 +0,0 @@
- GNU GENERAL PUBLIC LICENSE
- Version 2, June 1991
-
- Copyright (C) 1989, 1991 Free Software Foundation, Inc.
- 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
- Everyone is permitted to copy and distribute verbatim copies
- of this license document, but changing it is not allowed.
-
- Preamble
-
- The licenses for most software are designed to take away your
-freedom to share and change it. By contrast, the GNU General Public
-License is intended to guarantee your freedom to share and change free
-software--to make sure the software is free for all its users. This
-General Public License applies to most of the Free Software
-Foundation's software and to any other program whose authors commit to
-using it. (Some other Free Software Foundation software is covered by
-the GNU Library General Public License instead.) You can apply it to
-your programs, too.
-
- When we speak of free software, we are referring to freedom, not
-price. Our General Public Licenses are designed to make sure that you
-have the freedom to distribute copies of free software (and charge for
-this service if you wish), that you receive source code or can get it
-if you want it, that you can change the software or use pieces of it
-in new free programs; and that you know you can do these things.
-
- To protect your rights, we need to make restrictions that forbid
-anyone to deny you these rights or to ask you to surrender the rights.
-These restrictions translate to certain responsibilities for you if you
-distribute copies of the software, or if you modify it.
-
- For example, if you distribute copies of such a program, whether
-gratis or for a fee, you must give the recipients all the rights that
-you have. You must make sure that they, too, receive or can get the
-source code. And you must show them these terms so they know their
-rights.
-
- We protect your rights with two steps: (1) copyright the software, and
-(2) offer you this license which gives you legal permission to copy,
-distribute and/or modify the software.
-
- Also, for each author's protection and ours, we want to make certain
-that everyone understands that there is no warranty for this free
-software. If the software is modified by someone else and passed on, we
-want its recipients to know that what they have is not the original, so
-that any problems introduced by others will not reflect on the original
-authors' reputations.
-
- Finally, any free program is threatened constantly by software
-patents. We wish to avoid the danger that redistributors of a free
-program will individually obtain patent licenses, in effect making the
-program proprietary. To prevent this, we have made it clear that any
-patent must be licensed for everyone's free use or not licensed at all.
-
- The precise terms and conditions for copying, distribution and
-modification follow.
-
- GNU GENERAL PUBLIC LICENSE
- TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION
-
- 0. This License applies to any program or other work which contains
-a notice placed by the copyright holder saying it may be distributed
-under the terms of this General Public License. The "Program", below,
-refers to any such program or work, and a "work based on the Program"
-means either the Program or any derivative work under copyright law:
-that is to say, a work containing the Program or a portion of it,
-either verbatim or with modifications and/or translated into another
-language. (Hereinafter, translation is included without limitation in
-the term "modification".) Each licensee is addressed as "you".
-
-Activities other than copying, distribution and modification are not
-covered by this License; they are outside its scope. The act of
-running the Program is not restricted, and the output from the Program
-is covered only if its contents constitute a work based on the
-Program (independent of having been made by running the Program).
-Whether that is true depends on what the Program does.
-
- 1. You may copy and distribute verbatim copies of the Program's
-source code as you receive it, in any medium, provided that you
-conspicuously and appropriately publish on each copy an appropriate
-copyright notice and disclaimer of warranty; keep intact all the
-notices that refer to this License and to the absence of any warranty;
-and give any other recipients of the Program a copy of this License
-along with the Program.
-
-You may charge a fee for the physical act of transferring a copy, and
-you may at your option offer warranty protection in exchange for a fee.
-
- 2. You may modify your copy or copies of the Program or any portion
-of it, thus forming a work based on the Program, and copy and
-distribute such modifications or work under the terms of Section 1
-above, provided that you also meet all of these conditions:
-
- a) You must cause the modified files to carry prominent notices
- stating that you changed the files and the date of any change.
-
- b) You must cause any work that you distribute or publish, that in
- whole or in part contains or is derived from the Program or any
- part thereof, to be licensed as a whole at no charge to all third
- parties under the terms of this License.
-
- c) If the modified program normally reads commands interactively
- when run, you must cause it, when started running for such
- interactive use in the most ordinary way, to print or display an
- announcement including an appropriate copyright notice and a
- notice that there is no warranty (or else, saying that you provide
- a warranty) and that users may redistribute the program under
- these conditions, and telling the user how to view a copy of this
- License. (Exception: if the Program itself is interactive but
- does not normally print such an announcement, your work based on
- the Program is not required to print an announcement.)
-
-These requirements apply to the modified work as a whole. If
-identifiable sections of that work are not derived from the Program,
-and can be reasonably considered independent and separate works in
-themselves, then this License, and its terms, do not apply to those
-sections when you distribute them as separate works. But when you
-distribute the same sections as part of a whole which is a work based
-on the Program, the distribution of the whole must be on the terms of
-this License, whose permissions for other licensees extend to the
-entire whole, and thus to each and every part regardless of who wrote it.
-
-Thus, it is not the intent of this section to claim rights or contest
-your rights to work written entirely by you; rather, the intent is to
-exercise the right to control the distribution of derivative or
-collective works based on the Program.
-
-In addition, mere aggregation of another work not based on the Program
-with the Program (or with a work based on the Program) on a volume of
-a storage or distribution medium does not bring the other work under
-the scope of this License.
-
- 3. You may copy and distribute the Program (or a work based on it,
-under Section 2) in object code or executable form under the terms of
-Sections 1 and 2 above provided that you also do one of the following:
-
- a) Accompany it with the complete corresponding machine-readable
- source code, which must be distributed under the terms of Sections
- 1 and 2 above on a medium customarily used for software interchange; or,
-
- b) Accompany it with a written offer, valid for at least three
- years, to give any third party, for a charge no more than your
- cost of physically performing source distribution, a complete
- machine-readable copy of the corresponding source code, to be
- distributed under the terms of Sections 1 and 2 above on a medium
- customarily used for software interchange; or,
-
- c) Accompany it with the information you received as to the offer
- to distribute corresponding source code. (This alternative is
- allowed only for noncommercial distribution and only if you
- received the program in object code or executable form with such
- an offer, in accord with Subsection b above.)
-
-The source code for a work means the preferred form of the work for
-making modifications to it. For an executable work, complete source
-code means all the source code for all modules it contains, plus any
-associated interface definition files, plus the scripts used to
-control compilation and installation of the executable. However, as a
-special exception, the source code distributed need not include
-anything that is normally distributed (in either source or binary
-form) with the major components (compiler, kernel, and so on) of the
-operating system on which the executable runs, unless that component
-itself accompanies the executable.
-
-If distribution of executable or object code is made by offering
-access to copy from a designated place, then offering equivalent
-access to copy the source code from the same place counts as
-distribution of the source code, even though third parties are not
-compelled to copy the source along with the object code.
-
- 4. You may not copy, modify, sublicense, or distribute the Program
-except as expressly provided under this License. Any attempt
-otherwise to copy, modify, sublicense or distribute the Program is
-void, and will automatically terminate your rights under this License.
-However, parties who have received copies, or rights, from you under
-this License will not have their licenses terminated so long as such
-parties remain in full compliance.
-
- 5. You are not required to accept this License, since you have not
-signed it. However, nothing else grants you permission to modify or
-distribute the Program or its derivative works. These actions are
-prohibited by law if you do not accept this License. Therefore, by
-modifying or distributing the Program (or any work based on the
-Program), you indicate your acceptance of this License to do so, and
-all its terms and conditions for copying, distributing or modifying
-the Program or works based on it.
-
- 6. Each time you redistribute the Program (or any work based on the
-Program), the recipient automatically receives a license from the
-original licensor to copy, distribute or modify the Program subject to
-these terms and conditions. You may not impose any further
-restrictions on the recipients' exercise of the rights granted herein.
-You are not responsible for enforcing compliance by third parties to
-this License.
-
- 7. If, as a consequence of a court judgment or allegation of patent
-infringement or for any other reason (not limited to patent issues),
-conditions are imposed on you (whether by court order, agreement or
-otherwise) that contradict the conditions of this License, they do not
-excuse you from the conditions of this License. If you cannot
-distribute so as to satisfy simultaneously your obligations under this
-License and any other pertinent obligations, then as a consequence you
-may not distribute the Program at all. For example, if a patent
-license would not permit royalty-free redistribution of the Program by
-all those who receive copies directly or indirectly through you, then
-the only way you could satisfy both it and this License would be to
-refrain entirely from distribution of the Program.
-
-If any portion of this section is held invalid or unenforceable under
-any particular circumstance, the balance of the section is intended to
-apply and the section as a whole is intended to apply in other
-circumstances.
-
-It is not the purpose of this section to induce you to infringe any
-patents or other property right claims or to contest validity of any
-such claims; this section has the sole purpose of protecting the
-integrity of the free software distribution system, which is
-implemented by public license practices. Many people have made
-generous contributions to the wide range of software distributed
-through that system in reliance on consistent application of that
-system; it is up to the author/donor to decide if he or she is willing
-to distribute software through any other system and a licensee cannot
-impose that choice.
-
-This section is intended to make thoroughly clear what is believed to
-be a consequence of the rest of this License.
-
- 8. If the distribution and/or use of the Program is restricted in
-certain countries either by patents or by copyrighted interfaces, the
-original copyright holder who places the Program under this License
-may add an explicit geographical distribution limitation excluding
-those countries, so that distribution is permitted only in or among
-countries not thus excluded. In such case, this License incorporates
-the limitation as if written in the body of this License.
-
- 9. The Free Software Foundation may publish revised and/or new versions
-of the General Public License from time to time. Such new versions will
-be similar in spirit to the present version, but may differ in detail to
-address new problems or concerns.
-
-Each version is given a distinguishing version number. If the Program
-specifies a version number of this License which applies to it and "any
-later version", you have the option of following the terms and conditions
-either of that version or of any later version published by the Free
-Software Foundation. If the Program does not specify a version number of
-this License, you may choose any version ever published by the Free Software
-Foundation.
-
- 10. If you wish to incorporate parts of the Program into other free
-programs whose distribution conditions are different, write to the author
-to ask for permission. For software which is copyrighted by the Free
-Software Foundation, write to the Free Software Foundation; we sometimes
-make exceptions for this. Our decision will be guided by the two goals
-of preserving the free status of all derivatives of our free software and
-of promoting the sharing and reuse of software generally.
-
- NO WARRANTY
-
- 11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY
-FOR THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN
-OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES
-PROVIDE THE PROGRAM "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED
-OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS
-TO THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE
-PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING,
-REPAIR OR CORRECTION.
-
- 12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING
-WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR
-REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES,
-INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING
-OUT OF THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED
-TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY
-YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER
-PROGRAMS), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE
-POSSIBILITY OF SUCH DAMAGES.
-
- END OF TERMS AND CONDITIONS
-
- How to Apply These Terms to Your New Programs
-
- If you develop a new program, and you want it to be of the greatest
-possible use to the public, the best way to achieve this is to make it
-free software which everyone can redistribute and change under these terms.
-
- To do so, attach the following notices to the program. It is safest
-to attach them to the start of each source file to most effectively
-convey the exclusion of warranty; and each file should have at least
-the "copyright" line and a pointer to where the full notice is found.
-
- <one line to give the program's name and a brief idea of what it does.>
- Copyright (C) <year> <name of author>
-
- This program is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 2 of the License, or
- (at your option) any later version.
-
- This program is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this program; if not, write to the Free Software
- Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
-
-
-Also add information on how to contact you by electronic and paper mail.
-
-If the program is interactive, make it output a short notice like this
-when it starts in an interactive mode:
-
- Gnomovision version 69, Copyright (C) year name of author
- Gnomovision comes with ABSOLUTELY NO WARRANTY; for details type `show w'.
- This is free software, and you are welcome to redistribute it
- under certain conditions; type `show c' for details.
-
-The hypothetical commands `show w' and `show c' should show the appropriate
-parts of the General Public License. Of course, the commands you use may
-be called something other than `show w' and `show c'; they could even be
-mouse-clicks or menu items--whatever suits your program.
-
-You should also get your employer (if you work as a programmer) or your
-school, if any, to sign a "copyright disclaimer" for the program, if
-necessary. Here is a sample; alter the names:
-
- Yoyodyne, Inc., hereby disclaims all copyright interest in the program
- `Gnomovision' (which makes passes at compilers) written by James Hacker.
-
- <signature of Ty Coon>, 1 April 1989
- Ty Coon, President of Vice
-
-This General Public License does not permit incorporating your program into
-proprietary programs. If your program is a subroutine library, you may
-consider it more useful to permit linking proprietary applications with the
-library. If this is what you want to do, use the GNU Library General
-Public License instead of this License.
diff --git a/recipes-kernel/mocca-usb/_files/Makefile b/recipes-kernel/mocca-usb/_files/Makefile
deleted file mode 100644
index fd82dbcd..00000000
--- a/recipes-kernel/mocca-usb/_files/Makefile
+++ /dev/null
@@ -1,17 +0,0 @@
-# Makefile
-#
-
-SRC := $(shell pwd)
-
-obj-m += mocca_usb.o
-CFLAGS_hdm_usb.o := -I$(src)/../../aim-network/files/ -I$(src)/../../mostcore/files
-
-all:
- $(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules
-
-modules_install:
- $(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules_install
-
-clean:
- $(MAKE) -C $(KERNEL_SRC) M=$(SRC) clean
-
diff --git a/recipes-kernel/mocca-usb/_files/_Makefile b/recipes-kernel/mocca-usb/_files/_Makefile
deleted file mode 100644
index 406b1871..00000000
--- a/recipes-kernel/mocca-usb/_files/_Makefile
+++ /dev/null
@@ -1,42 +0,0 @@
-# set your module name here
-# provide the following files
-#
-# MODULENAME.c the driver
-# MODULENAME.h the include file
-# MODULENAME_test.c the driver test program
-# MODULENAME_test.sh the driver test script
-#
-MODULENAME := mocca-usb
-### should not need to change stuff below ######################
-
-
-# KDIR := /lib/modules/$(shell uname -r)/build
-#KDIR := /home/me/arm/linux-2.6.35.9/
-PWD := $(shell pwd)
-CC := ${CROSS_COMPILE}gcc -Wall
-
-ifeq ($(KERNELRELEASE),)
-all:
- $(MAKE) V=0 -C $(KDIR) SUBDIRS=$(PWD) modules
-else
- obj-m := $(MODULENAME).o
-endif
-
-
-load: all
- ssh root@10.0.0.3 'echo 0x46 > /sys/bus/i2c/devices/i2c-0/delete_device; rmmod /home/matrix/$(MODULENAME).ko'
- scp $(MODULENAME).ko root@10.0.0.3:/home/matrix
- ssh root@10.0.0.3 'insmod /home/matrix/$(MODULENAME).ko; echo k2l-i2c-0 0x46 > /sys/bus/i2c/devices/i2c-0/new_device'
-
-unload:
- ssh root@10.0.0.3 'echo 0x46 > /sys/bus/i2c/devices/i2c-0/delete_device; rmmod /home/matrix/$(MODULENAME).ko'
-
-test: all
-
-clean:
- -rm -f *.o *.ko modules.order Module.symvers *.mod.c .*.cmd $(MODULENAME)_test
- -rm -rf .tmp_versions
-
-copy:
- scp $(MODULENAME).ko root@10.0.0.3:/home/matrix
-
diff --git a/recipes-kernel/mocca-usb/_files/mocca_usb.c b/recipes-kernel/mocca-usb/_files/mocca_usb.c
deleted file mode 100644
index 1a6793c8..00000000
--- a/recipes-kernel/mocca-usb/_files/mocca_usb.c
+++ /dev/null
@@ -1,391 +0,0 @@
-/*
- * USB Skeleton driver - 2.2
- *
- * Copyright (C) 2001-2004 Greg Kroah-Hartman (greg@kroah.com)
- *
- * This program is free software; you can redistribute it and/or
- * modify it under the terms of the GNU General Public License as
- * published by the Free Software Foundation, version 2.
- *
- * This driver is based on the 2.6.3 version of drivers/usb/usb-skeleton.c
- * but has been rewritten to be easier to read and use.
- *
- */
-
-#include <linux/kernel.h>
-#include <linux/errno.h>
-#include <linux/init.h>
-#include <linux/slab.h>
-#include <linux/module.h>
-#include <linux/kref.h>
-#include <linux/uaccess.h>
-#include <linux/usb.h>
-#include <linux/mutex.h>
-#include <linux/spinlock.h>
-
-
-/* Define these values to match your devices */
-#define USB_MOCCA_VENDOR_ID 0x184f
-#define USB_MOCCA_PRODUCT_ID_1 0x0007
-#define USB_MOCCA_PRODUCT_ID_2 0x0008
-#define USB_MOCCA_PRODUCT_ID_3 0x0009
-#define USB_MOCCA_PRODUCT_ID_4 0x0010
-#define USB_MOCCA_PRODUCT_ID_5 0x0011
-#define USB_MOCCA_PRODUCT_ID_6 0x0012
-
-/* table of devices that work with this driver */
-static const struct usb_device_id mocca_table[] = {
- { USB_DEVICE(USB_MOCCA_VENDOR_ID, USB_MOCCA_PRODUCT_ID_1) },
- { USB_DEVICE(USB_MOCCA_VENDOR_ID, USB_MOCCA_PRODUCT_ID_2) },
- { USB_DEVICE(USB_MOCCA_VENDOR_ID, USB_MOCCA_PRODUCT_ID_3) },
- { USB_DEVICE(USB_MOCCA_VENDOR_ID, USB_MOCCA_PRODUCT_ID_4) },
- { USB_DEVICE(USB_MOCCA_VENDOR_ID, USB_MOCCA_PRODUCT_ID_5) },
- { USB_DEVICE(USB_MOCCA_VENDOR_ID, USB_MOCCA_PRODUCT_ID_6) },
- { } /* Terminating entry */
-};
-MODULE_DEVICE_TABLE (usb, mocca_table);
-
-
-/* Get a minor range for your devices from the usb maintainer */
-#define USB_MOCCA_MINOR_BASE 221 /*TODO: change this minor number */
-
-/* our private defines. if this grows any larger, use your own .h file */
-#define MAX_TRANSFER ( PAGE_SIZE - 512 )
-#define WRITES_IN_FLIGHT 8
-
-/* Structure to hold all of our device specific stuff */
-struct mocca_skel {
- struct usb_device * udev; /* the usb device for this device */
- struct usb_interface * interface; /* the interface for this device */
- struct semaphore limit_sem; /* limiting the number of writes in progress */
- unsigned char * bulk_in_buffer; /* the buffer to receive data */
- size_t bulk_in_size; /* the size of the receive buffer */
- __u8 bulk_in_endpointAddr; /* the address of the bulk in endpoint */
- __u8 bulk_out_endpointAddr; /* the address of the bulk out endpoint */
- struct kref kref;
-};
-#define to_mocca_dev(d) container_of(d, struct mocca_skel, kref)
-
-static struct usb_driver mocca_driver;
-static spinlock_t spinLock;
-
-static void mocca_delete(struct kref *kref)
-{
- struct mocca_skel *dev = to_mocca_dev(kref);
-
- usb_put_dev(dev->udev);
- kfree (dev->bulk_in_buffer);
- kfree (dev);
-}
-
-static int mocca_open(struct inode *inode, struct file *file)
-{
- struct mocca_skel *dev;
- struct usb_interface *interface;
- int subminor;
- int retval = 0;
-
- subminor = iminor(inode);
-
- interface = usb_find_interface(&mocca_driver, subminor);
- if (!interface) {
- printk(KERN_ERR "%s - error, can't find device for minor %d",
- __FUNCTION__, subminor);
- retval = -ENODEV;
- goto exit;
- }
-
- dev = usb_get_intfdata(interface);
- if (!dev) {
- retval = -ENODEV;
- goto exit;
- }
-
- /* increment our usage count for the device */
- kref_get(&dev->kref);
-
- /* save our object in the file's private structure */
- file->private_data = dev;
-
-exit:
- return retval;
-}
-
-static int mocca_release(struct inode *inode, struct file *file)
-{
- struct mocca_skel *dev;
-
- dev = (struct mocca_skel *)file->private_data;
- if (dev == NULL)
- return -ENODEV;
-
- /* decrement the count on our device */
- kref_put(&dev->kref, mocca_delete);
- return 0;
-}
-
-static ssize_t mocca_read(struct file *file, char *buffer, size_t count, loff_t *ppos)
-{
- struct mocca_skel *dev;
- int retval = 0;
- int bytes_read;
-
- dev = (struct mocca_skel *)file->private_data;
-
- /* do a blocking bulk read to get data from the device */
- retval = usb_bulk_msg(dev->udev,
- usb_rcvbulkpipe(dev->udev, dev->bulk_in_endpointAddr),
- dev->bulk_in_buffer,
- min(dev->bulk_in_size, count),
- &bytes_read, 10000);
-
- /* if the read was successful, copy the data to userspace */
- if (!retval) {
- if (copy_to_user(buffer, dev->bulk_in_buffer, bytes_read))
- retval = -EFAULT;
- else
- retval = bytes_read;
- }
-
- return retval;
-}
-
-static void mocca_write_bulk_callback(struct urb *urb)
-{
- struct mocca_skel *dev;
-
- dev = (struct mocca_skel *)urb->context;
-
- /* sync/async unlink faults aren't errors */
- if (urb->status &&
- !(urb->status == -ENOENT ||
- urb->status == -ECONNRESET ||
- urb->status == -ESHUTDOWN)) {
- printk(KERN_ERR "%s - nonzero write bulk status received: %d",
- __FUNCTION__, urb->status);
- }
-
- /* free up our allocated buffer */
- usb_free_coherent(urb->dev, urb->transfer_buffer_length,
- urb->transfer_buffer, urb->transfer_dma);
- up(&dev->limit_sem);
-}
-
-static ssize_t mocca_write(struct file *file, const char *user_buffer, size_t count, loff_t *ppos)
-{
- struct mocca_skel *dev;
- int retval = 0;
- struct urb *urb = NULL;
- char *buf = NULL;
- size_t writesize = min(count, (size_t)MAX_TRANSFER);
-
- dev = (struct mocca_skel *)file->private_data;
-
- /* verify that we actually have some data to write */
- if (count == 0)
- goto exit;
-
- /* limit the number of URBs in flight to stop a user from using up all RAM */
- if (down_interruptible(&dev->limit_sem)) {
- retval = -ERESTARTSYS;
- goto exit;
- }
-
- /* create a urb, and a buffer for it, and copy the data to the urb */
- urb = usb_alloc_urb(0, GFP_KERNEL);
- if (!urb) {
- retval = -ENOMEM;
- goto error;
- }
-
- buf = usb_alloc_coherent(dev->udev, writesize, GFP_KERNEL, &urb->transfer_dma);
- if (!buf) {
- retval = -ENOMEM;
- goto error;
- }
-
- if (copy_from_user(buf, user_buffer, writesize)) {
- retval = -EFAULT;
- goto error;
- }
-
- /* initialize the urb properly */
- usb_fill_bulk_urb(urb, dev->udev,
- usb_sndbulkpipe(dev->udev, dev->bulk_out_endpointAddr),
- buf, writesize, mocca_write_bulk_callback, dev);
- urb->transfer_flags |= URB_NO_TRANSFER_DMA_MAP;
-
- /* send the data out the bulk port */
- retval = usb_submit_urb(urb, GFP_KERNEL);
- if (retval) {
- printk(KERN_ERR "%s - failed submitting write urb, error %d", __FUNCTION__, retval);
- goto error;
- }
-
- /* release our reference to this urb, the USB core will eventually free it entirely */
- usb_free_urb(urb);
-
-exit:
- return writesize;
-
-error:
- usb_free_coherent(dev->udev, writesize, buf, urb->transfer_dma);
- usb_free_urb(urb);
- up(&dev->limit_sem);
- return retval;
-}
-
-static struct file_operations mocca_fops = {
- .owner = THIS_MODULE,
- .read = mocca_read,
- .write = mocca_write,
- .open = mocca_open,
- .release = mocca_release,
-};
-
-/*
- * usb class driver info in order to get a minor number from the usb core,
- * and to have the device registered with the driver core
- */
-static struct usb_class_driver mocca_class = {
- .name = "mocca%d",
- .fops = &mocca_fops,
- .minor_base = USB_MOCCA_MINOR_BASE,
-};
-
-static int mocca_probe(struct usb_interface *interface, const struct usb_device_id *id)
-{
- struct mocca_skel *dev = NULL;
- struct usb_host_interface *iface_desc;
- struct usb_endpoint_descriptor *endpoint;
- size_t buffer_size;
- int i;
- int retval = -ENOMEM;
-
- spin_lock_init(&spinLock);
-
- /* allocate memory for our device state and initialize it */
- dev = kzalloc(sizeof(*dev), GFP_KERNEL);
- if (dev == NULL) {
- printk(KERN_ERR "Out of memory");
- goto error;
- }
- kref_init(&dev->kref);
- sema_init(&dev->limit_sem, WRITES_IN_FLIGHT);
-
- dev->udev = usb_get_dev(interface_to_usbdev(interface));
- dev->interface = interface;
-
- /* set up the endpoint information */
- /* use only the first bulk-in and bulk-out endpoints */
- iface_desc = interface->cur_altsetting;
- for (i = 0; i < iface_desc->desc.bNumEndpoints; ++i) {
- endpoint = &iface_desc->endpoint[i].desc;
-
- if (!dev->bulk_in_endpointAddr &&
- ((endpoint->bEndpointAddress & USB_ENDPOINT_DIR_MASK)
- == USB_DIR_IN) &&
- ((endpoint->bmAttributes & USB_ENDPOINT_XFERTYPE_MASK)
- == USB_ENDPOINT_XFER_BULK)) {
- /* we found a bulk in endpoint */
- buffer_size = le16_to_cpu(endpoint->wMaxPacketSize);
- dev->bulk_in_size = buffer_size;
- dev->bulk_in_endpointAddr = endpoint->bEndpointAddress;
- dev->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL);
- if (!dev->bulk_in_buffer) {
- printk(KERN_ERR "Could not allocate bulk_in_buffer");
- goto error;
- }
- printk(KERN_INFO "Found bulk-in pipe, adress: %x, max packet size: %d", endpoint->bEndpointAddress, endpoint->wMaxPacketSize);
- }
-
- if (!dev->bulk_out_endpointAddr &&
- ((endpoint->bEndpointAddress & USB_ENDPOINT_DIR_MASK)
- == USB_DIR_OUT) &&
- ((endpoint->bmAttributes & USB_ENDPOINT_XFERTYPE_MASK)
- == USB_ENDPOINT_XFER_BULK)) {
- /* we found a bulk out endpoint */
- dev->bulk_out_endpointAddr = endpoint->bEndpointAddress;
- printk(KERN_INFO "Found bulk-out pipe, adress: %x, max packet size: %d", endpoint->bEndpointAddress, endpoint->wMaxPacketSize);
- }
- }
- if (!(dev->bulk_in_endpointAddr && dev->bulk_out_endpointAddr)) {
- printk(KERN_ERR "Could not find both bulk-in and bulk-out endpoints");
- goto error;
- }
-
- /* save our data pointer in this interface device */
- usb_set_intfdata(interface, dev);
-
- /* we can register the device now, as it is ready */
- retval = usb_register_dev(interface, &mocca_class);
- if (retval) {
- /* something prevented us from registering this driver */
- printk(KERN_ERR "Not able to get a minor for this device.");
- usb_set_intfdata(interface, NULL);
- goto error;
- }
-
- /* let the user know what node this device is now attached to */
- dev_info(&interface->dev,
- "K2L MOCCA device now attached to mocca%d",
- interface->minor);
- return 0;
-
-error:
- if (dev)
- kref_put(&dev->kref, mocca_delete);
- return retval;
-}
-
-static void mocca_disconnect(struct usb_interface *interface)
-{
- struct mocca_skel *dev;
- int minor = interface->minor;
-
- /* prevent mocca_open() from racing mocca_disconnect() */
- spin_lock(&spinLock);
-
- dev = usb_get_intfdata(interface);
- usb_set_intfdata(interface, NULL);
-
- /* give back our minor */
- usb_deregister_dev(interface, &mocca_class);
-
- spin_unlock(&spinLock);
-
- /* decrement our usage count */
- kref_put(&dev->kref, mocca_delete);
-
- dev_info(&interface->dev, "K2L MOCCA device #%d now disconnected", minor);
-}
-
-static struct usb_driver mocca_driver = {
- .name = "k2l-mocca",
- .probe = mocca_probe,
- .disconnect = mocca_disconnect,
- .id_table = mocca_table,
-};
-
-static int __init usb_mocca_init(void)
-{
- int result;
-
- /* register this driver with the USB subsystem */
- result = usb_register(&mocca_driver);
- if (result)
- printk(KERN_ERR "usb_register failed. Error number %d", result);
-
- return result;
-}
-
-static void __exit usb_mocca_exit(void)
-{
- /* deregister this driver with the USB subsystem */
- usb_deregister(&mocca_driver);
-}
-
-module_init (usb_mocca_init);
-module_exit (usb_mocca_exit);
-
-MODULE_LICENSE("GPL");
diff --git a/recipes-kernel/mocca-usb/mocca-usb.bb b/recipes-kernel/mocca-usb/mocca-usb.bb
index 034585f1..59bcf7a6 100644
--- a/recipes-kernel/mocca-usb/mocca-usb.bb
+++ b/recipes-kernel/mocca-usb/mocca-usb.bb
@@ -20,3 +20,6 @@ do_install_append () {
echo "mocca_usb" > ${D}${sysconfdir}/modules-load.d/mocca_usb.conf
fi
}
+
+# These sources are currently for the porter kernel only
+COMPATIBLE_MACHINE = "porter"
diff --git a/recipes-kernel/mostcore/mostcore.bb b/recipes-kernel/mostcore/mostcore.bb
index f170c58d..368b85a4 100644
--- a/recipes-kernel/mostcore/mostcore.bb
+++ b/recipes-kernel/mostcore/mostcore.bb
@@ -24,3 +24,6 @@ do_install_append () {
echo "mostcore" > ${D}${sysconfdir}/modules-load.d/mostcore.conf
fi
}
+
+# These sources are currently for the porter kernel only
+COMPATIBLE_MACHINE = "porter"
diff --git a/recipes-platform/images/agl-demo-platform.bb b/recipes-platform/images/agl-demo-platform.bb
index c58d22cf..a3878790 100644
--- a/recipes-platform/images/agl-demo-platform.bb
+++ b/recipes-platform/images/agl-demo-platform.bb
@@ -24,6 +24,41 @@ IMAGE_TTF_FONTS = " \
"
# add packages for CES2017 demo
+# Only for porter as these kernel module sources
+# are for the 3.10.x kernel only
+MOST_DRIVERS = " "
+MOST_DRIVERS_append_porter = " \
+ aim-cdev \
+ aim-network \
+ aim-sound \
+ aim-v4l2 \
+ hdm-dim2 \
+ hdm-i2c \
+ hdm-usb \
+ mocca-usb \
+ mostcore \
+ "
+
+# HVAC dependencies depend on drivers above
+IMAGE_MOST_HVAC = " "
+IMAGE_MOST_HVAC_append_porter = " \
+ ${MOST_DRIVERS} \
+ unicens \
+ vod-server \
+ "
+
+# can-lin is a binary and only for porter :(
+IMAGE_MOST_HVAC_append_porter = " \
+ can-lin \
+ "
+
+IMAGE_AGL_APPS = " \
+ hvac \
+ mediaplayer \
+ navigation \
+ settings \
+ "
+
IMAGE_INSTALL_append = " \
ces2017-demo \
linux-firmware-ath9k \
@@ -35,5 +70,7 @@ IMAGE_INSTALL_append = " \
climatecontrolplugin \
navigation \
poiapp \
+ ${IMAGE_MOST_HVAC} \
+ ${IMAGE_AGL_APPS} \
${IMAGE_TTF_FONTS} \
"