summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2016-12-21 19:39:01 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-12-22 15:31:44 +0000
commit9cd95faf6e886fdf10823f13fe3d38616fd0d566 (patch)
treec2da17985252f0763beac0efc74fc9389f61e126
parentaf4a22aeda5e5dfede3dd3f1a65165ccb5632ce0 (diff)
Remove redundancy from recipe CES2017-demo
Because some apps(mediaplayer, hvac, and setting) sperated from AGL/DemoApps/CES2017, CES2017-demo.bb being redundant. v2 (jsmoeller): add 2 dependencies back Change-Id: Iacf9a8d3f841888d2d12defe9930898beac4abfa Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com> Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rw-r--r--recipes-demo-hmi/CES2017-demo/CES2017-demo.bb54
1 files changed, 1 insertions, 53 deletions
diff --git a/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb b/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
index b72510ca..276a2273 100644
--- a/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
+++ b/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
@@ -8,7 +8,7 @@ S = "${WORKDIR}/git/"
PN = "ces2017-demo"
inherit qmake5
-DEPENDS = " qtbase qtdeclarative qtquickcontrols2 qtvirtualkeyboard qtmultimedia homescreen zip-native"
+DEPENDS = "homescreen zip-native qtmultimedia qtquickcontrols2"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad"
@@ -58,38 +58,6 @@ do_install_prepend() {
echo "<?xml version=\"1.0\" encoding=\"UTF-8\"?> \
-<widget xmlns=\"http://www.w3.org/ns/widgets\" id=\"hvac\" version=\"0.1\"> \
- <name>HVAC</name> \
- <content src=\"hvac\" type=\"application/x-executable\"/> \
- <description>HVAC app.</description> \
- <author>Qt</author> \
- <icon src=\"hvac.png\"/> \
- <license>Apache 2.0</license> \
-</widget> \
-" > ${B}/apps/HVAC/config.xml
-
- cd ${B}/apps/HVAC/
- zip hvac.wgt config.xml hvac
-
-
-
- echo "<?xml version=\"1.0\" encoding=\"UTF-8\"?> \
-<widget xmlns=\"http://www.w3.org/ns/widgets\" id=\"mediaplayer\" version=\"0.1\"> \
- <name>MediaPlayer</name> \
- <content src=\"mediaplayer\" type=\"application/x-executable\"/> \
- <description>MediaPlayer app.</description> \
- <author>Qt</author> \
- <icon src=\"mediaplayer.png\"/> \
- <license>Apache 2.0</license> \
-</widget> \
-" > ${B}/apps/MediaPlayer/config.xml
-
- cd ${B}/apps/MediaPlayer/
- zip mediaplayer.wgt config.xml mediaplayer
-
-
-
- echo "<?xml version=\"1.0\" encoding=\"UTF-8\"?> \
<widget xmlns=\"http://www.w3.org/ns/widgets\" id=\"phone\" version=\"0.1\"> \
<name>Phone</name> \
<content src=\"phone\" type=\"application/x-executable\"/> \
@@ -121,27 +89,10 @@ do_install_prepend() {
- echo "<?xml version=\"1.0\" encoding=\"UTF-8\"?> \
-<widget xmlns=\"http://www.w3.org/ns/widgets\" id=\"settings\" version=\"0.1\"> \
- <name>Settings</name> \
- <content src=\"settings\" type=\"application/x-executable\"/> \
- <description>Settings app.</description> \
- <author>Qt</author> \
- <icon src=\"settings.png\"/> \
- <license>Apache 2.0</license> \
-</widget> \
-" > ${B}/apps/Settings/config.xml
-
- cd ${B}/apps/Settings/
- zip settings.wgt config.xml settings
-
-
cat > ${B}/apps/installAllApps.sh <<-EOF
#!/bin/sh
/usr/bin/afm-util install controls.wgt
/usr/bin/afm-util install dashboard.wgt
- /usr/bin/afm-util install hvac.wgt
- /usr/bin/afm-util install mediaplayer.wgt
/usr/bin/afm-util install phone.wgt
/usr/bin/afm-util install radio.wgt
/usr/bin/afm-util install settings.wgt
@@ -153,11 +104,8 @@ do_install() {
install -d ${D}/usr/AGL/${PN}
install -m 0644 ${B}/apps/Controls/controls.wgt ${D}/usr/AGL/${PN}/
install -m 0644 ${B}/apps/Dashboard/dashboard.wgt ${D}/usr/AGL/${PN}/
- install -m 0644 ${B}/apps/HVAC/hvac.wgt ${D}/usr/AGL/${PN}/
- install -m 0644 ${B}/apps/MediaPlayer/mediaplayer.wgt ${D}/usr/AGL/${PN}/
install -m 0644 ${B}/apps/Phone/phone.wgt ${D}/usr/AGL/${PN}/
install -m 0644 ${B}/apps/Radio/radio.wgt ${D}/usr/AGL/${PN}/
- install -m 0644 ${B}/apps/Settings/settings.wgt ${D}/usr/AGL/${PN}/
install -m 0755 ${B}/apps/installAllApps.sh ${D}/usr/AGL/${PN}/