summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2017-03-01 11:05:33 -0500
committerScott Murray <scott.murray@konsulko.com>2017-03-01 11:05:33 -0500
commit9d13096870330ac11d915893c113d9e25989153c (patch)
treef668477f19cb9b0cef3d81d9f0cb249ef5a81a9e
parent5f52a2cf2a739ab14c74d54f383e527a2c3676b9 (diff)
Switch to split out demo apps
Add recipes for the split out controls, dashboard, phone, and radio app repositories, remove the related packaging of same from the CES2017-demo recipe, and add the split out apps to IMAGE_AGL_APPS in the agl-demo-platform image definition. Bug-AGL: SPEC-400, SPEC-401, SPEC-402, SPEC-403, SPEC-404 Change-Id: I790eee4edf97ab9c32ddfe5fe277cb7f05012ffc Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--recipes-demo-hmi/CES2017-demo/CES2017-demo.bb128
-rw-r--r--recipes-demo-hmi/controls/controls_git.bb22
-rw-r--r--recipes-demo-hmi/dashboard/dashboard_git.bb22
-rw-r--r--recipes-demo-hmi/phone/phone_git.bb22
-rw-r--r--recipes-demo-hmi/radio/files/presets-ALS.conf (renamed from recipes-demo-hmi/CES2017-demo/files/presets-ALS.conf)0
-rw-r--r--recipes-demo-hmi/radio/files/presets-CES.conf (renamed from recipes-demo-hmi/CES2017-demo/files/presets-CES.conf)0
-rw-r--r--recipes-demo-hmi/radio/files/presets-FOSDEM.conf (renamed from recipes-demo-hmi/CES2017-demo/files/presets-FOSDEM.conf)0
-rw-r--r--recipes-demo-hmi/radio/radio_git.bb48
-rw-r--r--recipes-platform/images/agl-demo-platform.bb7
9 files changed, 138 insertions, 111 deletions
diff --git a/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb b/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
index 7d64f83e..7f902ba8 100644
--- a/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
+++ b/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
@@ -1,116 +1,27 @@
SUMMARY = "App Launcher for the AGL Demonstrator @ CES2017"
DESCRIPTION = "App Lanucher app in QML format for the AGL Demonstrator @ CESS2017"
HOMEPAGE = "https://git.automotivelinux.org/gerrit/#/admin/projects/AGL/DemoApps/CES2017"
-LICENSE = "MPL-2.0"
SECTION = "apps"
-PV = "1.0+git${SRCPV}"
-S = "${WORKDIR}/git/"
-PN = "ces2017-demo"
-
-inherit qmake5
-DEPENDS = "homescreen zip-native qtmultimedia qtquickcontrols2"
-
-inherit aglwgt
-
+LICENSE = "MPL-2.0"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad"
-# ALS, CES, FOSDEM available
-AGL_RADIO_PRESETS_LOCALE ?= "CES"
+DEPENDS = "homescreen zip-native qtquickcontrols2"
+
+PV = "1.0+git${SRCPV}"
+PN = "ces2017-demo"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/AGL/DemoApps/CES2017;protocol=http \
- file://presets-ALS.conf \
- file://presets-CES.conf \
- file://presets-FOSDEM.conf \
- "
-SRCREV = "${AUTOREV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/AGL/DemoApps/CES2017;protocol=http"
+SRCREV = "${AUTOREV}"
# Pinned branch/SRCREV for Charming Chinook
-SRC_URI_chinook = "git://gerrit.automotivelinux.org/gerrit/AGL/DemoApps/CES2017;protocol=http;branch=chinook \
- file://presets-ALS.conf \
- file://presets-CES.conf \
- file://presets-FOSDEM.conf \
- "
+SRC_URI_chinook = "git://gerrit.automotivelinux.org/gerrit/AGL/DemoApps/CES2017;protocol=http;branch=chinook"
SRCREV_chinook = "354195c83841240ddd5f2c5daad97d66cc9e1d28"
-RDEPENDS_${PN} += " \
- qtmultimedia-qmlplugins \
- qtmultimedia-rtlfm-radio-plugin \
- qtquickcontrols-qmlplugins \
- qtquickcontrols2-qmlplugins \
- qtsvg-plugins \
- "
-
-do_install_prepend() {
- mkdir -p ${B}/package
-
- echo "<?xml version=\"1.0\" encoding=\"UTF-8\"?> \
-<widget xmlns=\"http://www.w3.org/ns/widgets\" id=\"controls\" version=\"0.1\"> \
- <name>Controls</name> \
- <content src=\"controls\" type=\"application/x-executable\"/> \
- <description>Controls app.</description> \
- <author>Qt</author> \
- <icon src=\"controls.png\"/> \
- <license>Apache 2.0</license> \
-</widget> \
-" > ${B}/apps/Controls/config.xml
-
- cd ${B}/apps/Controls/
- zip ${B}/package/controls.wgt config.xml controls
-
- echo "<?xml version=\"1.0\" encoding=\"UTF-8\"?> \
-<widget xmlns=\"http://www.w3.org/ns/widgets\" id=\"dashboard\" version=\"0.1\"> \
- <name>Dashboard</name> \
- <content src=\"dashboard\" type=\"application/x-executable\"/> \
- <description>Dashboard app.</description> \
- <author>Qt</author> \
- <icon src=\"dashboard.png\"/> \
- <license>Apache 2.0</license> \
-</widget> \
-" > ${B}/apps/Dashboard/config.xml
-
- cd ${B}/apps/Dashboard/
- zip ${B}/package/dashboard.wgt config.xml dashboard
+S = "${WORKDIR}/git/"
-
- echo "<?xml version=\"1.0\" encoding=\"UTF-8\"?> \
-<widget xmlns=\"http://www.w3.org/ns/widgets\" id=\"phone\" version=\"0.1\"> \
- <name>Phone</name> \
- <content src=\"phone\" type=\"application/x-executable\"/> \
- <description>Phone app.</description> \
- <author>Qt</author> \
- <icon src=\"phone.png\"/> \
- <license>Apache 2.0</license> \
-</widget> \
-" > ${B}/apps/Phone/config.xml
-
- cd ${B}/apps/Phone/
- zip ${B}/package/phone.wgt config.xml phone
-
-
-
- echo "<?xml version=\"1.0\" encoding=\"UTF-8\"?> \
-<widget xmlns=\"http://www.w3.org/ns/widgets\" id=\"radio\" version=\"0.1\"> \
- <name>Radio</name> \
- <content src=\"radio\" type=\"application/x-executable\"/> \
- <description>Radio app.</description> \
- <author>Qt</author> \
- <icon src=\"radio.png\"/> \
- <license>Apache 2.0</license> \
-</widget> \
-" > ${B}/apps/Radio/config.xml
-
- cd ${B}/apps/Radio/
- zip ${B}/package/radio.wgt config.xml radio
-
-}
+inherit qmake5
do_install() {
- install -d ${D}/home/root/app-data/radio
- install -m 0644 ${WORKDIR}/presets-CES.conf ${D}/home/root/app-data/radio/
- install -m 0644 ${WORKDIR}/presets-ALS.conf ${D}/home/root/app-data/radio/
- install -m 0644 ${WORKDIR}/presets-FOSDEM.conf ${D}/home/root/app-data/radio/
- install -m 0644 ${WORKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}/home/root/app-data/radio/presets.conf
-
install -d ${D}${libdir}/qt5/qml/AGL/Demo/Controls/
install -m 0644 ${S}/imports/AGL/Demo/Controls/qmldir ${D}${libdir}/qt5/qml/AGL/Demo/Controls/
install -m 0644 ${S}/imports/AGL/Demo/Controls/ImageButton.qml ${D}${libdir}/qt5/qml/AGL/Demo/Controls/
@@ -133,15 +44,8 @@ do_install() {
install -m 0644 ${S}/imports/qtquickcontrols2aglstyle/images/* ${D}${libdir}/qt5/qml/QtQuick/Controls.2/AGL/images/
}
-# plain copy in own folder for now
-#do_install() {
-# mkdir -p ${D}/usr/AGL/CES2017/
-# cp -rf ./* ${D}/usr/AGL/CES2017/
-#}
-
-FILES_${PN} += "/usr/AGL/ \
- /home/root/app-data/radio/presets-*.conf \
- /home/root/app-data/radio/presets.conf \
+FILES_${PN} += " \
+ /usr/AGL/ \
/usr/lib/qt5/qml/AGL/Demo/Controls/qmldir \
/usr/lib/qt5/qml/AGL/Demo/Controls/ImageButton.qml \
/usr/lib/qt5/qml/AGL/Demo/Controls/ToggleButton.qml \
@@ -156,4 +60,10 @@ FILES_${PN} += "/usr/AGL/ \
/usr/lib/qt5/qml/AGL/Demo/Controls/images/Keyboard_Arrow.svg \
/usr/lib/qt5/qml/QtQuick/Controls.2/AGL \
/usr/lib/qt5/qml/QtQuick/Controls.2/AGL/images \
- "
+"
+
+RDEPENDS_${PN} += " \
+ qtquickcontrols-qmlplugins \
+ qtquickcontrols2-qmlplugins \
+ qtsvg-plugins \
+"
diff --git a/recipes-demo-hmi/controls/controls_git.bb b/recipes-demo-hmi/controls/controls_git.bb
new file mode 100644
index 00000000..4c95ffc7
--- /dev/null
+++ b/recipes-demo-hmi/controls/controls_git.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Controls for CES2017 AGL Demonstration"
+DESCRIPTION = "AGL HMI Application for demonstrating UI components on AGL Distribution"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/controls"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/controls;protocol=http"
+SRCREV = "${AUTOREV}"
+
+# Pinned branch/SRCREV for Charming Chinook
+SRC_URI_chinook = "git://gerrit.automotivelinux.org/gerrit/apps/controls;protocol=http;branch=chinook"
+SRCREV_chinook = "f6e78f4b47f2bdc3e618c30deb4e4d11f71d30a0"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS += "qtquickcontrols2"
+
+inherit qmake5 aglwgt
diff --git a/recipes-demo-hmi/dashboard/dashboard_git.bb b/recipes-demo-hmi/dashboard/dashboard_git.bb
new file mode 100644
index 00000000..ca5ac29f
--- /dev/null
+++ b/recipes-demo-hmi/dashboard/dashboard_git.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Dashboard for CES2017 AGL Demonstration"
+DESCRIPTION = "AGL HMI Application for demonstrating dashboard on AGL Distribution"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/dashboard"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/dashboard;protocol=http"
+SRCREV = "${AUTOREV}"
+
+# Pinned branch/SRCREV for Charming Chinook
+SRC_URI_chinook = "git://gerrit.automotivelinux.org/gerrit/apps/dashboard;protocol=http;branch=chinook"
+SRCREV_chinook = "1d7a6c0175c20d06cf4315d994685e593e41b9a0"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS += "qtquickcontrols2"
+
+inherit qmake5 aglwgt
diff --git a/recipes-demo-hmi/phone/phone_git.bb b/recipes-demo-hmi/phone/phone_git.bb
new file mode 100644
index 00000000..bff08434
--- /dev/null
+++ b/recipes-demo-hmi/phone/phone_git.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Phone for CES2017 AGL Demonstration"
+DESCRIPTION = "AGL HMI Application for demonstrating phone on AGL Distribution"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/phone"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/phone;protocol=http"
+SRCREV = "${AUTOREV}"
+
+# Pinned branch/SRCREV for Charming Chinook
+SRC_URI_chinook = "git://gerrit.automotivelinux.org/gerrit/apps/phone;protocol=http;branch=chinook"
+SRCREV_chinook = "a87aaf9b9d8c3eeae0e9006e4c73d17d03a55b93"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS += "qtquickcontrols2"
+
+inherit qmake5 aglwgt
diff --git a/recipes-demo-hmi/CES2017-demo/files/presets-ALS.conf b/recipes-demo-hmi/radio/files/presets-ALS.conf
index ff559227..ff559227 100644
--- a/recipes-demo-hmi/CES2017-demo/files/presets-ALS.conf
+++ b/recipes-demo-hmi/radio/files/presets-ALS.conf
diff --git a/recipes-demo-hmi/CES2017-demo/files/presets-CES.conf b/recipes-demo-hmi/radio/files/presets-CES.conf
index 83caeffe..83caeffe 100644
--- a/recipes-demo-hmi/CES2017-demo/files/presets-CES.conf
+++ b/recipes-demo-hmi/radio/files/presets-CES.conf
diff --git a/recipes-demo-hmi/CES2017-demo/files/presets-FOSDEM.conf b/recipes-demo-hmi/radio/files/presets-FOSDEM.conf
index b88364f7..b88364f7 100644
--- a/recipes-demo-hmi/CES2017-demo/files/presets-FOSDEM.conf
+++ b/recipes-demo-hmi/radio/files/presets-FOSDEM.conf
diff --git a/recipes-demo-hmi/radio/radio_git.bb b/recipes-demo-hmi/radio/radio_git.bb
new file mode 100644
index 00000000..d48ba692
--- /dev/null
+++ b/recipes-demo-hmi/radio/radio_git.bb
@@ -0,0 +1,48 @@
+SUMMARY = "Radio for CES2017 AGL Demonstration"
+DESCRIPTION = "AGL HMI Application for demonstrating Radio on AGL Distribution"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/radio"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI_BRANCH = "master"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/radio;protocol=http;branch=${SRC_URI_BRANCH} \
+ file://presets-ALS.conf \
+ file://presets-CES.conf \
+ file://presets-FOSDEM.conf \
+"
+SRCREV = "${AUTOREV}"
+
+# Pinned branch/SRCREV for Charming Chinook
+SRC_URI_BRANCH_chinook = "chinook"
+SRCREV_chinook = "4dd6163184a243f80d6324c61d674383e88e9ba5"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS += "qtquickcontrols2 qtmultimedia"
+
+inherit qmake5 aglwgt
+
+# ALS, CES, FOSDEM available
+AGL_RADIO_PRESETS_LOCALE ?= "CES"
+
+do_install_append() {
+ install -d ${D}/home/root/app-data/radio
+ install -m 0644 ${WORKDIR}/presets-CES.conf ${D}/home/root/app-data/radio/
+ install -m 0644 ${WORKDIR}/presets-ALS.conf ${D}/home/root/app-data/radio/
+ install -m 0644 ${WORKDIR}/presets-FOSDEM.conf ${D}/home/root/app-data/radio/
+ install -m 0644 ${WORKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}/home/root/app-data/radio/presets.conf
+}
+
+FILES_${PN} += " \
+ /home/root/app-data/radio/presets-*.conf \
+ /home/root/app-data/radio/presets.conf \
+"
+
+RDEPENDS_${PN} += " \
+ qtmultimedia-qmlplugins \
+ qtmultimedia-rtlfm-radio-plugin \
+"
diff --git a/recipes-platform/images/agl-demo-platform.bb b/recipes-platform/images/agl-demo-platform.bb
index ff64f136..d1381218 100644
--- a/recipes-platform/images/agl-demo-platform.bb
+++ b/recipes-platform/images/agl-demo-platform.bb
@@ -60,10 +60,15 @@ IMAGE_MAPVIEWER_append_porter = " \
"
IMAGE_AGL_APPS = " \
+ controls \
+ dashboard \
hvac \
mediaplayer \
mixer \
navigation \
+ poiapp \
+ phone \
+ radio \
settings \
"
@@ -75,8 +80,6 @@ IMAGE_INSTALL_append = " \
iproute2 \
python-curses \
dhcp-client \
- navigation \
- poiapp \
${IMAGE_MAPVIEWER} \
${IMAGE_MOST_HVAC} \
${IMAGE_AGL_APPS} \