summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2016-12-21 22:25:15 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-12-21 15:24:13 +0000
commita56ca4d7070289e09b27d944d4b63834da434262 (patch)
treed2051af7b29083e84cdbf0abdfa60b4aa9e94636
parent748f48cbe6914c9eb48832ab8bd504bbccc418a3 (diff)
FIx build dependency of apps
There were missing build dependencies to qtquickcontrols2 and af-binder in apps' recipe. Change-Id: I497225b2a171d4cc19cb3224164af42a59bbcb69 Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
-rw-r--r--recipes-demo-hmi/hvac/hvac_git.bb5
-rw-r--r--recipes-demo-hmi/mediaplayer/mediaplayer_git.bb3
-rw-r--r--recipes-demo-hmi/settings/settings_git.bb5
3 files changed, 10 insertions, 3 deletions
diff --git a/recipes-demo-hmi/hvac/hvac_git.bb b/recipes-demo-hmi/hvac/hvac_git.bb
index f5d45379..4b3e2897 100644
--- a/recipes-demo-hmi/hvac/hvac_git.bb
+++ b/recipes-demo-hmi/hvac/hvac_git.bb
@@ -9,8 +9,11 @@ S = "${WORKDIR}/git"
inherit qmake5
+DEPENDS += "qtquickcontrols2"
# 'wgtpkg-pack' in af-main-native is required.
-DEPENDS = "af-main-native"
+DEPENDS += "af-main-native"
+# hvac has binding, so af-binder is required.
+DEPENDS += "af-binder"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
diff --git a/recipes-demo-hmi/mediaplayer/mediaplayer_git.bb b/recipes-demo-hmi/mediaplayer/mediaplayer_git.bb
index c551e693..9ad11fb7 100644
--- a/recipes-demo-hmi/mediaplayer/mediaplayer_git.bb
+++ b/recipes-demo-hmi/mediaplayer/mediaplayer_git.bb
@@ -9,8 +9,9 @@ S = "${WORKDIR}/git"
inherit qmake5
+DEPENDS += "qtquickcontrols2"
# 'wgtpkg-pack' in af-main-native is required.
-DEPENDS = "af-main-native"
+DEPENDS += "af-main-native"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
diff --git a/recipes-demo-hmi/settings/settings_git.bb b/recipes-demo-hmi/settings/settings_git.bb
index d59250be..427ea7cc 100644
--- a/recipes-demo-hmi/settings/settings_git.bb
+++ b/recipes-demo-hmi/settings/settings_git.bb
@@ -9,8 +9,11 @@ S = "${WORKDIR}/git"
inherit qmake5
+DEPENDS += "qtquickcontrols2"
# 'wgtpkg-pack' in af-main-native is required.
-DEPENDS = "af-main-native"
+DEPENDS += "af-main-native"
+# setting has binding, so af-binder is required.
+DEPENDS += "af-binder"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"