summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2016-12-19 00:18:16 +0900
committerTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2016-12-19 00:18:16 +0900
commitc6cc8e564f14a31e5125baf29ebb8550ec20b5d7 (patch)
treeac7888a3896cda2cf99889025f4b6cbfeb33d037
parente416218176328ef20ac8ff130af5bff5da51b284 (diff)
Add recipe of AGL Demo HMI (Settings)
This recipe is to deliver AGL Demo Platform for CES2017 AGL Showcase by bitbake integration. To use hmi of Settings(Date/Wifi/Bluetooth), it should be installed on the target board at least once afer booting. The package of application, settings.wgt would be installed in /usr/AGL/apps on the target board. To install it, follow these steps from the target console or remote shell. # cd /usr/AGL/apps # afm-util install settings.wgt Change-Id: Ice204d7fd002f4c25f34ae70b38607dc23d85f44 Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
-rw-r--r--recipes-demo-hmi/settings/settings_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-demo-hmi/settings/settings_git.bb b/recipes-demo-hmi/settings/settings_git.bb
new file mode 100644
index 00000000..d59250be
--- /dev/null
+++ b/recipes-demo-hmi/settings/settings_git.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Settings for CES2017 AGL Demonstration"
+DESCRIPTION = "AGL HMI Application for demonstrating Settings on AGL Distribution"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/settings"
+LICENSE = "Apache-2.0"
+SECTION = "apps"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit qmake5
+
+# 'wgtpkg-pack' in af-main-native is required.
+DEPENDS = "af-main-native"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/settings;protocol=http"
+SRCREV = "${AUTOREV}"
+
+RDEPENDS_${PN} += " \
+ qtmultimedia-qmlplugins \
+ qtquickcontrols2-qmlplugins \
+ "
+
+do_install() {
+ install -d ${D}/usr/AGL/apps
+ install -m 0644 ${B}/package/${PN}.wgt ${D}/usr/AGL/apps/
+}
+
+FILES_${PN} += "/usr/AGL/apps/ \
+ /usr/AGL/apps/${PN} \
+ "