aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>2017-08-11 01:32:13 +0900
committerNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>2017-08-11 01:32:45 +0900
commit48a0d4f881e3ce0332374683fd57acfc7a160bd4 (patch)
tree619ac163b5851043993ecaaee8bcc6b6ecafd843
parentcfd1dedb898e7aa3b43962318cd804f7cb2f6049 (diff)
navigation: fixing navigation packaging methods
With this fix, the navigation build method will be compatible with the SDK. This patch contains the workaround of the problem discussed in SPEC-384. Change-Id: I05b1b6b271892584e0a1f3b7db86f9c985cb529a Bug-AGL: SPEC-384 Signed-off-by: Naoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
-rwxr-xr-x[-rw-r--r--]recipes-demo-hmi/navigation/navigation_git.bb26
1 files changed, 2 insertions, 24 deletions
diff --git a/recipes-demo-hmi/navigation/navigation_git.bb b/recipes-demo-hmi/navigation/navigation_git.bb
index bc62ef40..33515285 100644..100755
--- a/recipes-demo-hmi/navigation/navigation_git.bb
+++ b/recipes-demo-hmi/navigation/navigation_git.bb
@@ -15,13 +15,10 @@ DEPENDS = " \
RDEPENDS_${PN} = " flite openjtalk glib-2.0 freetype sqlite3 wayland zlib expat openssl \
wayland libdbus-c++ af-main "
-SRCREV="c6403c1147fa53cd6a638f738d270c5d3bb214cf"
+SRCREV="acbb9ea0678bd2f21f268000332a4786e87fb3f6"
SRC_URI="git://github.com/AGLExport/gpsnavi.git;branch=agl \
- file://flite.in \
- file://jtalk.in \
file://download_mapdata_jp.sh \
file://download_mapdata_uk.sh \
- file://0001-Makefile-compatible-aglwgt.patch \
"
# To avoid C++ library link failure
@@ -32,32 +29,13 @@ inherit aglwgt
S = "${WORKDIR}/git"
-do_compile_prepend() {
- cp ${WORKDIR}/flite.in ${S}/
- cp ${WORKDIR}/jtalk.in ${S}/
-}
-
do_install_append() {
- # Attention: BUG: app ships native lib as part of platform
- # see SPEC-785 and SPEC-384
- # /start FIXME __________________
- cd ${B}
- oe_runmake 'DESTDIR=${D}' install
- rm ${D}/usr/bin/navi
- # /end FIXME ^^^^^^^^^^^^^^^^^^^
-
+# mapdata install scripts
install -d ${D}/usr/AGL/apps
- mkdir -p ${B}/package/
- mv ${B}/navigation.wgt ${B}/package/
install -m 0755 ${WORKDIR}/download_mapdata_jp.sh ${D}/usr/AGL/apps/
install -m 0755 ${WORKDIR}/download_mapdata_uk.sh ${D}/usr/AGL/apps/
install -d ${D}/var/mapdata
}
-#it's Workaround
-EXTRA_WGT_POSTINSTALL = "\
- cyad -s -k MANIFESTS -t allow -c User::App::navigation -u '*' -p 'http://tizen.org/privilege/internal/dbus';\
- cyad -s -k MANIFESTS -t allow -c User::App::poi -u '*' -p 'http://tizen.org/privilege/internal/dbus';\
-"
FILES_${PN} += " /usr/AGL/apps/*.sh /var/mapdata "