aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>2017-05-16 19:21:25 +0900
committerHarunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>2017-07-06 12:46:30 +0000
commit804ff862a8592e102f93e7eebf2337e5483ba696 (patch)
tree97e6f7bea504543ab30a9716e859aca70f67ad4f
parentd51e3421345cf0d1659abf52d602734ee13bca37 (diff)
weston.ini: Add virtual display and record for CES2017 demo
In order to support IVI-Cluster demo, set virtual display and gst-recorder parameter in weston.ini. v2: If you want to use virtual output system, set "virtual-display" in DISTRO_FEATURES. Then the sample value is enabled. If you want to use transfer system to multi ECU via H.264, set "gst-record" in DISTRO_FEATURES. Note: These system are supported in R-Car M3 only. Change-Id: Ia782d3bc7079c38f30be52c1f6f152d55e1d2e17 Signed-off-by: Harunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>
-rw-r--r--recipes-graphics/wayland/weston-ini-conf.bbappend25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/weston-ini-conf.bbappend b/recipes-graphics/wayland/weston-ini-conf.bbappend
index b79c5260..635218a6 100644
--- a/recipes-graphics/wayland/weston-ini-conf.bbappend
+++ b/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -4,3 +4,28 @@ WESTONIVISHELL[ivi-module] ??= "ivi-controller.so"
WESTONIVISHELL[ivi-input-module] ??= "ivi-input-controller.so"
WESTONSECTION[WESTONIVISHELL] = "ivi-shell"
+
+# IVI cluster and virtual display sample
+python () {
+ if bb.utils.contains('DISTRO_FEATURES', 'virtual-display', True, False, d):
+ d.setVarFlag("WESTONCORE", "virtual", "1")
+}
+
+WESTONOUTPUT2[agl_screen] ??= "SCREEN_VIRTUAL"
+
+WESTONSECTION[WESTONOUTPUT2] = "output"
+
+SCREEN_VIRTUAL[name]?="virtual1"
+SCREEN_VIRTUAL[mode]?="384x368@60"
+
+# If gst-record is set, recorder flag is true
+python () {
+ if bb.utils.contains('DISTRO_FEATURES', 'gst-record', True, False, d):
+ d.setVarFlag("SCREEN_VIRTUAL", "recorder", "true")
+}
+
+SCREEN_VIRTUAL[ip]?="192.168.20.99"
+SCREEN_VIRTUAL[port]?="5005"
+SCREEN_VIRTUAL[bitrate]?="300000"
+SCREEN_VIRTUAL[crop]?="384x368@0x0"
+