aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2017-07-10 15:13:23 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-08-30 16:31:44 +0000
commit8713d50be8ad02c742d99327321e5b45ae579717 (patch)
tree3bfa7f66274475abc2879f87f6b513c5c3d7efaf
parent48a0d4f881e3ce0332374683fd57acfc7a160bd4 (diff)
Integration Low CAN demo and High Lvl ViWi.
This integration use non automatic post installation at first boot on a board. Change-Id: I0f080c72ec98b9280256de20a45aa847714bebf0 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
-rw-r--r--recipes-demo-hmi/high-level-viwi-service/high-level-viwi-service.bb19
-rw-r--r--recipes-demo-hmi/low-can-demo/low-can-demo_git.bb19
-rwxr-xr-xrecipes-platform/packagegroups/packagegroup-agl-demo-platform.bb2
3 files changed, 40 insertions, 0 deletions
diff --git a/recipes-demo-hmi/high-level-viwi-service/high-level-viwi-service.bb b/recipes-demo-hmi/high-level-viwi-service/high-level-viwi-service.bb
new file mode 100644
index 00000000..4391883e
--- /dev/null
+++ b/recipes-demo-hmi/high-level-viwi-service/high-level-viwi-service.bb
@@ -0,0 +1,19 @@
+SUMMARY = "High level ViWi service"
+DESCRIPTION = "AGL High Level service using ViWi protocol to expose CAN API."
+HOMEPAGE = "https://github.com/iotbzh/high-level-viwi-service"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5de84541278ea4e62cacfdc0f890c459"
+
+SRC_URI = "gitsm://github.com/iotbzh/high-level-viwi-service.git;protocol=https"
+SRCREV = "c4935e58769966a9b79b21c45798ab8828fe0ad0"
+
+PV = "4.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+# Run-time dependencies
+RDEPENDS_${PN} += "low-level-can-service"
+
+inherit cmake aglwgt
+
+AGLWGT_AUTOINSTALL_${PN} := "0"
diff --git a/recipes-demo-hmi/low-can-demo/low-can-demo_git.bb b/recipes-demo-hmi/low-can-demo/low-can-demo_git.bb
new file mode 100644
index 00000000..6b8f6b5b
--- /dev/null
+++ b/recipes-demo-hmi/low-can-demo/low-can-demo_git.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Low CAN demo HTTP5 UI"
+DESCRIPTION = "AGL HTTP5 UI to display car metric (speed, rpm, ...) on AGL Distribution"
+HOMEPAGE = "https://github.com/iotbzh/low-can-demo"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+SRC_URI = "gitsm://github.com/iotbzh/low-can-demo.git;protocol=https"
+SRCREV = "df5cf4027d1978bd3ac37d583e711f134dd4a406"
+
+PV = "4.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+# Run-time dependencies
+RDEPENDS_${PN} += " low-level-can-service"
+
+inherit cmake aglwgt
+
+AGLWGT_AUTOINSTALL_${PN} := "0"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
index c41c8962..2cf2b6e4 100755
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
@@ -51,6 +51,8 @@ AGL_APPS = " \
poiapp \
radio \
settings \
+ high-level-viwi-service \
+ low-can-demo \
"
RDEPENDS_${PN}_append = " \