summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2017-02-14 02:08:59 +0000
committerMatt Ranostay <matt.ranostay@konsulko.com>2017-02-14 18:36:59 +0000
commit030b1ed0255350ec266d0674e397b9ab2487c6bf (patch)
tree9eb92cba5212c0ed7462240674f4343840083f04
parent947ac6fbb51ab30082d4ded359fece6a94020243 (diff)
kernel: most: add mostcore module dependencies
Varies recipes depend on the mostcore module being built first. This patchset fixes a race condition that causes invalid module builds. Issue: SPEC-438 Change-Id: I045e88bc4aa31409937860a377bc43c25a194a2e Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
-rw-r--r--recipes-kernel/aim-cdev/aim-cdev.bb1
-rw-r--r--recipes-kernel/aim-network/aim-network.bb1
-rw-r--r--recipes-kernel/aim-sound/aim-sound.bb1
-rw-r--r--recipes-kernel/aim-v4l2/aim-v4l2.bb1
-rw-r--r--recipes-kernel/hdm-dim2/hdm-dim2.bb1
-rw-r--r--recipes-kernel/hdm-i2c/hdm-i2c.bb1
-rw-r--r--recipes-kernel/hdm-usb/hdm-usb.bb1
7 files changed, 7 insertions, 0 deletions
diff --git a/recipes-kernel/aim-cdev/aim-cdev.bb b/recipes-kernel/aim-cdev/aim-cdev.bb
index 09c24ce7..e8c101e9 100644
--- a/recipes-kernel/aim-cdev/aim-cdev.bb
+++ b/recipes-kernel/aim-cdev/aim-cdev.bb
@@ -1,6 +1,7 @@
DESCRIPTION = "Build character device driver for MOST"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+DEPENDS = " mostcore"
inherit module
diff --git a/recipes-kernel/aim-network/aim-network.bb b/recipes-kernel/aim-network/aim-network.bb
index b731f935..7ef192ce 100644
--- a/recipes-kernel/aim-network/aim-network.bb
+++ b/recipes-kernel/aim-network/aim-network.bb
@@ -1,6 +1,7 @@
DESCRIPTION = "Build networking driver for MOST"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+DEPENDS = " mostcore"
inherit module
diff --git a/recipes-kernel/aim-sound/aim-sound.bb b/recipes-kernel/aim-sound/aim-sound.bb
index ae8d7d8b..cb2b9836 100644
--- a/recipes-kernel/aim-sound/aim-sound.bb
+++ b/recipes-kernel/aim-sound/aim-sound.bb
@@ -1,6 +1,7 @@
DESCRIPTION = "Build ALSA driver for MOST"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+DEPENDS = " mostcore"
inherit module
diff --git a/recipes-kernel/aim-v4l2/aim-v4l2.bb b/recipes-kernel/aim-v4l2/aim-v4l2.bb
index 41dbf6db..5233eed9 100644
--- a/recipes-kernel/aim-v4l2/aim-v4l2.bb
+++ b/recipes-kernel/aim-v4l2/aim-v4l2.bb
@@ -1,6 +1,7 @@
DESCRIPTION = "Build V4L2 driver for MOST"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+DEPENDS = " mostcore"
inherit module
diff --git a/recipes-kernel/hdm-dim2/hdm-dim2.bb b/recipes-kernel/hdm-dim2/hdm-dim2.bb
index 6e156f1b..a9179299 100644
--- a/recipes-kernel/hdm-dim2/hdm-dim2.bb
+++ b/recipes-kernel/hdm-dim2/hdm-dim2.bb
@@ -1,6 +1,7 @@
DESCRIPTION = "Build DIM2 adapter driver for MOST"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+DEPENDS = " mostcore"
inherit module
diff --git a/recipes-kernel/hdm-i2c/hdm-i2c.bb b/recipes-kernel/hdm-i2c/hdm-i2c.bb
index e1e93ee0..90216ec2 100644
--- a/recipes-kernel/hdm-i2c/hdm-i2c.bb
+++ b/recipes-kernel/hdm-i2c/hdm-i2c.bb
@@ -1,6 +1,7 @@
DESCRIPTION = "Build I2C adapter driver for MOST"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+DEPENDS = " mostcore"
inherit module
diff --git a/recipes-kernel/hdm-usb/hdm-usb.bb b/recipes-kernel/hdm-usb/hdm-usb.bb
index 4c1ef8a6..df45e370 100644
--- a/recipes-kernel/hdm-usb/hdm-usb.bb
+++ b/recipes-kernel/hdm-usb/hdm-usb.bb
@@ -1,6 +1,7 @@
DESCRIPTION = "Build USB adapter driver for MOST"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+DEPENDS = " mostcore"
inherit module