summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-01-02 23:32:35 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-01-02 23:00:31 +0000
commit87f999160a602748a247ed1237634b24870d05b3 (patch)
treede79bacdfac72afd4353a20a2403881f22417a25
parent863b17a6fc1b2992b90feb62e5b70d325b39d2dd (diff)
Copy all Radio presets onto the target
Change-Id: I1d279901c901115f85a177ec086af837af3a5b82 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rw-r--r--recipes-demo-hmi/CES2017-demo/CES2017-demo.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb b/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
index 6c10650b..2567086a 100644
--- a/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
+++ b/recipes-demo-hmi/CES2017-demo/CES2017-demo.bb
@@ -16,7 +16,9 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad"
AGL_RADIO_PRESETS_LOCALE ?= "CES"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/AGL/DemoApps/CES2017;protocol=http \
- file://presets-${AGL_RADIO_PRESETS_LOCALE}.conf \
+ file://presets-ALS.conf \
+ file://presets-CES.conf \
+ file://presets-FOSDEM.conf \
"
SRCREV = "${AUTOREV}"
@@ -115,6 +117,9 @@ do_install() {
install -m 0644 ${B}/apps/Phone/phone.wgt ${D}/usr/AGL/apps/
install -m 0644 ${B}/apps/Radio/radio.wgt ${D}/usr/AGL/apps/
install -d ${D}/home/root/app-data/radio
+ install -m 0644 ${WORKDIR}/presets-CES.conf ${D}/home/root/app-data/radio/
+ install -m 0644 ${WORKDIR}/presets-ALS.conf ${D}/home/root/app-data/radio/
+ install -m 0644 ${WORKDIR}/presets-FOSDEM.conf ${D}/home/root/app-data/radio/
install -m 0644 ${WORKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}/home/root/app-data/radio/presets.conf
install -m 0755 ${B}/apps/installAllApps.sh ${D}/usr/AGL/apps/
@@ -151,6 +156,7 @@ do_install() {
FILES_${PN} += "/usr/AGL/ \
/usr/AGL/apps/* \
/usr/AGL/${PN}/* \
+ /home/root/app-data/radio/presets-*.conf \
/home/root/app-data/radio/presets.conf \
/usr/lib/qt5/qml/AGL/Demo/Controls/qmldir \
/usr/lib/qt5/qml/AGL/Demo/Controls/ImageButton.qml \